summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSpacingBat32020-09-03 19:51:49 +0200
committerSpacingBat32020-09-03 19:51:49 +0200
commit7a2e085ac5f4be47df4dc12e9b985b5186f79234 (patch)
treed433dc30cd8a94832f6cc4c1c7fea64d0df600ef
downloadaur-7a2e085ac5f4be47df4dc12e9b985b5186f79234.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD40
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0f9855e102f3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = funny-manpages-git
+ pkgdesc = A set of miscellaneous humorous manpages (don't take them too seriously!). Git master repo.
+ pkgver = r26.a3e0b08
+ pkgrel = 1
+ url = http://debian.org/
+ arch = any
+ license = custom
+ depends = man-db
+ depends = git
+ provides = funny-manpages
+ conflicts = funny-manpages
+ source = git+https://github.com/ltworf/funny-manpages.git
+ sha512sums = SKIP
+
+pkgname = funny-manpages-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3b04ba62fb5e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: Spacingbat3 <SpacingBat3 at github.com>
+# Contributor: Hyacinthe Cartiaux <hyacinthe.cartiaux at free.fr>
+# Contributor: Arkham <arkham at archlinux dot us>
+# Contributor: StaCk <proc.null at gmail dot com>
+
+pkgname=funny-manpages-git
+pkgver=r26.a3e0b08
+pkgrel=1
+pkgdesc="A set of miscellaneous humorous manpages (don't take them too seriously!). Git master repo."
+arch=('any')
+url="http://debian.org/"
+license=('custom')
+depends=('man-db' 'git')
+provides=('funny-manpages')
+conflicts=('funny-manpages')
+
+_gitname=funny-manpages
+
+source=("git+https://github.com/ltworf/funny-manpages.git")
+sha512sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$_gitname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $srcdir/$_gitname/man
+ for f in *.[0-57-9]fun ; do
+ mv $f ${f/.?fun/.6fun}
+ done
+}
+
+package() {
+ # Make installed files visible for pamac
+ for i in `ls -w0 $srcdir/$_gitname/man/*.6fun`; do
+ install -Dm644 "$i" "${pkgdir}/usr/share/man/man6/`basename $i`"
+ done
+ install -Dm644 "$srcdir/$_gitname/LICENSE" "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}