summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormusiclover2022-04-01 23:02:40 +0200
committermusiclover2022-04-01 23:02:40 +0200
commit496d884992e52b6d16bf852107279c17c3005e4d (patch)
tree5730e11da01aa0432efe77b215c9966713c3a8fd
downloadaur-496d884992e52b6d16bf852107279c17c3005e4d.tar.gz
Initial import
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD29
2 files changed, 48 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..77b658bbc61d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = furtherance-git
+ pkgdesc = Track your time without being tracked
+ pkgver = 1.0.8.r8.g1ff89ff
+ pkgrel = 1
+ url = https://github.com/lakoliu/Furtherance
+ arch = x86_64
+ license = GPL3
+ makedepends = git
+ makedepends = meson
+ makedepends = rust
+ depends = gtk4
+ depends = libadwaita
+ depends = sqlite
+ provides = furtherance
+ conflicts = furtherance
+ source = git+https://github.com/lakoliu/Furtherance.git
+ b2sums = SKIP
+
+pkgname = furtherance-git
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..65664e00b790
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,29 @@
+# Maintainer: musiclover <musiclover382@protonmail.com>
+
+pkgname=furtherance-git
+pkgver=1.0.8.r8.g1ff89ff
+pkgrel=1
+pkgdesc='Track your time without being tracked'
+arch=(x86_64)
+url=https://github.com/lakoliu/Furtherance
+license=(GPL3)
+depends=('gtk4' 'libadwaita' 'sqlite')
+makedepends=('git' 'meson' 'rust')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+source=(git+$url.git)
+b2sums=('SKIP')
+
+pkgver() {
+ cd Furtherance
+ git describe --long --tags | sed 's/^v//;s/\([^-]*-g\)/r\1/;s/-/./g'
+}
+
+build() {
+ arch-meson Furtherance build
+ meson compile -C build
+}
+
+package() {
+ DESTDIR="${pkgdir}" meson install -C build
+}