summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorluigoalma2019-04-17 20:06:01 +0100
committerluigoalma2019-04-17 20:06:01 +0100
commitbda6406da5ce1113d728f2c20d398b70473072b2 (patch)
treef2df3c650613ebafaa90385bd7d314bd77cafc6d
parent425463c79178c5d5fe9d5a0266c531874044f217 (diff)
downloadaur-bda6406da5ce1113d728f2c20d398b70473072b2.tar.gz
Moved to ninfs
-rw-r--r--.SRCINFO24
-rw-r--r--.gitignore2
-rw-r--r--Fuse3DSGUI.install6
-rw-r--r--Fuse3DSMoved.install7
-rw-r--r--PKGBUILD33
5 files changed, 19 insertions, 53 deletions
diff --git a/.SRCINFO b/.SRCINFO
index db280f4d6e4c..963d650988e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,14 @@
pkgbase = fuse-3ds
- pkgdesc = FUSE Filesystem Python scripts for Nintendo 3DS files
- pkgver = 1.3.1
+ pkgver = 1.4
pkgrel = 1
- url = https://github.com/ihaveamac/fuse-3ds
- arch = x86_64
+ url = https://github.com/ihaveamac/ninfs
+ arch = any
license = MIT
- makedepends = python-setuptools
- makedepends = python-pycryptodomex
- makedepends = unzip
- noextract = fuse-3ds-1.3.1-src.zip
- options = !strip
- source = fuse-3ds-1.3.1-src.zip::https://github.com/ihaveamac/fuse-3ds/releases/download/v1.3.1/fuse-3ds-1.3.1-src.zip
- sha256sums = 8243f64fdabb536b07e9a4fbf152a35e9350f58ae8c49938c115d607a46911d0
pkgname = fuse-3ds
- depends = python>=3.6.1
- depends = python-pycryptodomex
- depends = fuse2
+ install = Fuse3DSMoved.install
+ depends = ninfs
pkgname = fuse-3ds-gui
- install = Fuse3DSGUI.install
- depends = fuse-3ds=1.3.1-1
- depends = python-appjar
- depends = tk
+ depends = ninfs-gui
diff --git a/.gitignore b/.gitignore
index 1bd15bf08436..f589136862b5 100644
--- a/.gitignore
+++ b/.gitignore
@@ -5,5 +5,3 @@
!.SRCINFO
!.gitignore
!*.install
-!fuse3ds.desktop
-
diff --git a/Fuse3DSGUI.install b/Fuse3DSGUI.install
deleted file mode 100644
index 07afb2ebbafb..000000000000
--- a/Fuse3DSGUI.install
+++ /dev/null
@@ -1,6 +0,0 @@
-post_upgrade() {
- echo " >> You'll need the respective terminal for your DE for gui to open."
- echo " >> Mate for example uses xterm to open a terminal=true set .desktop."
- echo " >> XFCE uses xfce4-terminal."
- echo " >> Check what does your respective DE uses and install it."
-}
diff --git a/Fuse3DSMoved.install b/Fuse3DSMoved.install
new file mode 100644
index 000000000000..4df5b6a315aa
--- /dev/null
+++ b/Fuse3DSMoved.install
@@ -0,0 +1,7 @@
+post_upgrade() {
+ echo " >> fuse-3ds was renamed and moved to ninfs"
+ echo " >> This is just a stub package to redirect you to it."
+ echo " >> It will be deleted out of AUR in the future."
+ echo " >> For now, it serves as a small grace period to inform."
+ echo " >> You may uninstall fuse-3ds and fuse-3ds-gui packages."
+}
diff --git a/PKGBUILD b/PKGBUILD
index 9c2d3b6dce17..923cc23178cd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,37 +1,16 @@
pkgbase=fuse-3ds
pkgname=(fuse-3ds fuse-3ds-gui)
-pkgver=1.3.1
+pkgver=1.4
pkgrel=1
-pkgdesc="FUSE Filesystem Python scripts for Nintendo 3DS files"
-arch=($CARCH)
+arch=(any)
license=(MIT)
-url='https://github.com/ihaveamac/fuse-3ds'
-makedepends=('python-setuptools' 'python-pycryptodomex' 'unzip')
-options=(!strip)
-source=("fuse-3ds-${pkgver}-src.zip::https://github.com/ihaveamac/fuse-3ds/releases/download/v${pkgver}/fuse-3ds-${pkgver}-src.zip")
-sha256sums=('8243f64fdabb536b07e9a4fbf152a35e9350f58ae8c49938c115d607a46911d0')
-noextract=("fuse-3ds-${pkgver}-src.zip")
-
-build() {
- unzip "${srcdir}/fuse-3ds-${pkgver}-src.zip" -d "${srcdir}/fuse-3ds"
- cd "${srcdir}/fuse-3ds"
- python setup.py build
-}
+url='https://github.com/ihaveamac/ninfs'
package_fuse-3ds() {
- depends=("python>=3.6.1" "python-pycryptodomex" "fuse2")
- cd "${srcdir}/fuse-3ds"
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
- rm "$pkgdir/usr/bin/fuse3ds"
- rm -rf "$pkgdir/usr/share"
+ depends=("ninfs")
+ install="Fuse3DSMoved.install"
}
package_fuse-3ds-gui() {
- depends=("fuse-3ds=$pkgver-$pkgrel" "python-appjar" "tk")
- cd "${srcdir}/fuse-3ds"
- install="Fuse3DSGUI.install"
- python setup.py install --prefix=/usr --root="$pkgdir" --optimize=1
- rm "$pkgdir/usr/bin/mount_"*
- rm -r "$pkgdir/usr/lib"
- PYTHONPATH="$pkgdir/usr:$PYTHONPATH" python -mfuse3ds --install-desktop-entry "$pkgdir/usr/share"
+ depends=("ninfs-gui")
}