summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Grechkin2020-05-28 15:10:33 +0200
committerAndrew Grechkin2020-05-28 15:10:33 +0200
commit2d8d196df4ffa70cc440d17b5e324677dccfb88b (patch)
treebd9047ad1fd8930415278b3029f4d591f00d5543
downloadaur-2d8d196df4ffa70cc440d17b5e324677dccfb88b.tar.gz
Release v0.9.0
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD39
2 files changed, 54 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..b1806afe6d52
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fuse3-p7zip-git
+ pkgdesc = fuse3 file system that uses the p7zip library to mount archives
+ pkgver = 0.9.0
+ pkgrel = 1
+ url = https://github.com/andrew-grechkin/fuse3-p7zip
+ arch = x86_64
+ license = GPL
+ makedepends = cmake
+ depends = fuse3
+ depends = p7zip
+ source = git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=a9014b2348d8e1427d11be71cf0c109fc3198bd4
+ sha256sums = SKIP
+
+pkgname = fuse3-p7zip-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9e23efa3ddfd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+_name=fuse3-p7zip
+pkgname="$_name-git"
+pkgver=0.9.0
+pkgrel=1
+pkgdesc="fuse3 file system that uses the p7zip library to mount archives"
+arch=('x86_64')
+url="https://github.com/andrew-grechkin/fuse3-p7zip"
+license=('GPL')
+depends=('fuse3' 'p7zip')
+makedepends=('cmake')
+_commit=a9014b2348d8e1427d11be71cf0c109fc3198bd4
+source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=$_commit")
+sha256sums=('SKIP')
+
+prepare() {
+ cd "$_name"
+ git submodule update --init
+}
+
+pkgver() {
+ cd "$_name"
+ git describe --tags | sed 's/-/+/g'
+}
+
+build() {
+ cd "$_name"
+ mkdir -p build-release
+ pushd build-release
+ cmake .. \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr
+ popd
+ make -C build-release
+}
+
+package() {
+ cd "$_name"
+ make DESTDIR="$pkgdir" install -C build-release
+}