summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Grechkin2020-08-28 17:25:31 +0200
committerAndrew Grechkin2020-08-28 17:25:31 +0200
commit3462a0ebe9b716376458b87969f0435df6978b13 (patch)
treec07ddf527abec4d888ed0341d3cbdad95fd8385c
parent6b7199723f471b04947491fd9cddb2f67b743ac6 (diff)
downloadaur-3462a0ebe9b716376458b87969f0435df6978b13.tar.gz
release v1.0.0
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD9
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 35d2faa1c888..3ec2c8e1e562 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,15 @@
pkgbase = fuse3-p7zip-git
pkgdesc = fuse3 file system that uses the p7zip library to mount archives
- pkgver = 0.9.4
+ pkgver = 1.0.0
pkgrel = 1
url = https://github.com/andrew-grechkin/fuse3-p7zip
arch = x86_64
license = GPL
makedepends = cmake
+ makedepends = go-md2man
depends = fuse3
depends = p7zip
- source = git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=5d2a577b45f3b11458308ba7f3027e2420de7850
+ source = git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=08b07f2ada5e1090c4a99aea5f94a98d19bc9ae4
sha256sums = SKIP
pkgname = fuse3-p7zip-git
diff --git a/PKGBUILD b/PKGBUILD
index a39742d6bf48..7fdd26911522 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,15 +1,14 @@
_name=fuse3-p7zip
pkgname="$_name-git"
-pkgver=0.9.4
+pkgver=1.0.0
pkgrel=1
pkgdesc="fuse3 file system that uses the p7zip library to mount archives"
arch=('x86_64')
url="https://github.com/andrew-grechkin/fuse3-p7zip"
license=('GPL')
depends=('fuse3' 'p7zip')
-makedepends=('cmake')
-_commit=5d2a577b45f3b11458308ba7f3027e2420de7850
-source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=$_commit")
+makedepends=('cmake' 'go-md2man')
+source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=08b07f2ada5e1090c4a99aea5f94a98d19bc9ae4")
sha256sums=('SKIP')
prepare() {
@@ -29,9 +28,11 @@ build() {
-DCMAKE_INSTALL_PREFIX=/usr \
-S . -B "build-release"
make -j -C "build-release"
+ go-md2man -in=README.md -out="${_name}.1"
}
package() {
cd "$_name"
make DESTDIR="$pkgdir" install -C "build-release"
+ install -Dm644 "${_name}.1" "$pkgdir/usr/share/man/man1/${_name}.1"
}