summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndrew Grechkin2020-05-29 23:38:53 +0200
committerAndrew Grechkin2020-05-29 23:38:53 +0200
commit4228f12fa22173c3708d89ed232dafc458b666d3 (patch)
treee52a30d5c50e836786a48258d583dcc13b4690c0
parent2d8d196df4ffa70cc440d17b5e324677dccfb88b (diff)
downloadaur-4228f12fa22173c3708d89ed232dafc458b666d3.tar.gz
release v0.9.1
-rw-r--r--.SRCINFO4
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD16
3 files changed, 10 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b1806afe6d52..f26624ea169b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fuse3-p7zip-git
pkgdesc = fuse3 file system that uses the p7zip library to mount archives
- pkgver = 0.9.0
+ pkgver = 0.9.1
pkgrel = 1
url = https://github.com/andrew-grechkin/fuse3-p7zip
arch = x86_64
@@ -8,7 +8,7 @@ pkgbase = fuse3-p7zip-git
makedepends = cmake
depends = fuse3
depends = p7zip
- source = git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=a9014b2348d8e1427d11be71cf0c109fc3198bd4
+ source = git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=005bf44322becb74675de659ecf229c45c6e4ce9
sha256sums = SKIP
pkgname = fuse3-p7zip-git
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..7bc0f44ee062
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+fuse3-p7zip*
diff --git a/PKGBUILD b/PKGBUILD
index 9e23efa3ddfd..56352fe23f51 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
_name=fuse3-p7zip
pkgname="$_name-git"
-pkgver=0.9.0
+pkgver=0.9.1
pkgrel=1
pkgdesc="fuse3 file system that uses the p7zip library to mount archives"
arch=('x86_64')
@@ -8,7 +8,7 @@ url="https://github.com/andrew-grechkin/fuse3-p7zip"
license=('GPL')
depends=('fuse3' 'p7zip')
makedepends=('cmake')
-_commit=a9014b2348d8e1427d11be71cf0c109fc3198bd4
+_commit=005bf44322becb74675de659ecf229c45c6e4ce9
source=("git+https://github.com/andrew-grechkin/fuse3-p7zip#commit=$_commit")
sha256sums=('SKIP')
@@ -24,16 +24,14 @@ pkgver() {
build() {
cd "$_name"
- mkdir -p build-release
- pushd build-release
- cmake .. \
+ cmake \
-DCMAKE_BUILD_TYPE=Release \
- -DCMAKE_INSTALL_PREFIX=/usr
- popd
- make -C build-release
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -S . -B "build-release"
+ make -j -C "build-release"
}
package() {
cd "$_name"
- make DESTDIR="$pkgdir" install -C build-release
+ make DESTDIR="$pkgdir" install -C "build-release"
}