summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorV1oL3nc2020-05-06 01:50:29 +0200
committerV1oL3nc2020-05-06 01:50:29 +0200
commit673dfadf0a5234147d0e50a95eb84e1a3c7305e7 (patch)
tree32203a36ad58825a68001ffcc5ac6221521f8b03
downloadaur-673dfadf0a5234147d0e50a95eb84e1a3c7305e7.tar.gz
Init aur repo
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD35
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..816c3270da4b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fusion
+ pkgdesc = Simple wlan management tool with gnu-like syntax
+ pkgver = 0.1.0.1.g7508f79
+ pkgrel = 1
+ url = https://github.com/V1oL3nc/fusion
+ arch = x86_64
+ license = GPL
+ makedepends = cargo
+ makedepends = git
+ depends = networkmanager
+ provides = fusion
+ conflicts = fusion
+ source = fusion::git+https://github.com/V1oL3nc/fusion.git
+ sha256sums = SKIP
+
+pkgname = fusion
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..6a81ddaafd66
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: V1oL3nc <v1ol3nc@protonmail.com>
+pkgname='fusion'
+pkgver=0.1.0.1.g7508f79
+pkgrel=1
+arch=('x86_64')
+url="https://github.com/V1oL3nc/fusion"
+pkgdesc="Simple wlan management tool with gnu-like syntax"
+license=('GPL')
+depends=('networkmanager')
+makedepends=('cargo' 'git')
+checkdepends=()
+provides=('fusion')
+conflicts=('fusion')
+source=("$pkgname::git+https://github.com/V1oL3nc/fusion.git")
+sha256sums=('SKIP')
+
+prepare() {
+ cd $pkgname
+ echo "$(grep '^version =' Cargo.toml|head -n1|cut -d\" -f2|cut -d\- -f1).$(git rev-list --count HEAD).g$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "$pkgname"
+ env CARGO_INCREMENTAL=0 cargo build --release --locked
+}
+
+check() {
+ cd "$pkgname"
+ env CARGO_INCREMENTAL=0 cargo check
+}
+
+package() {
+ cd $pkgname
+ install -D -m755 "target/release/fusion" "$pkgdir/usr/bin/fusion"
+}