summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNovikov Maxim2017-08-17 13:08:42 +0300
committerNovikov Maxim2017-08-17 13:08:42 +0300
commitc59f4eb1843e1906973664971ce27cf6872fd367 (patch)
tree53821716ab229050dba741cb7ab9eeac88ac6f13
downloadaur-c59f4eb1843e1906973664971ce27cf6872fd367.tar.gz
init
-rw-r--r--.INSTALL4
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD53
-rw-r--r--agent.cfg118
4 files changed, 199 insertions, 0 deletions
diff --git a/.INSTALL b/.INSTALL
new file mode 100644
index 000000000000..1faedc5e7200
--- /dev/null
+++ b/.INSTALL
@@ -0,0 +1,4 @@
+post_install() {
+ cpan install UNIVERSAL::require
+ cpan install FusionInventory::Agent
+}
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..e14d3d8e7c8c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = fusioninventory-agent-bin
+ pkgdesc = An application for keeping track of the hardware and software
+ pkgver = 2.3.21
+ pkgrel = 2
+ url = http://fusioninventory.org
+ install = .INSTALL
+ arch = any
+ license = GPL
+ depends = perl>=5.8
+ depends = perl-module-build
+ depends = perl-file-which
+ depends = perl-libwww>=5.8
+ depends = perl-net-ip
+ depends = perl-text-template
+ depends = perl-data-structure-util
+ provides = fusioninventory-agent
+ conflicts = fusioninventory-agent
+ source = http://debian.fusioninventory.org/downloads/fusioninventory-agent_2.3.21-2_all.deb
+ source = agent.cfg
+ md5sums = 6ede95612470907f1964fa9f00732c4f
+ md5sums = eaf2c13c8adb7e57da038f3ae521ab35
+
+pkgname = fusioninventory-agent-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..fa3bb5cd3340
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,53 @@
+# Maintainer : Raphaël Doursenaud <rdoursenaud@gpcsolutions.fr>
+# Previous Maintainer : kuri <sysegv at gmail dot com>
+# Contributor : Kevin C <kiven at kiven dot fr>
+# Contributor: Alex 'AdUser' Z
+pkgname=fusioninventory-agent-bin
+_pkgname="FusionInventory-Agent"
+pkgver=2.3.21
+pkgrel=2
+pkgdesc="An application for keeping track of the hardware and software"
+arch=(any)
+url="http://fusioninventory.org"
+_watch="http://debian.fusioninventory.org/downloads"
+license=('GPL')
+provides=('fusioninventory-agent')
+conflicts=('fusioninventory-agent')
+install=.INSTALL
+depends=(
+ 'perl>=5.8'
+ 'perl-module-build'
+ 'perl-file-which'
+ # Provides LWP::UserAgent
+ 'perl-libwww>=5.8'
+ 'perl-net-ip'
+ 'perl-text-template'
+ #'perl-universal-require'
+ #'perl-xml-treepp>=0.26'
+ 'perl-data-structure-util'
+ #'perl-proc-daemon'
+)
+source=("http://debian.fusioninventory.org/downloads/fusioninventory-agent_${pkgver}-2_all.deb"
+ "agent.cfg"
+)
+md5sums=('6ede95612470907f1964fa9f00732c4f'
+ 'eaf2c13c8adb7e57da038f3ae521ab35'
+)
+
+
+package() {
+ tar xf ${srcdir}/data.tar.xz
+
+ # Clear
+ unlink ${srcdir}/control.tar.gz
+ unlink ${srcdir}/data.tar.xz
+ unlink ${srcdir}/debian-binary
+ unlink ${srcdir}/fusioninventory-agent_${pkgver}-2_all.deb
+
+ cp -a ${srcdir}/etc/ $pkgdir/etc/
+ cp -a ${srcdir}/usr/ $pkgdir/usr/
+ cp -a ${srcdir}/lib/ $pkgdir/usr/lib/
+ cp -a ${srcdir}/var/ $pkgdir/var/
+
+ install -D -m444 ${srcdir}/agent.cfg $pkgdir/etc/fusioninventory/agent.cfg.default
+}
diff --git a/agent.cfg b/agent.cfg
new file mode 100644
index 000000000000..2e9c50abb88a
--- /dev/null
+++ b/agent.cfg
@@ -0,0 +1,118 @@
+# fusioninventory agent configuration
+
+# all defined values match default
+# all commented values are examples
+
+
+#
+# Target definition options
+#
+
+# send tasks results to an OCS server
+#server = http://server.domain.com/ocsinventory
+# send tasks results to a FusionInventory for GLPI server
+#server = http://server.domain.com/glpi/plugins/fusioninventory/
+# write tasks results in a directory
+local = /tmp
+
+#
+# Task definition options
+#
+
+# disable software deployment tasks
+#no-task = deploy
+#tasks = inventory,deploy,inventory
+
+#
+# Target scheduling options
+#
+
+# maximum delay before first target, in seconds
+delaytime = 3600
+# do not contact the target before next scheduled time
+lazy = 0
+
+#
+# Inventory task specific options
+#
+
+# do not list local printers
+# no-category = printer
+# allow to scan user home directories
+scan-homedirs = 0
+# allow to scan user profiles
+scan-profiles = 0
+# save the inventory as HTML
+html = 0
+# timeout for inventory modules execution
+backend-collect-timeout = 30
+# always send data to server
+force = 0
+# additional inventory content file
+additional-content =
+
+#
+# Package deployment task specific options
+#
+
+# do not use peer to peer to download files
+no-p2p = 0
+
+#
+# Network options
+#
+
+# proxy address
+proxy =
+# user name for server authentication
+user = glpi
+# password for server authentication
+password = glpi
+# CA certificates directory
+ca-cert-dir =
+# CA certificates file
+ca-cert-file =
+# do not check server SSL certificate
+no-ssl-check = 0
+# connection timeout, in seconds
+timeout = 180
+
+#
+# Web interface options
+#
+
+# disable embedded web server
+no-httpd = 0
+# network interface to listen to
+httpd-ip =
+# network port to listen to
+httpd-port = 62354
+# trust requests without authentication token
+httpd-trust = 127.0.0.1/32
+
+#
+# Logging options
+#
+
+# Logger backend, either Stderr, File or Syslog (Stderr)
+logger = stderr
+# log file
+#logfile = /var/log/fusioninventory.log
+# maximum log file size, in MB
+#logfile-maxsize = 0
+# Syslog facility
+logfacility = LOG_USER
+# Use color in the console
+color = 0
+
+#
+# Execution mode options
+#
+
+# add given tag to inventory results
+tag =
+# debug mode
+debug = 2
+
+# time to wait to reload config (0 means no reload, it's default value)
+# conf-reload-interval = 0