summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMikael Blomstrand2019-05-28 01:58:14 +0200
committerMikael Blomstrand2019-05-28 01:58:14 +0200
commit36e1da034810befdb33b36da49ba5b2996335e5e (patch)
tree3eb207f1acb9a4d206a2a01799472007e48bd255
parentf8865f2f07bdd812bd62465f0edd115ccc3b3483 (diff)
downloadaur-36e1da034810befdb33b36da49ba5b2996335e5e.tar.gz
better pkgver function and new dependencies
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD30
2 files changed, 28 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 39bc99c28891..793b3f851d6d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,19 @@
pkgbase = futhark-nightly
pkgdesc = A data-parallel functional programming language
- pkgver = 0.99.r6719f9a
+ pkgver = 0.11.0.r03a6258
pkgrel = 1
- url = https://github.com/HIPERFIT/futhark
+ url = https://github.com/diku-dk/futhark
arch = x86_64
license = ISC
+ depends = ncurses5-compat-libs
+ depends = zlib
+ depends = gmp
+ optdepends = opencl-headers: opencl support
+ optdepends = ocl-icd: opencl support
+ optdepends = opencl-driver: opencl support
provides = futhark
conflicts = futhark
- source = https://futhark-lang.org/releases/futhark-nightly-linux-x86_64.tar.xz
+ source = futhark-nightly-0.11.0.r03a6258.tar.gz::https://futhark-lang.org/releases/futhark-nightly-linux-x86_64.tar.xz
sha256sums = SKIP
pkgname = futhark-nightly
diff --git a/PKGBUILD b/PKGBUILD
index a199c34cbf52..882e4235638e 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,33 @@
-# Maintainer: Olaf Leidinger <oleid@mescharet.de>
+# Maintainer: Mikael Blomstrand <mbloms ÅT kth DÖT se>
+# Contributor: Olaf Leidinger <oleid@mescharet.de>
+
pkgname=futhark-nightly
-pkgver=0.99.r6719f9a
+pkgver=0.11.0.r03a6258
pkgrel=1
pkgdesc="A data-parallel functional programming language"
arch=('x86_64')
-url="https://github.com/HIPERFIT/futhark"
+url="https://github.com/diku-dk/futhark"
license=('ISC')
-groups=()
-depends=()
-makedepends=()
+depends=('ncurses5-compat-libs'
+ 'zlib'
+ 'gmp')
+optdepends=('opencl-headers: opencl support'
+ 'ocl-icd: opencl support'
+ 'opencl-driver: opencl support')
+makedepends=()
provides=("${pkgname%-nightly}")
conflicts=("${pkgname%-nightly}")
-source=("https://futhark-lang.org/releases/futhark-nightly-linux-x86_64.tar.xz")
+source=("${pkgname}-${pkgver}.tar.gz::https://futhark-lang.org/releases/futhark-nightly-linux-x86_64.tar.xz")
sha256sums=(SKIP)
pkgver() {
- cd "futhark-nightly-linux-x86_64"
- printf "0.99.r%s" "$(cat commit-id)"
+ cd "${srcdir}/futhark-nightly-linux-x86_64"
+ printf "%s.r%s" "$(./bin/futhark -V | grep Futhark | sed "s/Futhark //")" "$(cat commit-id)"
}
package() {
- cd "$srcdir/futhark-nightly-linux-x86_64"
- make PREFIX="$pkgdir/usr" install
+ cd "${srcdir}/futhark-nightly-linux-x86_64"
+ make PREFIX="${pkgdir}/usr" install
+
+ install -Dm644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}