summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002022-07-23 20:54:36 +0200
committer0x9fff002022-07-23 20:54:36 +0200
commit71be35039a80d66f013dae424b6db8158a655a27 (patch)
tree0bc47aaabef283b2f76de98200ed09939cde8078
parent00b04335f72b98b0698945628f8f8ef72724f2a1 (diff)
downloadaur-71be35039a80d66f013dae424b6db8158a655a27.tar.gz
update to last commit with old build system
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD25
-rw-r--r--idevicerestore-0001-configure.ac-check-for-pthreads.patch10
-rw-r--r--idevicerestore-0002-ipsw-Update-to-reflect-color-macro-name-change-in-li.patch69
4 files changed, 101 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cf7a7c1f05ce..4aa46bde1a1e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,8 @@
pkgbase = futurerestore-m1stadev-git
pkgdesc = iOS upgrade and downgrade tool utilizing SHSH blobs - m1stadev's fork - git version
- pkgver = r199.f42719c5
+ pkgver = r278.ecc32003
pkgrel = 1
- url = https://github.com/m1stadev/futurerestore
+ url = https://github.com/futurerestore/futurerestore
arch = x86_64
license = LGPL3
makedepends = git
@@ -10,9 +10,10 @@ pkgbase = futurerestore-m1stadev-git
depends = img4tool
depends = libfragmentzip
depends = libgeneral
+ depends = libimobiledevice-glue
depends = libimobiledevice
- depends = libirecovery
- depends = libplist
+ depends = libirecovery-git
+ depends = libplist-git
depends = libzip
depends = openssl
depends = zlib
@@ -21,15 +22,17 @@ pkgbase = futurerestore-m1stadev-git
provides = futurerestore-marijuanarm-git
conflicts = futurerestore
replaces = futurerestore-marijuanarm-git
- source = git+https://github.com/m1stadev/futurerestore.git#branch=master
- source = git+https://github.com/DanTheMann15/tsschecker.git
- source = git+https://github.com/m1stadev/idevicerestore.git
+ source = git+https://github.com/futurerestore/futurerestore.git#commit=ecc32003b09a3afb27be80fd881cee9fcc0b5d49
+ source = git+https://github.com/futurerestore/idevicerestore.git
+ source = git+https://github.com/1Conan/tsschecker.git
source = git+https://github.com/tihmstar/jssy.git
source = idevicerestore-0001-configure.ac-check-for-pthreads.patch
+ source = idevicerestore-0002-ipsw-Update-to-reflect-color-macro-name-change-in-li.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
- sha256sums = 7a1ac46309eab59763186fdb91e456bd77f703b0fe59fec968e0001349c24d78
+ sha256sums = 3ba642f08b569bd91767a1c3bd74cc4dcf50f14c7253c4a5f20795acaafcf8f1
+ sha256sums = 7f01f292913d20df47254a776bab3cab385063d86b47420706bae42450e8b8f3
pkgname = futurerestore-m1stadev-git
diff --git a/PKGBUILD b/PKGBUILD
index 63480d3cbac5..7b286c1edaf4 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,27 +4,34 @@ _name=futurerestore
_fork=m1stadev
_forkpkgname=$_name-${_fork,,}
pkgname=$_forkpkgname-git
-pkgver=r199.f42719c5
+pkgver=r278.ecc32003
pkgrel=1
pkgdesc="iOS upgrade and downgrade tool utilizing SHSH blobs - m1stadev's fork - git version"
arch=('x86_64')
-url="https://github.com/$_fork/$_name"
+url="https://github.com/futurerestore/$_name"
license=('LGPL3')
-depends=('curl' 'img4tool' 'libfragmentzip' 'libgeneral' 'libimobiledevice' 'libirecovery' 'libplist' 'libzip' 'openssl' 'zlib')
+# depend on libirecovery-git because idevicerestore requires unreleased libirecovery 1.0.1
+# depend on libplist-git because idevicerestore requires unreleased libplist 70f4a422e01910cdb783aac81f13c11223c3acbd
+depends=('curl' 'img4tool' 'libfragmentzip' 'libgeneral' 'libimobiledevice-glue' 'libimobiledevice' 'libirecovery-git' 'libplist-git' 'libzip' 'openssl' 'zlib')
makedepends=('git')
provides=("$_name" "$_forkpkgname" 'futurerestore-marijuanarm-git')
conflicts=("$_name")
replaces=('futurerestore-marijuanarm-git')
-source=("git+$url.git#branch=master"
- 'git+https://github.com/DanTheMann15/tsschecker.git'
- 'git+https://github.com/m1stadev/idevicerestore.git'
+# use last commit with old build system
+# TODO update for new build system
+#source=("git+$url.git"
+source=("git+$url.git#commit=ecc32003b09a3afb27be80fd881cee9fcc0b5d49"
+ 'git+https://github.com/futurerestore/idevicerestore.git'
+ 'git+https://github.com/1Conan/tsschecker.git'
'git+https://github.com/tihmstar/jssy.git'
- 'idevicerestore-0001-configure.ac-check-for-pthreads.patch')
+ 'idevicerestore-0001-configure.ac-check-for-pthreads.patch'
+ 'idevicerestore-0002-ipsw-Update-to-reflect-color-macro-name-change-in-li.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
- '7a1ac46309eab59763186fdb91e456bd77f703b0fe59fec968e0001349c24d78')
+ '3ba642f08b569bd91767a1c3bd74cc4dcf50f14c7253c4a5f20795acaafcf8f1'
+ '7f01f292913d20df47254a776bab3cab385063d86b47420706bae42450e8b8f3')
pkgver() {
cd "$_name"
@@ -36,8 +43,8 @@ prepare() {
git submodule deinit -f --all
git submodule init
- git config submodule.external/tsschecker.url "$srcdir/tsschecker"
git config submodule.external/idevicerestore.url "$srcdir/idevicerestore"
+ git config submodule.external/tsschecker.url "$srcdir/tsschecker"
git submodule update
cd external/tsschecker
diff --git a/idevicerestore-0001-configure.ac-check-for-pthreads.patch b/idevicerestore-0001-configure.ac-check-for-pthreads.patch
index f6f23c1152eb..fe6388b02b55 100644
--- a/idevicerestore-0001-configure.ac-check-for-pthreads.patch
+++ b/idevicerestore-0001-configure.ac-check-for-pthreads.patch
@@ -1,7 +1,7 @@
-From ac0888125048f4f7ef8c44b1c9ebff57d3f371d0 Mon Sep 17 00:00:00 2001
+From 10724679eaae1c191730e5713429f0a611edba71 Mon Sep 17 00:00:00 2001
From: Ivan Shapovalov <intelfx100@gmail.com>
Date: Fri, 25 Sep 2015 23:37:27 +0300
-Subject: [PATCH] configure.ac: check for pthreads
+Subject: [PATCH 1/2] configure.ac: check for pthreads
Fixes building at least on Arch.
---
@@ -9,10 +9,10 @@ Fixes building at least on Arch.
1 file changed, 1 insertion(+)
diff --git a/configure.ac b/configure.ac
-index f17a95b..95834f2 100644
+index a0f2e30..ce0a7cd 100644
--- a/configure.ac
+++ b/configure.ac
-@@ -36,6 +36,7 @@ AM_PROG_CC_C_O
+@@ -38,6 +38,7 @@ AM_PROG_CC_C_O
AC_PROG_LIBTOOL
# Checks for libraries.
@@ -21,5 +21,5 @@ index f17a95b..95834f2 100644
PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= $LIBIMOBILEDEVICE_VERSION)
PKG_CHECK_MODULES(libplist, libplist-2.0 >= $LIBPLIST_VERSION)
--
-2.30.0
+2.37.1
diff --git a/idevicerestore-0002-ipsw-Update-to-reflect-color-macro-name-change-in-li.patch b/idevicerestore-0002-ipsw-Update-to-reflect-color-macro-name-change-in-li.patch
new file mode 100644
index 000000000000..608b44774d97
--- /dev/null
+++ b/idevicerestore-0002-ipsw-Update-to-reflect-color-macro-name-change-in-li.patch
@@ -0,0 +1,69 @@
+From 9ea93e0e1117d6acdbd3a7133fdb60914b9845b2 Mon Sep 17 00:00:00 2001
+From: Nikias Bassen <nikias@gmx.li>
+Date: Mon, 23 May 2022 02:50:55 +0200
+Subject: [PATCH 2/2] ipsw: Update to reflect color macro name change in
+ libimobiledevice-glue
+
+---
+ src/ipsw.c | 14 +++++++-------
+ 1 file changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/ipsw.c b/src/ipsw.c
+index f3b7f57..6887003 100644
+--- a/src/ipsw.c
++++ b/src/ipsw.c
+@@ -150,10 +150,10 @@ int ipsw_print_info(const char* path)
+ plist_get_string_val(val, &build_ver);
+ }
+
+- cprintf(COLOR_WHITE "Product Version: " COLOR_BRIGHT_YELLOW "%s" COLOR_RESET COLOR_WHITE " Build: " COLOR_BRIGHT_YELLOW "%s" COLOR_RESET "\n", prod_ver, build_ver);
++ cprintf(FG_WHITE "Product Version: " FG_BRIGHT_YELLOW "%s" COLOR_RESET FG_WHITE " Build: " FG_BRIGHT_YELLOW "%s" COLOR_RESET "\n", prod_ver, build_ver);
+ free(prod_ver);
+ free(build_ver);
+- cprintf(COLOR_WHITE "Supported Product Types:" COLOR_RESET);
++ cprintf(FG_WHITE "Supported Product Types:" COLOR_RESET);
+ val = plist_dict_get_item(manifest, "SupportedProductTypes");
+ if (val) {
+ plist_array_iter iter = NULL;
+@@ -165,7 +165,7 @@ int ipsw_print_info(const char* path)
+ if (item) {
+ char* item_str = NULL;
+ plist_get_string_val(item, &item_str);
+- cprintf(" " COLOR_BRIGHT_CYAN "%s" COLOR_RESET, item_str);
++ cprintf(" " FG_BRIGHT_CYAN "%s" COLOR_RESET, item_str);
+ free(item_str);
+ }
+ } while (item);
+@@ -174,7 +174,7 @@ int ipsw_print_info(const char* path)
+ }
+ cprintf("\n");
+
+- cprintf(COLOR_WHITE "Build Identities:" COLOR_RESET "\n");
++ cprintf(FG_WHITE "Build Identities:" COLOR_RESET "\n");
+
+ plist_t build_ids_grouped = plist_new_dict();
+
+@@ -230,7 +230,7 @@ int ipsw_print_info(const char* path)
+ group_no++;
+ node = plist_dict_get_item(group, "RestoreBehavior");
+ plist_get_string_val(node, &rbehavior);
+- cprintf(" " COLOR_WHITE "[%d] Variant: " COLOR_BRIGHT_CYAN "%s" COLOR_WHITE " Behavior: " COLOR_BRIGHT_CYAN "%s" COLOR_RESET "\n", group_no, key, rbehavior);
++ cprintf(" " FG_WHITE "[%d] Variant: " FG_BRIGHT_CYAN "%s" FG_WHITE " Behavior: " FG_BRIGHT_CYAN "%s" COLOR_RESET "\n", group_no, key, rbehavior);
+ free(key);
+ free(rbehavior);
+
+@@ -283,9 +283,9 @@ int ipsw_print_info(const char* path)
+
+ irecv_device_t irecvdev = NULL;
+ if (irecv_devices_get_device_by_hardware_model(hwmodel, &irecvdev) == 0) {
+- cprintf(" ChipID: " COLOR_GREEN "%04x" COLOR_RESET " BoardID: " COLOR_GREEN "%02x" COLOR_RESET " Model: " COLOR_YELLOW "%-8s" COLOR_RESET " " COLOR_MAGENTA "%s" COLOR_RESET "\n", (int)chip_id, (int)board_id, hwmodel, irecvdev->display_name);
++ cprintf(" ChipID: " FG_GREEN "%04x" COLOR_RESET " BoardID: " FG_GREEN "%02x" COLOR_RESET " Model: " FG_YELLOW "%-8s" COLOR_RESET " " FG_MAGENTA "%s" COLOR_RESET "\n", (int)chip_id, (int)board_id, hwmodel, irecvdev->display_name);
+ } else {
+- cprintf(" ChipID: " COLOR_GREEN "%04x" COLOR_RESET " BoardID: " COLOR_GREEN "%02x" COLOR_RESET " Model: " COLOR_YELLOW "%s" COLOR_RESET "\n", (int)chip_id, (int)board_id, hwmodel);
++ cprintf(" ChipID: " FG_GREEN "%04x" COLOR_RESET " BoardID: " FG_GREEN "%02x" COLOR_RESET " Model: " FG_YELLOW "%s" COLOR_RESET "\n", (int)chip_id, (int)board_id, hwmodel);
+ }
+ free(hwmodel);
+ } while (build_id);
+--
+2.37.1
+