summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002021-01-31 20:23:29 +0100
committer0x9fff002021-01-31 20:23:29 +0100
commitf589924a020797b55438505b8a57e24be9298ee8 (patch)
treed89adf8af0a742deb2c21d084a846f0b363489f7
downloadaur-f589924a020797b55438505b8a57e24be9298ee8.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--.gitignore31
-rw-r--r--.gitignore_append5
-rw-r--r--PKGBUILD71
-rw-r--r--futurerestore-0001-Ensure-CUSTOM_LOGGING-refers-to-a-file.patch25
-rw-r--r--idevicerestore-0001-configure.ac-check-for-pthreads.patch25
6 files changed, 193 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1e3f6d24e86d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = futurerestore-marijuanarm-git
+ pkgdesc = iOS upgrade and downgrade tool utilizing SHSH blobs - git version
+ pkgver = r190.e4a8178
+ pkgrel = 1
+ url = https://github.com/marijuanARM/futurerestore
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ depends = libplist
+ depends = libzip
+ depends = libimobiledevice
+ depends = libfragmentzip
+ depends = libirecovery
+ depends = curl
+ depends = openssl
+ depends = zlib
+ depends = img4tool
+ depends = libgeneral
+ provides = futurerestore
+ provides = futurerestore-marijuanarm
+ conflicts = futurerestore
+ source = git+https://github.com/marijuanARM/futurerestore.git
+ source = git+https://github.com/tihmstar/tsschecker.git
+ source = git+https://github.com/marijuanARM/idevicerestore.git
+ source = git+https://github.com/tihmstar/jssy.git
+ source = futurerestore-0001-Ensure-CUSTOM_LOGGING-refers-to-a-file.patch
+ source = idevicerestore-0001-configure.ac-check-for-pthreads.patch
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = SKIP
+ sha256sums = 6b50f455cfa5a60fcb77d9db55ce48186774b5cf9c5f04ad5fc911b8df7e047e
+ sha256sums = 7a1ac46309eab59763186fdb91e456bd77f703b0fe59fec968e0001349c24d78
+
+pkgname = futurerestore-marijuanarm-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..6d11fee725fe
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,31 @@
+*.tar
+*.tar.*
+*.jar
+*.exe
+*.msi
+*.zip
+*.tgz
+*.log
+*.log.*
+*.sig
+
+pkg/
+src/
+*~
+
+# temporary files which can be created if a process still has a handle open of a deleted file
+.fuse_hidden*
+
+# KDE directory preferences
+.directory
+
+# Linux trash folder which might appear on any partition or disk
+.Trash-*
+
+# .nfs files are created when an open file is removed but is still being accessed
+.nfs*
+# archlinuxpackages linux
+futurerestore
+tsschecker
+idevicerestore
+jssy
diff --git a/.gitignore_append b/.gitignore_append
new file mode 100644
index 000000000000..d52ef6bd2ace
--- /dev/null
+++ b/.gitignore_append
@@ -0,0 +1,5 @@
+# archlinuxpackages linux
+futurerestore
+tsschecker
+idevicerestore
+jssy
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a2e8d7155079
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,71 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+
+_name=futurerestore
+_forkname=$_name-marijuanarm
+pkgname=$_forkname-git
+pkgver=r190.e4a8178
+pkgrel=1
+pkgdesc='iOS upgrade and downgrade tool utilizing SHSH blobs - git version'
+arch=('x86_64')
+url="https://github.com/marijuanARM/$_name"
+license=('LGPL3')
+depends=('libplist' 'libzip' 'libimobiledevice' 'libfragmentzip' 'libirecovery' 'curl' 'openssl' 'zlib' 'img4tool' 'libgeneral')
+makedepends=('git')
+provides=("$_name" "$_forkname")
+conflicts=("$_name")
+source=("git+$url.git"
+ 'git+https://github.com/tihmstar/tsschecker.git'
+ 'git+https://github.com/marijuanARM/idevicerestore.git'
+ 'git+https://github.com/tihmstar/jssy.git'
+ "$_name-0001-Ensure-CUSTOM_LOGGING-refers-to-a-file.patch"
+ 'idevicerestore-0001-configure.ac-check-for-pthreads.patch')
+sha256sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ '6b50f455cfa5a60fcb77d9db55ce48186774b5cf9c5f04ad5fc911b8df7e047e'
+ '7a1ac46309eab59763186fdb91e456bd77f703b0fe59fec968e0001349c24d78')
+
+pkgver() {
+ cd "$_name"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_name"
+
+ git submodule deinit -f --all
+ git submodule init
+ git config submodule.external/tsschecker.url "$srcdir/tsschecker"
+ git config submodule.external/idevicerestore.url "$srcdir/idevicerestore"
+ git submodule update
+
+ for p in "$srcdir"/$_name-*.patch; do
+ patch -Np1 -i "$p"
+ done
+
+ cd external/tsschecker
+ git submodule init
+ git config submodule.external/jssy.url "$srcdir/jssy"
+ git submodule update
+ cd ../..
+
+ cd external/idevicerestore
+ for p in "$srcdir"/idevicerestore-*.patch; do
+ patch -Np1 -i "$p"
+ done
+ cd ../..
+}
+
+build() {
+ cd "$_name"
+
+ ./autogen.sh --prefix=/usr
+ make
+}
+
+package() {
+ cd "$_name"
+
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/futurerestore-0001-Ensure-CUSTOM_LOGGING-refers-to-a-file.patch b/futurerestore-0001-Ensure-CUSTOM_LOGGING-refers-to-a-file.patch
new file mode 100644
index 000000000000..7cc69a2c9041
--- /dev/null
+++ b/futurerestore-0001-Ensure-CUSTOM_LOGGING-refers-to-a-file.patch
@@ -0,0 +1,25 @@
+From fef20213adbe78bd90c5b7bda7473d501211aa0c Mon Sep 17 00:00:00 2001
+From: 0x9fff00 <0x9fff00+git@protonmail.ch>
+Date: Sun, 31 Jan 2021 19:25:38 +0100
+Subject: [PATCH] Ensure CUSTOM_LOGGING refers to a file
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index f7ce087..c225130 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -81,7 +81,7 @@ else
+ fi
+ AM_CONDITIONAL([HAVE_LIBIPATCHER],[test "x$do_libipatcher" = "xyes"])
+
+-AC_DEFINE(CUSTOM_LOGGING, 1, [required for futurerestore])
++AC_DEFINE(CUSTOM_LOGGING, "/dev/null", [required for futurerestore])
+
+ LT_INIT
+
+--
+2.30.0
+
diff --git a/idevicerestore-0001-configure.ac-check-for-pthreads.patch b/idevicerestore-0001-configure.ac-check-for-pthreads.patch
new file mode 100644
index 000000000000..f6f23c1152eb
--- /dev/null
+++ b/idevicerestore-0001-configure.ac-check-for-pthreads.patch
@@ -0,0 +1,25 @@
+From ac0888125048f4f7ef8c44b1c9ebff57d3f371d0 Mon Sep 17 00:00:00 2001
+From: Ivan Shapovalov <intelfx100@gmail.com>
+Date: Fri, 25 Sep 2015 23:37:27 +0300
+Subject: [PATCH] configure.ac: check for pthreads
+
+Fixes building at least on Arch.
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/configure.ac b/configure.ac
+index f17a95b..95834f2 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -36,6 +36,7 @@ AM_PROG_CC_C_O
+ AC_PROG_LIBTOOL
+
+ # Checks for libraries.
++AC_SEARCH_LIBS([pthread_create], [pthread])
+ PKG_CHECK_MODULES(libirecovery, libirecovery-1.0 >= $LIBIRECOVERY_VERSION)
+ PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= $LIBIMOBILEDEVICE_VERSION)
+ PKG_CHECK_MODULES(libplist, libplist-2.0 >= $LIBPLIST_VERSION)
+--
+2.30.0
+