summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002019-02-16 18:21:24 +0100
committer0x9fff002019-02-16 18:22:56 +0100
commit46cb9da74caa4ce643c2c9705e250a50ef06e28f (patch)
tree7bed5135cf941a2807959fb4113a11b2f38d684d
downloadaur-46cb9da74caa4ce643c2c9705e250a50ef06e28f.tar.gz
Initial commit
-rw-r--r--.SRCINFO36
-rw-r--r--PKGBUILD65
-rw-r--r--check_for_pthreads.patch12
3 files changed, 113 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8b2188bf7620
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,36 @@
+pkgbase = futurerestore-s0uthwest-git
+ pkgdesc = iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version
+ pkgver = r231.546c759
+ pkgrel = 1
+ url = https://github.com/s0uthwest/futurerestore
+ arch = x86_64
+ license = LGPL3
+ makedepends = git
+ depends = libplist
+ depends = libzip
+ depends = libimobiledevice
+ depends = libfragmentzip
+ depends = libirecovery
+ depends = libusbmuxd
+ depends = curl
+ depends = openssl
+ depends = zlib
+ depends = lzfse
+ provides = futurerestore
+ provides = futurerestore-s0uthwest
+ conflicts = futurerestore
+ source = git+https://github.com/s0uthwest/futurerestore.git
+ source = git+https://github.com/s0uthwest/img4tool.git
+ source = git+https://github.com/s0uthwest/tsschecker.git
+ source = git+https://github.com/s0uthwest/idevicerestore.git
+ source = git+https://github.com/tihmstar/jssy.git
+ source = check_for_pthreads.patch
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = SKIP
+ sha512sums = a9594bdc7fe465fe6e63cef1f9e6300fd79c37800431c718ebf37b4786f0ee3ecc76a61b9dd654200f2be059d87922baccddc475527c5b56491e99d9aa38f609
+
+pkgname = futurerestore-s0uthwest-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ac9275df8a8b
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,65 @@
+# Maintainer: 0x9fff00 <0x9fff00+git@protonmail.ch>
+pkgname=futurerestore-s0uthwest-git
+_pkgname=futurerestore
+pkgver=r231.546c759
+pkgrel=1
+pkgdesc="iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version"
+arch=('x86_64')
+url="https://github.com/s0uthwest/futurerestore"
+license=('LGPL3')
+depends=('libplist' 'libzip' 'libimobiledevice' 'libfragmentzip' 'libirecovery' 'libusbmuxd' 'curl' 'openssl' 'zlib' 'lzfse')
+makedepends=('git')
+provides=('futurerestore' 'futurerestore-s0uthwest')
+conflicts=('futurerestore')
+source=('git+https://github.com/s0uthwest/futurerestore.git'
+ 'git+https://github.com/s0uthwest/img4tool.git'
+ 'git+https://github.com/s0uthwest/tsschecker.git'
+ 'git+https://github.com/s0uthwest/idevicerestore.git'
+ 'git+https://github.com/tihmstar/jssy.git'
+ 'check_for_pthreads.patch')
+sha512sums=('SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
+ 'a9594bdc7fe465fe6e63cef1f9e6300fd79c37800431c718ebf37b4786f0ee3ecc76a61b9dd654200f2be059d87922baccddc475527c5b56491e99d9aa38f609')
+
+pkgver() {
+ cd "$_pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+prepare() {
+ cd "$_pkgname"
+
+ git submodule deinit -f --all
+ git submodule init
+ git config submodule.external/img4tool.url "$srcdir/img4tool"
+ git config submodule.external/tsschecker.url "$srcdir/tsschecker"
+ git config submodule.external/idevicerestore.url "$srcdir/idevicerestore"
+ git submodule update
+
+ cd external/idevicerestore
+ patch -Np1 -i "$srcdir/check_for_pthreads.patch"
+ cd ../..
+
+ cd external/tsschecker
+ git submodule init
+ git config submodule.external/jssy.url "$srcdir/jssy"
+ git submodule update
+ cd ../..
+}
+
+build() {
+ cd "$_pkgname"
+
+ CFLAGS+=' -DIDEVICERESTORE_NOMAIN=1 -DIMG4TOOL_NOMAIN=1 -DTSSCHECKER_NOMAIN=1'
+ ./autogen.sh --prefix=/usr
+ make V=1
+}
+
+package() {
+ cd "$_pkgname"
+
+ make DESTDIR="$pkgdir/" install
+}
diff --git a/check_for_pthreads.patch b/check_for_pthreads.patch
new file mode 100644
index 000000000000..900b3642ebd5
--- /dev/null
+++ b/check_for_pthreads.patch
@@ -0,0 +1,12 @@
+diff --git a/configure.ac b/configure.ac
+index d189087..55aea17 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -19,6 +19,7 @@ AM_PROG_CC_C_O
+ AC_PROG_LIBTOOL
+
+ # Checks for libraries.
++AC_SEARCH_LIBS([pthread_create], [pthread])
+ PKG_CHECK_MODULES(libirecovery, libirecovery >= 0.2.0)
+ PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= 1.2.1)
+ PKG_CHECK_MODULES(libplist, libplist >= 1.0)