summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002019-02-17 15:40:14 +0100
committer0x9fff002019-02-17 15:40:14 +0100
commit57ced118210c964db4eb8e781b01b9bbaad91c32 (patch)
treedb3b2c067085fb306a62ce21648cce67574f8a6c
parentb750a077674b6eea8643c93ae86aea1126758a93 (diff)
downloadaur-57ced118210c964db4eb8e781b01b9bbaad91c32.tar.gz
Add patch to revert 07a40245037b4d255e2142bb49d29c91336a317f
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD12
-rw-r--r--idevicerestore-0001-configure.ac-check-for-pthreads.patch (renamed from check_for_pthreads.patch)13
-rw-r--r--idevicerestore-0002-Revert-img4-fix-ubuntu-compiling.patch48
4 files changed, 74 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8b2188bf7620..fec5a3592603 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = futurerestore-s0uthwest-git
pkgdesc = iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version
pkgver = r231.546c759
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/s0uthwest/futurerestore
arch = x86_64
license = LGPL3
@@ -24,13 +24,15 @@ pkgbase = futurerestore-s0uthwest-git
source = git+https://github.com/s0uthwest/tsschecker.git
source = git+https://github.com/s0uthwest/idevicerestore.git
source = git+https://github.com/tihmstar/jssy.git
- source = check_for_pthreads.patch
+ source = idevicerestore-0001-configure.ac-check-for-pthreads.patch
+ source = idevicerestore-0002-Revert-img4-fix-ubuntu-compiling.patch
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = a9594bdc7fe465fe6e63cef1f9e6300fd79c37800431c718ebf37b4786f0ee3ecc76a61b9dd654200f2be059d87922baccddc475527c5b56491e99d9aa38f609
+ sha512sums = 99635fba451f1bfa0864cb4b2ccee76c49413c66ec08a975cdb4432d564cbc4824be96999fe5adbec9cf90b41f5ba00e71fd45088e173e66af75d5722ad7e587
+ sha512sums = f840c0897da1b11e5f43b09d784b57757f8de68edf021f5a9230ccbf392acabe1b1e574a4156d7cef86976c3f38ca04b9ad2d52f72c08c94e4105720780edd0d
pkgname = futurerestore-s0uthwest-git
diff --git a/PKGBUILD b/PKGBUILD
index 64233a4bfc65..e8e3defdbe01 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=futurerestore-s0uthwest-git
_pkgname=futurerestore
pkgver=r231.546c759
-pkgrel=1
+pkgrel=2
pkgdesc="iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version"
arch=('x86_64')
url="https://github.com/s0uthwest/futurerestore"
@@ -16,13 +16,15 @@ source=('git+https://github.com/s0uthwest/futurerestore.git'
'git+https://github.com/s0uthwest/tsschecker.git'
'git+https://github.com/s0uthwest/idevicerestore.git'
'git+https://github.com/tihmstar/jssy.git'
- 'check_for_pthreads.patch')
+ 'idevicerestore-0001-configure.ac-check-for-pthreads.patch'
+ 'idevicerestore-0002-Revert-img4-fix-ubuntu-compiling.patch')
sha512sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
- 'a9594bdc7fe465fe6e63cef1f9e6300fd79c37800431c718ebf37b4786f0ee3ecc76a61b9dd654200f2be059d87922baccddc475527c5b56491e99d9aa38f609')
+ '99635fba451f1bfa0864cb4b2ccee76c49413c66ec08a975cdb4432d564cbc4824be96999fe5adbec9cf90b41f5ba00e71fd45088e173e66af75d5722ad7e587'
+ 'f840c0897da1b11e5f43b09d784b57757f8de68edf021f5a9230ccbf392acabe1b1e574a4156d7cef86976c3f38ca04b9ad2d52f72c08c94e4105720780edd0d')
pkgver() {
cd "$_pkgname"
@@ -40,7 +42,9 @@ prepare() {
git submodule update
cd external/idevicerestore
- patch -Np1 -i "$srcdir/check_for_pthreads.patch"
+ for p in "$srcdir"/idevicerestore-*.patch; do
+ patch -Np1 -i "$p"
+ done
cd ../..
cd external/tsschecker
diff --git a/check_for_pthreads.patch b/idevicerestore-0001-configure.ac-check-for-pthreads.patch
index 900b3642ebd5..58c92c185663 100644
--- a/check_for_pthreads.patch
+++ b/idevicerestore-0001-configure.ac-check-for-pthreads.patch
@@ -1,3 +1,13 @@
+From f79c08e7b63b96cc8328729b7f87e94133de65ab Mon Sep 17 00:00:00 2001
+From: Ivan Shapovalov <intelfx100@gmail.com>
+Date: Fri, 25 Sep 2015 23:37:27 +0300
+Subject: [PATCH 1/2] configure.ac: check for pthreads
+
+Fixes building at least on Arch.
+---
+ configure.ac | 1 +
+ 1 file changed, 1 insertion(+)
+
diff --git a/configure.ac b/configure.ac
index d189087..55aea17 100644
--- a/configure.ac
@@ -10,3 +20,6 @@ index d189087..55aea17 100644
PKG_CHECK_MODULES(libirecovery, libirecovery >= 0.2.0)
PKG_CHECK_MODULES(libimobiledevice, libimobiledevice-1.0 >= 1.2.1)
PKG_CHECK_MODULES(libplist, libplist >= 1.0)
+--
+2.20.1
+
diff --git a/idevicerestore-0002-Revert-img4-fix-ubuntu-compiling.patch b/idevicerestore-0002-Revert-img4-fix-ubuntu-compiling.patch
new file mode 100644
index 000000000000..6610d6de1c9c
--- /dev/null
+++ b/idevicerestore-0002-Revert-img4-fix-ubuntu-compiling.patch
@@ -0,0 +1,48 @@
+From d1c43cc5d9a9722addbd20db6599a4c568963f24 Mon Sep 17 00:00:00 2001
+From: 0x9fff00 <0x9fff00+git@protonmail.ch>
+Date: Sun, 17 Feb 2019 14:58:52 +0100
+Subject: [PATCH 2/2] Revert "img4: fix ubuntu compiling"
+
+This reverts commit 07a40245037b4d255e2142bb49d29c91336a317f.
+
+This caused the restore to get stuck at "Waiting for device...".
+---
+ src/img4.c | 4 +---
+ src/img4.h | 2 +-
+ 2 files changed, 2 insertions(+), 4 deletions(-)
+
+diff --git a/src/img4.c b/src/img4.c
+index 8ca5baa..db33f15 100644
+--- a/src/img4.c
++++ b/src/img4.c
+@@ -123,8 +123,7 @@ static const unsigned char *asn1_find_element(unsigned int index, unsigned char
+ }
+
+ // find the element we are searching
+- int i = 0;
+- while (i <= index, i++) {
++ for (int i = 0; i <= index; i++) {
+ off += asn1_get_element(&data[off], &el_type, &el_size);
+ if (i == index)
+ break;
+@@ -174,7 +173,6 @@ int img4_stitch_component(const char* component_name, const unsigned char* compo
+
+ // create element header for the "IMG4" magic
+ asn1_create_element_header(ASN1_IA5_STRING, IMG4_MAGIC_SIZE, &magic_header, &magic_header_size);
+-
+ // create element header for the blob (ApImg4Ticket)
+ asn1_create_element_header(ASN1_CONTEXT_SPECIFIC|ASN1_CONSTRUCTED, blob_size, &blob_header, &blob_header_size);
+
+diff --git a/src/img4.h b/src/img4.h
+index 005ead3..b83f1ca 100644
+--- a/src/img4.h
++++ b/src/img4.h
+@@ -32,4 +32,4 @@ int img4_stitch_component(const char* component_name, const unsigned char* compo
+ }
+ #endif
+
+-#endif /* idevicerestore_img4_h */
++#endif
+--
+2.20.1
+