summarylogtreecommitdiffstats
diff options
context:
space:
mode:
author0x9fff002020-02-08 19:03:56 +0100
committer0x9fff002020-02-08 19:03:56 +0100
commitbdbf95e757626465108ea16d2ce75eb3cf8f1b3e (patch)
treefb64211845396a58261646e05feb5932e3aac062
parent8dd0441b65173c0812b029459d6745919430a89b (diff)
downloadaur-bdbf95e757626465108ea16d2ce75eb3cf8f1b3e.tar.gz
Add patches
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD19
-rw-r--r--img4tool-0001-Include-arpa-inet.h-header.patch24
-rw-r--r--tsschecker-0001-Fix-incorrect-language-standard.patch25
4 files changed, 70 insertions, 4 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 443f9d323d45..ad9405040e0d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = futurerestore-s0uthwest-git
pkgdesc = iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version
pkgver = r248.08d0e00
- pkgrel = 5
+ pkgrel = 6
url = https://github.com/s0uthwest/futurerestore
arch = x86_64
license = LGPL3
@@ -23,12 +23,16 @@ pkgbase = futurerestore-s0uthwest-git
source = git+https://github.com/tihmstar/tsschecker.git
source = git+https://github.com/s0uthwest/idevicerestore.git
source = git+https://github.com/tihmstar/jssy.git
+ source = img4tool-0001-Include-arpa-inet.h-header.patch
+ source = tsschecker-0001-Fix-incorrect-language-standard.patch
source = idevicerestore-0001-configure.ac-check-for-pthreads.patch
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
sha256sums = SKIP
+ sha256sums = bd9c4dc74f56a26d9aef10938fe0fb58cdec268a80a04b217dd4a32c5b60db2d
+ sha256sums = 3fcde7558ae9f5ebfa930a2b02074251a6817e2a984c8d0e18113baa0ea708a5
sha256sums = 621e0e9bd2a31d8be8da59c051d2190a98be0f5c4cd5158225ffd4ff91d3ab1e
pkgname = futurerestore-s0uthwest-git
diff --git a/PKGBUILD b/PKGBUILD
index 31296d40fd3a..13bc6650d70f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@ _name=futurerestore
_forkname=$_name-s0uthwest
pkgname=$_forkname-git
pkgver=r248.08d0e00
-pkgrel=5
+pkgrel=6
pkgdesc="iOS upgrade and downgrade tool utilizing SHSH blobs - s0uthwest's fork - git version"
arch=('x86_64')
url="https://github.com/s0uthwest/$_name"
@@ -18,12 +18,16 @@ source=("git+$url.git"
'git+https://github.com/tihmstar/tsschecker.git'
'git+https://github.com/s0uthwest/idevicerestore.git'
'git+https://github.com/tihmstar/jssy.git'
+ 'img4tool-0001-Include-arpa-inet.h-header.patch'
+ 'tsschecker-0001-Fix-incorrect-language-standard.patch'
'idevicerestore-0001-configure.ac-check-for-pthreads.patch')
sha256sums=('SKIP'
'SKIP'
'SKIP'
'SKIP'
'SKIP'
+ 'bd9c4dc74f56a26d9aef10938fe0fb58cdec268a80a04b217dd4a32c5b60db2d'
+ '3fcde7558ae9f5ebfa930a2b02074251a6817e2a984c8d0e18113baa0ea708a5'
'621e0e9bd2a31d8be8da59c051d2190a98be0f5c4cd5158225ffd4ff91d3ab1e')
pkgver() {
@@ -41,8 +45,8 @@ prepare() {
git config submodule.external/idevicerestore.url "$srcdir/idevicerestore"
git submodule update
- cd external/idevicerestore
- for p in "$srcdir"/idevicerestore-*.patch; do
+ cd external/img4tool
+ for p in "$srcdir"/img4tool-*.patch; do
patch -Np1 -i "$p"
done
cd ../..
@@ -51,6 +55,15 @@ prepare() {
git submodule init
git config submodule.external/jssy.url "$srcdir/jssy"
git submodule update
+ for p in "$srcdir"/tsschecker-*.patch; do
+ patch -Np1 -i "$p"
+ done
+ cd ../..
+
+ cd external/idevicerestore
+ for p in "$srcdir"/idevicerestore-*.patch; do
+ patch -Np1 -i "$p"
+ done
cd ../..
}
diff --git a/img4tool-0001-Include-arpa-inet.h-header.patch b/img4tool-0001-Include-arpa-inet.h-header.patch
new file mode 100644
index 000000000000..e8a8dd0ddae1
--- /dev/null
+++ b/img4tool-0001-Include-arpa-inet.h-header.patch
@@ -0,0 +1,24 @@
+From 8d891ada1d15c17ed677cd6a08bbea9fa337af15 Mon Sep 17 00:00:00 2001
+From: 0x9fff00 <0x9fff00+git@protonmail.ch>
+Date: Sat, 8 Feb 2020 18:57:30 +0100
+Subject: [PATCH] Include arpa/inet.h header
+
+---
+ img4tool/lzssdec.c | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/img4tool/lzssdec.c b/img4tool/lzssdec.c
+index 4f16784..bd19e60 100644
+--- a/img4tool/lzssdec.c
++++ b/img4tool/lzssdec.c
+@@ -9,6 +9,7 @@
+ #include <string.h>
+ #include <stdlib.h>
+ #include <sys/types.h>
++#include <arpa/inet.h>
+
+ #include "lzssdec.h"
+
+--
+2.25.0
+
diff --git a/tsschecker-0001-Fix-incorrect-language-standard.patch b/tsschecker-0001-Fix-incorrect-language-standard.patch
new file mode 100644
index 000000000000..1ba2be4ebf88
--- /dev/null
+++ b/tsschecker-0001-Fix-incorrect-language-standard.patch
@@ -0,0 +1,25 @@
+From fea67caa58f492b86fbab298e3329dbf5ff835fb Mon Sep 17 00:00:00 2001
+From: 0x9fff00 <0x9fff00+git@protonmail.ch>
+Date: Sat, 8 Feb 2020 18:22:55 +0100
+Subject: [PATCH] Fix incorrect language standard
+
+---
+ configure.ac | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/configure.ac b/configure.ac
+index 4d8ca11..e9e2384 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -15,7 +15,7 @@ esac
+
+ # Checks for programs.
+ AC_PROG_CC
+-CFLAGS+=" -std=c11"
++CFLAGS+=" -std=gnu11"
+ AC_PROG_INSTALL
+ AC_PROG_LIBTOOL
+ AC_CONFIG_MACRO_DIRS([m4])
+--
+2.25.0
+