summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcaltlgin2020-08-08 06:25:08 +1200
committercaltlgin2020-08-08 06:25:08 +1200
commit3a7ce9dc9eb4a0ca897e398a6d08ea1060976d37 (patch)
treebc5521e374a9a48031928168d2b8b88b340084c2
parent9ea635ac1d94aed0f3c5c5a83e8031fe37f72959 (diff)
downloadaur-3a7ce9dc9eb4a0ca897e398a6d08ea1060976d37.tar.gz
Add aarch64, examples, man pages, docs
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD39
2 files changed, 27 insertions, 24 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 90f08d2f1ea8..abf422280e81 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,14 +1,14 @@
pkgbase = fuzzylite
- pkgdesc = A Fuzzy Logic Control Library in C++
+ pkgdesc = C++ fuzzy logic control library
pkgver = 6.0
- pkgrel = 1
- url = https://www.fuzzylite.com
- arch = i686
+ pkgrel = 2
+ url = https://github.com/fuzzylite/fuzzylite
arch = x86_64
+ arch = aarch64
license = GPL3
makedepends = cmake
- makedepends = git
- source = https://github.com/fuzzylite/fuzzylite/archive/v6.0.tar.gz
+ options = zipman
+ source = fuzzylite-6.0.tar.gz::https://github.com/fuzzylite/fuzzylite/archive/v6.0.tar.gz
sha256sums = 7e9f56deb9baf063de2232bfd8285f57ddccb651dae842fe3f587d0ac65ecdb0
pkgname = fuzzylite
diff --git a/PKGBUILD b/PKGBUILD
index 427093b0dd6f..cb28bf850a99 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,31 +1,34 @@
-# Maintainer: Sandy Carter <bwrsandman+aur@gmail.com>
+# Maintainer: Caltlgin Stsodaat <contact@fossdaily.xyz>
+# Contributor: Sandy Carter <bwrsandman+aur@gmail.com>
pkgname=fuzzylite
pkgver=6.0
-pkgrel=1
-pkgdesc="A Fuzzy Logic Control Library in C++"
-arch=('i686' 'x86_64')
-url="https://www.fuzzylite.com"
+pkgrel=2
+pkgdesc='C++ fuzzy logic control library'
+arch=('x86_64' 'aarch64')
+url='https://github.com/fuzzylite/fuzzylite'
license=('GPL3')
-depends=()
-makedepends=('cmake' 'git')
-optdepends=()
-provides=()
-conflicts=()
-source=("https://github.com/fuzzylite/fuzzylite/archive/v${pkgver}.tar.gz")
+makedepends=('cmake')
+options=('zipman')
+source=("${pkgname}-${pkgver}.tar.gz::${url}/archive/v${pkgver}.tar.gz")
sha256sums=('7e9f56deb9baf063de2232bfd8285f57ddccb651dae842fe3f587d0ac65ecdb0')
build() {
- cd "${srcdir}/${pkgname}-6.0/${pkgname}"
- cmake \
+ export CFLAGS+=" ${CPPFLAGS}"
+ export CXXFLAGS+=" ${CPPFLAGS}"
+ cmake -B build -S "${pkgname}-${pkgver}/${pkgname}" \
+ -DCMAKE_BUILD_TYPE='None' \
-DCMAKE_INSTALL_PREFIX='/usr' \
- -DCMAKE_BUILD_TYPE='Release'
- make
+ -Wno-dev
+ make -C build
}
package() {
- cd "${srcdir}/${pkgname}-6.0/${pkgname}"
- make DESTDIR="$pkgdir" install
+ make DESTDIR="${pkgdir}" PREFIX="/usr" -C build install
+ cd "${pkgname}-${pkgver}"
+ install -Dm644 -t "${pkgdir}/usr/share/doc/${pkgname}" 'README.md'
+ install -Dm644 -t "${pkgdir}/usr/share/man/man1" "${pkgname}/${pkgname}.1"
+ cp -r 'examples' "${pkgdir}/usr/share/doc/${pkgname}"
}
-# vim:set ts=2 sw=2 et:
+# vim: ts=2 sw=2 et: