summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSandy Carter2017-09-10 10:34:05 -0700
committerSandy Carter2017-09-10 10:34:05 -0700
commit9ea635ac1d94aed0f3c5c5a83e8031fe37f72959 (patch)
tree8bdc8da751b5fab8bb2a454bd6661fd440462bae
downloadaur-9ea635ac1d94aed0f3c5c5a83e8031fe37f72959.tar.gz
initial package
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD31
2 files changed, 46 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..90f08d2f1ea8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+pkgbase = fuzzylite
+ pkgdesc = A Fuzzy Logic Control Library in C++
+ pkgver = 6.0
+ pkgrel = 1
+ url = https://www.fuzzylite.com
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = cmake
+ makedepends = git
+ source = https://github.com/fuzzylite/fuzzylite/archive/v6.0.tar.gz
+ sha256sums = 7e9f56deb9baf063de2232bfd8285f57ddccb651dae842fe3f587d0ac65ecdb0
+
+pkgname = fuzzylite
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..427093b0dd6f
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Sandy Carter <bwrsandman+aur@gmail.com>
+
+pkgname=fuzzylite
+pkgver=6.0
+pkgrel=1
+pkgdesc="A Fuzzy Logic Control Library in C++"
+arch=('i686' 'x86_64')
+url="https://www.fuzzylite.com"
+license=('GPL3')
+depends=()
+makedepends=('cmake' 'git')
+optdepends=()
+provides=()
+conflicts=()
+source=("https://github.com/fuzzylite/fuzzylite/archive/v${pkgver}.tar.gz")
+sha256sums=('7e9f56deb9baf063de2232bfd8285f57ddccb651dae842fe3f587d0ac65ecdb0')
+
+build() {
+ cd "${srcdir}/${pkgname}-6.0/${pkgname}"
+ cmake \
+ -DCMAKE_INSTALL_PREFIX='/usr' \
+ -DCMAKE_BUILD_TYPE='Release'
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-6.0/${pkgname}"
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et: