summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChinmay Dalal2021-09-12 18:59:17 +0530
committerChinmay Dalal2021-09-12 18:59:17 +0530
commit3b306f5d29e4e8145dfde4a9cb741f60b8370bb1 (patch)
tree7c9a19dd12cb906427a3f6379bda259383e9585c
downloadaur-3b306f5d29e4e8145dfde4a9cb741f60b8370bb1.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD27
2 files changed, 44 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4a0b5a892f83
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = fvim-bin
+ pkgdesc = Cross platform Neovim front-end UI, built with F# + Avalonia
+ pkgver = 0.3.433_gf48ac0e
+ pkgrel = 1
+ url = https://github.com/yatli/fvim
+ arch = x86_64
+ license = MIT
+ makedepends = rpmextract
+ depends = neovim
+ depends = ttf-dejavu
+ provides = fvim
+ conflicts = fvim
+ options = staticlibs
+ source = https://github.com/yatli/fvim/releases/download/v0.3.433%2Bgf48ac0e/fvim-linux-x86_64.rpm
+ md5sums = SKIP
+
+pkgname = fvim-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..02e3b9e3ccf2
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: Chinmay Dalal <w5vwg64uy@relay.firefox.com>
+pkgname=fvim-bin
+pkgver=0.3.433_gf48ac0e
+_pkgver=$(echo "${pkgver}" | sed -e "s/_/-/g")
+pkgrel=1
+pkgdesc="Cross platform Neovim front-end UI, built with F# + Avalonia"
+arch=('x86_64')
+url="https://github.com/yatli/fvim"
+license=('MIT')
+groups=()
+depends=('neovim' 'ttf-dejavu')
+makedepends=('rpmextract')
+optdepends=()
+provides=('fvim')
+conflicts=('fvim')
+source=("https://github.com/yatli/fvim/releases/download/v0.3.433%2Bgf48ac0e/fvim-linux-x86_64.rpm")
+md5sums=('SKIP')
+arch=('x86_64')
+options=('staticlibs')
+
+package() {
+ cd $srcdir
+ for i in *.rpm; do
+ rpmextract.sh "$i"
+ done
+ cp -r "$srcdir/usr" "$pkgdir"
+}