summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Rojas2021-05-08 08:42:50 +0000
committerAntonio Rojas2021-05-08 08:42:50 +0000
commit4b4fe86cba9e218cc9e573c75a8878deeeffed93 (patch)
treefa6c71dfa5912e1344a65004cb59bb28fdd1a4b7
downloadaur-4b4fe86cba9e218cc9e573c75a8878deeeffed93.tar.gz
Dropped from repos
-rw-r--r--.SRCINFO28
-rw-r--r--PKGBUILD31
-rw-r--r--fvwm.desktop7
3 files changed, 66 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5ce839ce17cb
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,28 @@
+pkgbase = fvwm
+ pkgdesc = A multiple large virtual desktop window manager originally derived from twm
+ pkgver = 2.6.9
+ pkgrel = 3
+ url = http://www.fvwm.org
+ arch = x86_64
+ license = GPL
+ license = custom
+ makedepends = libxslt
+ depends = fribidi
+ depends = perl
+ depends = libstroke
+ depends = libxpm
+ depends = librsvg
+ depends = libxinerama
+ depends = libxcursor
+ depends = python-xdg
+ optdepends = perl-tk: for ClickToFocus support
+ optdepends = perl-x11-protocol: for ClickToFocus support
+ options = !emptydirs
+ options = !makeflags
+ source = https://github.com/fvwmorg/fvwm/releases/download/2.6.9/fvwm-2.6.9.tar.gz
+ source = fvwm.desktop
+ sha256sums = 1bc64cf3ccd0073008758168327a8265b8059def9b239b451d6b9fab2cc391ae
+ sha256sums = 51d345f995f57c6d881d48bf535f71d75041a9bf1f0fa41dd99e1b22fd66aaf3
+
+pkgname = fvwm
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..046c71cd6b8d
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: Eric BĂ©langer <eric@archlinux.org>
+
+pkgname=fvwm
+pkgver=2.6.9
+pkgrel=3
+pkgdesc="A multiple large virtual desktop window manager originally derived from twm"
+arch=('x86_64')
+url="http://www.fvwm.org"
+license=('GPL' 'custom')
+depends=('fribidi' 'perl' 'libstroke' 'libxpm' 'librsvg' 'libxinerama' 'libxcursor' 'python-xdg')
+makedepends=('libxslt')
+optdepends=('perl-tk: for ClickToFocus support'
+ 'perl-x11-protocol: for ClickToFocus support')
+options=('!emptydirs' '!makeflags')
+source=(https://github.com/fvwmorg/fvwm/releases/download/${pkgver}/fvwm-${pkgver}.tar.gz fvwm.desktop)
+sha256sums=('1bc64cf3ccd0073008758168327a8265b8059def9b239b451d6b9fab2cc391ae'
+ '51d345f995f57c6d881d48bf535f71d75041a9bf1f0fa41dd99e1b22fd66aaf3')
+
+build() {
+ cd ${pkgname}-${pkgver}
+ ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --with-stroke-library --enable-mandoc
+ make
+}
+
+package() {
+ cd ${pkgname}-${pkgver}
+ make DESTDIR="${pkgdir}" install
+ install -d "${pkgdir}/usr/share/doc/fvwm"
+ install -D -m644 ../fvwm.desktop "${pkgdir}/usr/share/xsessions/fvwm.desktop"
+ install -D -m644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"
+}
diff --git a/fvwm.desktop b/fvwm.desktop
new file mode 100644
index 000000000000..e297a6109b70
--- /dev/null
+++ b/fvwm.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Encoding=UTF-8
+Name=FVWM
+Comment=The fvwm window manager
+Type=XSession
+Exec=/usr/bin/fvwm
+TryExec=/usr/bin/fvwm