summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlquidfire2024-05-12 20:48:35 +0200
committerlquidfire2024-05-12 20:48:35 +0200
commit8cfaed6f7cc9a5e1c482e662aa14a5131c2899fb (patch)
treed59b79f9e387b616776e277c32e1115644affee2
parent5a9031c4110777ad9ee11b9aa5ab6552bfb41f48 (diff)
downloadaur-8cfaed6f7cc9a5e1c482e662aa14a5131c2899fb.tar.gz
upgpkg: fvwm 2.7.0-3
Added CFLAGS to allow configure on GCC 14.1+
-rw-r--r--PKGBUILD5
1 files changed, 4 insertions, 1 deletions
diff --git a/PKGBUILD b/PKGBUILD
index e325cbeed941..ac4e05c70add 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,12 +13,15 @@ makedepends=('libxslt')
optdepends=('perl-tk: for ClickToFocus support'
'perl-x11-protocol: for ClickToFocus support')
options=('buildflags' '!emptydirs' '!makeflags')
-source=(https://github.com/fvwmorg/fvwm/releases/download/${pkgver}/fvwm-${pkgver}.tar.gz fvwm.desktop)
+source=(https://github.com/fvwmorg/fvwm/releases/download/${pkgver}/fvwm-${pkgver}.tar.gz
+ fvwm.desktop)
sha256sums=('66826dd60b774447170037d9078fd43e75f7230a49acfb84a988eebce7e3418b'
'51d345f995f57c6d881d48bf535f71d75041a9bf1f0fa41dd99e1b22fd66aaf3')
build() {
cd ${pkgname}-${pkgver}
+ # 2 CFLAGS Wno-error were added to allow building FVWM with GCC 14.1+.
+ # Cf.: https://bbs.archlinux.org/viewtopic.php?pid=2170711
CFLAGS="$CFLAGS -Wno-error=int-conversion -Wno-error=incompatible-pointer-types" ./configure --prefix=/usr --sysconfdir=/etc --libexecdir=/usr/lib --with-stroke-library --enable-mandoc
make
}