summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 05:32:14 -0600
committerBrian Bidulock2015-06-10 05:32:14 -0600
commitc8a5c318626b75ce2d073e34456265d0fc760af4 (patch)
tree4efb8234756fc83f4f23a8167ddc1cdcef05d63d
downloadaur-c8a5c318626b75ce2d073e34456265d0fc760af4.tar.gz
initial version
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
-rw-r--r--fvwm-xdg-menu.install13
3 files changed, 55 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..596d63b3fb69
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fvwm-xdg-menu
+ pkgdesc = XDG application menu with full support for FVWM
+ pkgver = r51
+ pkgrel = 1
+ url = http://github.com/domichel/fvwm-xdg-menu
+ install = fvwm-xdg-menu.install
+ arch = any
+ groups = xde
+ license = GPL2
+ makedepends = git
+ depends = gtk-update-icon-cache
+ source = fvwm-xdg-menu::git://github.com/domichel/fvwm-xdg-menu.git#commit=4b49473
+ md5sums = SKIP
+
+pkgname = fvwm-xdg-menu
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c685f78d5102
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+#Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgdesc="XDG application menu with full support for FVWM"
+pkgname=fvwm-xdg-menu
+pkgver=r51
+pkgrel=1
+arch=(any)
+license=(GPL2)
+url="http://github.com/domichel/$pkgname"
+groups=('xde')
+depends=('gtk-update-icon-cache')
+source=("$pkgname::git://github.com/domichel/$pkgname.git#commit=4b49473")
+md5sums=('SKIP')
+makedepends=('git')
+install=$pkgname.install
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+# vim: et sw=2:
diff --git a/fvwm-xdg-menu.install b/fvwm-xdg-menu.install
new file mode 100644
index 000000000000..b71c437554b1
--- /dev/null
+++ b/fvwm-xdg-menu.install
@@ -0,0 +1,13 @@
+update_icon_cache() {
+ gtk-update-icon-cache usr/share/icons/hicolor
+ gtk-update-icon-cache usr/share/icons/FVWM_Xdg
+}
+post_install() {
+ update_icon_cache
+}
+post_upgrade() {
+ update_icon_cache
+}
+post_remove() {
+ update_icon_cache
+}