summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorBrian Bidulock2015-06-10 05:33:00 -0600
committerBrian Bidulock2015-06-10 05:33:00 -0600
commit5d49040c01d9b33c9313990b159ccb92b58eb079 (patch)
treed16433806249a41cee2f9590497001e65abd3d09
downloadaur-5d49040c01d9b33c9313990b159ccb92b58eb079.tar.gz
initial version
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD34
-rw-r--r--fvwm-xdg-menu.install13
3 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6da465943dad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = fvwm-xdg-menu-git
+ pkgdesc = XDG application menu with full support for FVWM
+ pkgver = r51.g4b49473
+ pkgrel = 1
+ url = http://github.com/domichel/fvwm-xdg-menu
+ install = fvwm-xdg-menu.install
+ arch = any
+ groups = xde
+ license = GPL2
+ makedepends = git
+ depends = gtk-update-icon-cache
+ provides = fvwm-xdg-menu
+ conflicts = fvwm-xdg-menu
+ source = fvwm-xdg-menu-git::git://github.com/domichel/fvwm-xdg-menu.git
+ md5sums = SKIP
+
+pkgname = fvwm-xdg-menu-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..b029a5764e76
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,34 @@
+#Maintainer: Brian Bidulock <bidulock@openss7.org>
+pkgdesc="XDG application menu with full support for FVWM"
+pkgname=fvwm-xdg-menu-git
+_pkgname=fvwm-xdg-menu
+pkgver=r51.g4b49473
+pkgrel=1
+arch=(any)
+license=(GPL2)
+url="http://github.com/domichel/$_pkgname"
+groups=('xde')
+depends=('gtk-update-icon-cache')
+conflicts=($_pkgname)
+provides=($_pkgname)
+source=("$pkgname::git://github.com/domichel/$_pkgname.git")
+md5sums=('SKIP')
+makedepends=('git')
+install=$_pkgname.install
+
+pkgver() {
+ cd $pkgname
+ printf "r%s.g%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd $pkgname
+ make
+}
+
+package() {
+ cd $pkgname
+ make DESTDIR="$pkgdir" PREFIX=/usr install
+}
+
+# vim: et sw=2:
diff --git a/fvwm-xdg-menu.install b/fvwm-xdg-menu.install
new file mode 100644
index 000000000000..b71c437554b1
--- /dev/null
+++ b/fvwm-xdg-menu.install
@@ -0,0 +1,13 @@
+update_icon_cache() {
+ gtk-update-icon-cache usr/share/icons/hicolor
+ gtk-update-icon-cache usr/share/icons/FVWM_Xdg
+}
+post_install() {
+ update_icon_cache
+}
+post_upgrade() {
+ update_icon_cache
+}
+post_remove() {
+ update_icon_cache
+}