summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPhillip Smith2015-06-09 09:53:25 +1000
committerPhillip Smith2015-06-09 09:53:25 +1000
commit4f23cccae035d1f8ad40d842742f261c44c72269 (patch)
treebab34891988237935d0dd736c9218b5bee44ac20
downloadaur-4f23cccae035d1f8ad40d842742f261c44c72269.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD51
-rw-r--r--fwlogwatch38
-rw-r--r--fwlogwatch.conf4
5 files changed, 116 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..52e9f6b51f2b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = fwlogwatch
+ pkgdesc = A packet filter/firewall/IDS log analyzer
+ pkgver = 1.4
+ pkgrel = 1
+ url = http://fwlogwatch.inside-security.de/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = zlib>=1.0.9
+ backup = etc/conf.d/fwlogwatch
+ source = http://fwlogwatch.inside-security.de/sw/fwlogwatch-1.4.tar.gz
+ source = fwlogwatch
+ source = fwlogwatch.conf
+ md5sums = b76bad368ea311677dabb0618ec6c8cf
+ md5sums = e10d41244780c74280d27794ca6a6525
+ md5sums = 35dc2f301904b2b03ef688e2e2edae53
+
+pkgname = fwlogwatch
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..0e34430b5f57
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+/fwlogwatch-*.pkg.tar.xz
+/fwlogwatch-*.tar.gz
+/pkg/
+/src/
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..88535ee7b86e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,51 @@
+# Maintainer: Phillip Smith <fukawi2@NO-SPAM.gmail.com>
+# http://github.com/fukawi2/aur-packages
+# Contributor: Sven Schulz <omee@archlinux.de>
+# Contributor: dorphell <dorphell@archlinux.org>
+# Contributor: Moritz Alexander Esser <Moritz.Esser@rwth-aachen.de>
+
+### I AM ONLY THE PACKAGER, NOT THE DEVELOPER
+### Please ask support questions about this software in one of:
+### 1) The AUR comments; OR
+### 2) Upstream forums/maillist etc; OR
+### 3) The ArchLinux forums
+### I do not always know enough about the software itself, or don't have the
+### time to promptly respond to direct emails.
+### If you have found a problem with the package/PKGBUILD (as opposed to
+### the software) then please do email me or post an AUR comment.
+
+pkgname=fwlogwatch
+pkgver=1.4
+pkgrel=1
+pkgdesc="A packet filter/firewall/IDS log analyzer"
+arch=('i686' 'x86_64')
+depends=('zlib>=1.0.9')
+backup=(etc/conf.d/fwlogwatch)
+url="http://fwlogwatch.inside-security.de/"
+license=('GPL')
+source=("http://fwlogwatch.inside-security.de/sw/$pkgname-$pkgver.tar.gz"
+ 'fwlogwatch'
+ 'fwlogwatch.conf')
+md5sums=('b76bad368ea311677dabb0618ec6c8cf'
+ 'e10d41244780c74280d27794ca6a6525'
+ '35dc2f301904b2b03ef688e2e2edae53')
+
+build() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ make
+}
+
+package() {
+ cd "$srcdir"/$pkgname-$pkgver
+
+ mkdir -p "$pkgdir"/{etc,usr/{sbin,share/man/man8}}
+ mkdir -p "$pkgdir"/usr/share/locale/{de,ja,pt,sv,zh_CN,zh_TW}/LC_MESSAGES
+
+ make INSTALL_DIR="$pkgdir"/usr install
+ make CONF_DIR="$pkgdir"/etc install-config
+ make LOCALE_DIR="$pkgdir"/usr install-i18n
+
+ install -D -m755 "$srcdir"/fwlogwatch "$pkgdir"/etc/rc.d/fwlogwatch
+ install -D -m644 "$srcdir"/fwlogwatch.conf "$pkgdir"/etc/conf.d/fwlogwatch
+}
diff --git a/fwlogwatch b/fwlogwatch
new file mode 100644
index 000000000000..0afbecffe358
--- /dev/null
+++ b/fwlogwatch
@@ -0,0 +1,38 @@
+#!/bin/bash
+
+# source application-specific settings
+[ -f /etc/conf.d/fwlogwatch ] && . /etc/conf.d/fwlogwatch
+
+. /etc/rc.conf
+. /etc/rc.d/functions
+
+PID=`pidof -o %PPID /usr/sbin/fwlogwatch`
+case "$1" in
+ start)
+ stat_busy "Starting fwlogwatch"
+ [ -z "$PID" ] && /usr/sbin/fwlogwatch ${ARGS}
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ add_daemon fwlogwatch
+ stat_done
+ fi
+ ;;
+ stop)
+ stat_busy "Stopping fwlogwatch"
+ [ ! -z "$PID" ] && kill $PID &> /dev/null
+ if [ $? -gt 0 ]; then
+ stat_fail
+ else
+ rm_daemon fwlogwatch
+ stat_done
+ fi
+ ;;
+ restart)
+ $0 stop
+ $0 start
+ ;;
+ *)
+ echo "usage: `basename $0` {start|stop|restart}"
+esac
+exit 0
diff --git a/fwlogwatch.conf b/fwlogwatch.conf
new file mode 100644
index 000000000000..41d2fdd27ff3
--- /dev/null
+++ b/fwlogwatch.conf
@@ -0,0 +1,4 @@
+#
+# Parameters to be passed to fwlogwatch
+#
+ARGS="-R -A -X -Pn"