summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302015-06-17 15:34:32 +0200
committerM0Rf302015-06-17 15:34:32 +0200
commit1f647b5a87063e0370431c24e901a2c5b75ee8f5 (patch)
tree22f88bd51fcf6e7689373f1af851b8821f5c813a
downloadaur-1f647b5a87063e0370431c24e901a2c5b75ee8f5.tar.gz
Initial import
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD31
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eedeff8bd45a
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = fwts-git
+ pkgdesc = The FirmWare Test Suite is a tool to do automatic testing of a PC's firmware
+ pkgver = 2325.c519fe0
+ pkgrel = 1
+ url = http://smackerelofopinion.blogspot.com/2010/08/firmware-test-suite-biosacpi-health.html
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = git
+ depends = pcre
+ depends = json-c
+ source = fwts::git://kernel.ubuntu.com/hwe/fwts.git
+ md5sums = SKIP
+
+pkgname = fwts-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..035fd1588dbd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,31 @@
+# Maintainer: M0Rf30
+
+pkgname=fwts-git
+pkgver=2325.c519fe0
+pkgrel=1
+pkgdesc="The FirmWare Test Suite is a tool to do automatic testing of a PC's firmware"
+arch=('i686' 'x86_64')
+url="http://smackerelofopinion.blogspot.com/2010/08/firmware-test-suite-biosacpi-health.html"
+license=('GPL')
+depends=('pcre' 'json-c')
+makedepends=('git')
+source=('fwts::git://kernel.ubuntu.com/hwe/fwts.git')
+
+build() {
+ cd fwts
+ autoreconf -ivf
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd fwts
+ make DESTDIR=$pkgdir install
+}
+
+pkgver() {
+ cd fwts
+ echo $(git rev-list --count master).$(git rev-parse --short master)
+}
+
+md5sums=('SKIP')