summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorM0Rf302021-03-22 22:37:23 +0100
committerM0Rf302021-03-22 22:37:23 +0100
commitad1c972977650903c4472a09e2eb7dbd93e562b5 (patch)
tree323e056d6ffc48d10134c5feb6fac155ac712321
parent13e3f17181a38a3ee717f459885c65fa0d999983 (diff)
downloadaur-ad1c972977650903c4472a09e2eb7dbd93e562b5.tar.gz
fwts-git: update
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD26
2 files changed, 20 insertions, 14 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 903f5aad0a42..7b40b2d056ea 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,15 +1,19 @@
pkgbase = fwts-git
pkgdesc = The FirmWare Test Suite is a tool to do automatic testing of a PC's firmware
- pkgver = 4604.2b14ce46
+ pkgver = 21.02.00.r7.3ba26885
pkgrel = 1
url = http://smackerelofopinion.blogspot.com/2010/08/firmware-test-suite-biosacpi-health.html
arch = i686
arch = x86_64
license = GPL
makedepends = git
+ depends = dtc
+ depends = libbsd
depends = pcre
depends = json-c
- source = fwts::git://kernel.ubuntu.com/hwe/fwts.git
+ provides = fwts
+ conflicts = fwts
+ source = fwts-git::git://kernel.ubuntu.com/hwe/fwts.git
md5sums = SKIP
pkgname = fwts-git
diff --git a/PKGBUILD b/PKGBUILD
index 6ae71ac5a602..0e77c820ae0f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,32 +2,34 @@
# Contributor: brikler
pkgname=fwts-git
-pkgver=4604.2b14ce46
+pkgver=21.02.00.r7.3ba26885
pkgrel=1
pkgdesc="The FirmWare Test Suite is a tool to do automatic testing of a PC's firmware"
arch=('i686' 'x86_64')
url="http://smackerelofopinion.blogspot.com/2010/08/firmware-test-suite-biosacpi-health.html"
license=('GPL')
-depends=('pcre' 'json-c')
+depends=('dtc' 'libbsd' 'pcre' 'json-c')
+conflicts=("${pkgname%-git}")
+provides=("${pkgname%-git}")
makedepends=('git')
-source=('fwts::git://kernel.ubuntu.com/hwe/fwts.git')
+source=("${pkgname}::git://kernel.ubuntu.com/hwe/fwts.git")
build() {
- cd fwts
- autoreconf -ivf
- CPPFLAGS="$CPPFLAGS -O2"
- CFLAGS=--sysroot= ./configure --prefix=/usr
- make
+ cd "${srcdir}/${pkgname}"
+ autoreconf -ivf
+ CPPFLAGS="$CPPFLAGS -O2"
+ CFLAGS=--sysroot= ./configure --prefix=/usr
+ make
}
package() {
- cd fwts
- make DESTDIR=$pkgdir install
+ cd "${srcdir}/${pkgname}"
+ make DESTDIR="${pkgdir}" install
}
pkgver() {
- cd fwts
- echo $(git rev-list --count master).$(git rev-parse --short master)
+ cd "${srcdir}/${pkgname}"
+ printf "%s" "$(git describe --long | sed 's/\([^-]*-\)g/r\1/;s/-/./g' | sed 's/V//')"
}
md5sums=('SKIP')