summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPieter Goetschalckx2020-07-22 15:22:26 +0200
committerPieter Goetschalckx2020-07-22 15:22:26 +0200
commit5fb7357a6904d47b22f5d0ac63d6aa3de808e5bd (patch)
tree51bc8c05467bb6e6ce4f7d973d2cad08facc227e
parent08bcad791b9a627fbd298c49412a343a7d0efb5c (diff)
downloadaur-5fb7357a6904d47b22f5d0ac63d6aa3de808e5bd.tar.gz
v0.0.7
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 9 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e8135099594d..0f21fb261798 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = fx_cast
pkgdesc = Implementation of the Chrome Sender API (Chromecast) within Firefox
- pkgver = 0.0.6
+ pkgver = 0.0.7
pkgrel = 1
url = https://hensm.github.io/fx_cast/
arch = x86_64
@@ -8,8 +8,8 @@ pkgbase = fx_cast
makedepends = npm
conflicts = fx_cast-bin
options = !strip
- source = https://github.com/hensm/fx_cast/archive/v0.0.6.tar.gz
- sha256sums = b7044abfd46f9ccbe2a0a79632d5e0e10154a0cd23e4712f97efe58013dd7cdc
+ source = https://github.com/hensm/fx_cast/archive/v0.0.7.tar.gz
+ sha256sums = d9dbcf9594e343b2e5ccc901a1bf5659b1a98cdce4e0910833d1d27872eb5efe
pkgname = fx_cast
diff --git a/PKGBUILD b/PKGBUILD
index 17579a5e80a5..87b804b5d8da 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
# Contributor: csicar
pkgname=fx_cast
-pkgver=0.0.6
+pkgver=0.0.7
pkgrel=1
pkgdesc="Implementation of the Chrome Sender API (Chromecast) within Firefox"
arch=('x86_64')
@@ -12,20 +12,22 @@ makedepends=('npm')
conflicts=('fx_cast-bin')
options=('!strip')
source=("https://github.com/hensm/${pkgname}/archive/v${pkgver}.tar.gz")
-sha256sums=('b7044abfd46f9ccbe2a0a79632d5e0e10154a0cd23e4712f97efe58013dd7cdc')
+sha256sums=('d9dbcf9594e343b2e5ccc901a1bf5659b1a98cdce4e0910833d1d27872eb5efe')
build() {
cd "${pkgname}-${pkgver}"
+ sed -i 's/`node.*`/"host"/' app/bin/build.js
npm install --cache "${srcdir}/npm-cache"
npm run build:app
- sed -i 's#"path":.*$#"path": "/usr/bin/fx_cast_bridge"#' dist/app/fx_cast_bridge.json
+ sed -i 's#"path":.*$#"path": "/usr/lib/fx_cast/fx_cast_bridge"#' dist/app/fx_cast_bridge.json
}
package() {
cd "${pkgname}-${pkgver}"
- install -Dm755 dist/app/fx_cast_bridge "${pkgdir}/usr/bin/fx_cast_bridge"
+ install -Dm755 dist/app/fx_cast_bridge -t "${pkgdir}/usr/lib/fx_cast/"
+ install -Dm755 dist/app/dns_sd_bindings.node -t "${pkgdir}/usr/lib/fx_cast/"
install -Dm644 dist/app/fx_cast_bridge.json "${pkgdir}/usr/lib/mozilla/native-messaging-hosts/fx_cast_bridge.json"
install -Dm644 LICENSE "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
}