summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorcsicar2021-01-28 16:55:36 +0100
committercsicar2021-01-28 16:57:37 +0100
commit860b2fd3c3ad90131fdcfb5ea586d5ad26edb9c4 (patch)
tree528b8cbd6d03bda6b067413551c792978426d07c
parent5a97a8f5fe8a7fab28cb593845a2c11527a04ed8 (diff)
downloadaur-860b2fd3c3ad90131fdcfb5ea586d5ad26edb9c4.tar.gz
Use better install script
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD30
-rw-r--r--fx_cast.install5
3 files changed, 31 insertions, 17 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 44282beaf25d..47c954b89f7f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,16 +1,19 @@
pkgbase = fx_cast-bin
- pkgdesc = Implementation of the Chrome Sender API (Chromecast) within Firefox
+ pkgdesc = Implementation of the Google Cast Chrome Sender SDK within Firefox
pkgver = 0.1.0
- pkgrel = 1
+ pkgrel = 2
url = https://hensm.github.io/fx_cast/
+ install = fx_cast.install
arch = x86_64
- groups =
license = MIT
- depends = nodejs
+ depends = avahi
+ provides = fx_cast
+ conflicts = fx_cast
options = !strip
- options = !emptydirs
source = https://github.com/hensm/fx_cast/releases/download/v0.1.0/fx_cast_bridge-0.1.0-x64.deb
+ source = https://raw.githubusercontent.com/hensm/fx_cast/v0.1.0/LICENSE
sha512sums = 0cad784281f46c3b6d2818b3de8823afe6d935a2108ed6de3b06a28db20f0a751f530657c59c9cdc7235c6c3a0463a9d0f5d072c67a0081d029bb05116d14168
+ sha512sums = 342096561c04ea9b85db0bb6f365bd448afbf7ce8f80e3dc35e26c303358b45bf6d19dc4e4bfbb20e52685fcfd8a650a27071387cdc4761a0365c66f427d8992
pkgname = fx_cast-bin
diff --git a/PKGBUILD b/PKGBUILD
index 587d3adba028..df13dff3de8c 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,23 +1,29 @@
-# Generated by debtap
# Maintainer: csicar
# Contributor: csicar
+# Based on: https://github.com/yochananmarqos/pkgbuilds/blob/master/fx_cast-bin/PKGBUILD
pkgname=fx_cast-bin
pkgver=0.1.0
-pkgrel=1
-pkgdesc="Implementation of the Chrome Sender API (Chromecast) within Firefox"
+pkgrel=2
+pkgdesc="Implementation of the Google Cast Chrome Sender SDK within Firefox "
arch=('x86_64')
url="https://hensm.github.io/fx_cast/"
license=('MIT')
-groups=('')
-depends=('nodejs')
-options=('!strip' '!emptydirs')
-source=("https://github.com/hensm/fx_cast/releases/download/v0.1.0/fx_cast_bridge-0.1.0-x64.deb")
-sha512sums=('0cad784281f46c3b6d2818b3de8823afe6d935a2108ed6de3b06a28db20f0a751f530657c59c9cdc7235c6c3a0463a9d0f5d072c67a0081d029bb05116d14168')
+depends=('avahi')
+provides=("${pkgname%-bin}")
+conflicts=("${pkgname%-bin}")
+options=('!strip')
+install="${pkgname%-bin}.install"
+source=("https://github.com/hensm/fx_cast/releases/download/v0.1.0/fx_cast_bridge-0.1.0-x64.deb"
+ "https://raw.githubusercontent.com/hensm/fx_cast/v$pkgver/LICENSE")
+sha512sums=('0cad784281f46c3b6d2818b3de8823afe6d935a2108ed6de3b06a28db20f0a751f530657c59c9cdc7235c6c3a0463a9d0f5d072c67a0081d029bb05116d14168'
+ '342096561c04ea9b85db0bb6f365bd448afbf7ce8f80e3dc35e26c303358b45bf6d19dc4e4bfbb20e52685fcfd8a650a27071387cdc4761a0365c66f427d8992')
package(){
+ bsdtar -xvf data.tar.xz -C "$pkgdir"
- # Extract package data
- tar xf data.tar.xz -C "${pkgdir}"
- echo "fx_cast: Do not forget to install the firefox extension"
+ # Fix permissions
+ find "$pkgdir/" -type d -exec chmod 755 {} \;
+ chmod 644 "$pkgdir/usr/lib/mozilla/native-messaging-hosts/${pkgname%-bin}_bridge.json"
-}
+ install -Dm644 LICENSE -t "$pkgdir/usr/share/licenses/${pkgname%-bin}"
+} \ No newline at end of file
diff --git a/fx_cast.install b/fx_cast.install
new file mode 100644
index 000000000000..d21cdcfecaac
--- /dev/null
+++ b/fx_cast.install
@@ -0,0 +1,5 @@
+post_install() {
+ echo ""
+ echo "Don't forget to install the Firefox extension and enable the Avahi service!"
+ echo ""
+} \ No newline at end of file