summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMiepee2021-09-12 17:29:01 +0200
committerMiepee2021-09-12 17:29:01 +0200
commit226fcb9a49c5ac9a965dbc947b3b27df90f1b5c2 (patch)
treea749a9e76299c12c3b3fa348101402f674ac4cd6
downloadaur-226fcb9a49c5ac9a965dbc947b3b27df90f1b5c2.tar.gz
initial fxball remaster commit
-rw-r--r--.SRCINFO38
-rw-r--r--PKGBUILD43
2 files changed, 81 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..95dcffff4398
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,38 @@
+pkgbase = fxball-remastered
+ pkgdesc = A classic Breakout / Arkanoid arcade game with a few twists. Made by DoctorM64.
+ pkgver = 1.0
+ pkgrel = 1
+ url = https://doctorm64.itch.io/fxb-remastered
+ arch = x86_64
+ license = none
+ depends = lib32-gcc-libs
+ depends = lib32-zlib
+ depends = lib32-libxxf86vm
+ depends = lib32-libglvnd
+ depends = lib32-curl
+ depends = lib32-openal
+ depends = lib32-glibc
+ depends = lib32-openssl-1.0
+ depends = lib32-libxext
+ depends = lib32-libx11
+ depends = lib32-libx11
+ depends = lib32-libxrandr
+ depends = lib32-glu
+ depends = lib32-libidn2
+ depends = lib32-libssh2
+ depends = lib32-libpsl
+ depends = lib32-openssl
+ depends = lib32-krb5
+ depends = lib32-zstd
+ depends = lib32-libxcb
+ depends = lib32-libxrender
+ depends = lib32-libunistring
+ depends = lib32-e2fsprogs
+ depends = lib32-keyutils
+ depends = lib32-libxau
+ depends = lib32-libxdmcp
+ depends = lib32-libpulse
+ source = https://matix.li/4763d465f26d
+ md5sums = SKIP
+
+pkgname = fxball-remastered
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..4367507ee434
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: Miepee <janbidler00 at tutanota dot com>
+pkgname=fxball-remastered
+pkgver=1.0
+pkgrel=1
+pkgdesc="A classic Breakout / Arkanoid arcade game with a few twists. Made by DoctorM64."
+arch=(x86_64)
+url="https://doctorm64.itch.io/fxb-remastered"
+license=('none')
+depends=('lib32-gcc-libs' 'lib32-zlib' 'lib32-libxxf86vm' 'lib32-libglvnd' 'lib32-curl' 'lib32-openal' 'lib32-glibc' 'lib32-openssl-1.0' 'lib32-libxext' 'lib32-libx11' 'lib32-libx11' 'lib32-libxrandr' 'lib32-glu' 'lib32-libidn2' 'lib32-libssh2' 'lib32-libpsl' 'lib32-openssl' 'lib32-krb5' 'lib32-zstd' 'lib32-libxcb' 'lib32-libxrender' 'lib32-libunistring' 'lib32-e2fsprogs' 'lib32-keyutils' 'lib32-libxau' 'lib32-libxdmcp' 'lib32-libpulse')
+source=("https://matix.li/4763d465f26d")
+md5sums=(SKIP)
+
+build() {
+ # remove orphaned file
+ rm -f $(echo $source | sed "s/https:\/\/matix.li\///g")
+}
+
+package() {
+ mkdir -p "$pkgdir/usr/bin/"
+ mkdir -p "$pkgdir/opt/$pkgname/"
+ cp -r ./ "$pkgdir/opt/$pkgname"
+ chmod +x "$pkgdir/opt/$pkgname/FX_Ball_Remastered"
+
+ #creating shell script cause gms1.4 dumb
+ echo "#! /usr/bin/sh
+LD_PRELOAD=libcurl.so.3 /opt/$pkgname/FX_Ball_Remastered" > "$pkgdir/opt/$pkgname/startFXBall-Remastered.sh"
+
+ chmod +x "$pkgdir/opt/$pkgname/startFXBall-Remastered.sh"
+
+ ln -sf "/opt/$pkgname/startFXBall-Remastered.sh" "$pkgdir/usr/bin/$pkgname"
+
+ # Adding desktop entry
+ mkdir -p "$pkgdir/usr/share/applications/"
+ echo "[Desktop Entry]
+Type=Application
+Categories=Game
+Encoding=UTF-8
+Name=FX Ball Remastered
+Comment=A classic Breakout / Arkanoid arcade game, but you can control up to 4 paddles at the same time with the mouse.
+Exec=fxball-remastered
+Icon=/opt/fxball-remastered/assets/icon.png
+Terminal=false" > "$pkgdir/usr/share/applications/$pkgname.desktop"
+}