summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2017-05-07 11:01:53 -0300
committerDaniel Bermond2017-05-07 11:01:53 -0300
commit68692853a6cab087b4259bcae9a3f3b0c0c49e83 (patch)
tree8ff5c7a0c45fb2fdd644354e6a948a59786dcd62
downloadaur-68692853a6cab087b4259bcae9a3f3b0c0c49e83.tar.gz
Initial commit
-rw-r--r--.SRCINFO15
-rw-r--r--PKGBUILD59
2 files changed, 74 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..3640a5f2073e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,15 @@
+# Generated by mksrcinfo v8
+# Sun May 7 14:01:39 UTC 2017
+pkgbase = fxdiv-git
+ pkgdesc = Header-only library for division via fixed-point multiplication by inverse (git version)
+ pkgver = r36.8f85044
+ pkgrel = 1
+ url = https://github.com/Maratyszcza/FXdiv/
+ arch = any
+ license = MIT
+ makedepends = git
+ source = fxdiv-git::git+https://github.com/Maratyszcza/FXdiv.git
+ sha256sums = SKIP
+
+pkgname = fxdiv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..63ecf8174bd7
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,59 @@
+# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+
+# NOTE:
+# This is a header-only library. No dependecy is needed and no build is necessary.
+# If you want to build the checks/tests, uncomment the blocks in makedepends, build() and check().
+
+pkgname=fxdiv-git
+pkgver=r36.8f85044
+pkgrel=1
+pkgdesc="Header-only library for division via fixed-point multiplication by inverse (git version)"
+arch=('any')
+url="https://github.com/Maratyszcza/FXdiv/"
+license=('MIT')
+makedepends=('git'
+ # for building checks:
+ #'python2' 'ninja' # binary repositories
+ #'confu2-git' # AUR
+)
+source=("$pkgname"::"git+https://github.com/Maratyszcza/FXdiv.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$pkgname"
+
+ # git, no tags available
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+# uncomment this block to build and run the checks/tests
+#build() {
+# cd "$pkgname"
+#
+# confu2 setup
+# python2 ./configure.py
+# ninja
+#}
+#
+#check() {
+# cd "${pkgname}/bin"
+# for _test in *
+# do
+# msg2 "Running test '${_test}'..."
+# ./"$_test"
+# done
+#}
+
+package() {
+ cd "${pkgname}"
+
+ # directories creation
+ mkdir -p "${pkgdir}/usr/include"
+ mkdir -p "${pkgdir}/usr/share/licenses/${pkgname}"
+
+ # include
+ install -D -m644 include/*.h "${pkgdir}/usr/include"
+
+ # license
+ install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+}