summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDaniel Bermond2018-10-17 21:13:59 +0000
committerDaniel Bermond2018-10-17 21:13:59 +0000
commita3f22de4c67795af55cfd5e75bf0137a0af7ffa3 (patch)
treed6a78c6972143cb6374c35ff0be5b5103f83d3ff
parent68692853a6cab087b4259bcae9a3f3b0c0c49e83 (diff)
downloadaur-a3f22de4c67795af55cfd5e75bf0137a0af7ffa3.tar.gz
Remove makepkg internal function. Cosmetic changes.
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD32
2 files changed, 18 insertions, 18 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3640a5f2073e..f6614e32508e 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,8 +1,6 @@
-# Generated by mksrcinfo v8
-# Sun May 7 14:01:39 UTC 2017
pkgbase = fxdiv-git
pkgdesc = Header-only library for division via fixed-point multiplication by inverse (git version)
- pkgver = r36.8f85044
+ pkgver = r51.811b482
pkgrel = 1
url = https://github.com/Maratyszcza/FXdiv/
arch = any
diff --git a/PKGBUILD b/PKGBUILD
index 63ecf8174bd7..124dd6fd9bcf 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,35 +1,36 @@
-# Maintainer : Daniel Bermond < yahoo-com: danielbermond >
+# Maintainer : Daniel Bermond < gmail-com: danielbermond >
# NOTE:
# This is a header-only library. No dependecy is needed and no build is necessary.
-# If you want to build the checks/tests, uncomment the blocks in makedepends, build() and check().
+# If you want to build the checks/tests, uncomment the blocks in checkdepends, build() and check().
pkgname=fxdiv-git
-pkgver=r36.8f85044
+pkgver=r51.811b482
pkgrel=1
-pkgdesc="Header-only library for division via fixed-point multiplication by inverse (git version)"
+pkgdesc='Header-only library for division via fixed-point multiplication by inverse (git version)'
arch=('any')
-url="https://github.com/Maratyszcza/FXdiv/"
+url='https://github.com/Maratyszcza/FXdiv/'
license=('MIT')
-makedepends=('git'
- # for building checks:
- #'python2' 'ninja' # binary repositories
- #'confu2-git' # AUR
-)
-source=("$pkgname"::"git+https://github.com/Maratyszcza/FXdiv.git")
+makedepends=('git')
+#checkdepends=(
+# official repositories:
+# 'python2' 'ninja'
+# AUR:
+# 'confu2-git'
+#)
+source=("$pkgname"::'git+https://github.com/Maratyszcza/FXdiv.git')
sha256sums=('SKIP')
pkgver() {
cd "$pkgname"
# git, no tags available
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+ printf 'r%s.%s' "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
# uncomment this block to build and run the checks/tests
#build() {
# cd "$pkgname"
-#
# confu2 setup
# python2 ./configure.py
# ninja
@@ -37,9 +38,10 @@ pkgver() {
#
#check() {
# cd "${pkgname}/bin"
+# local _test
# for _test in *
# do
-# msg2 "Running test '${_test}'..."
+# printf '%s\n' " -> Running test '${_test}'..."
# ./"$_test"
# done
#}
@@ -55,5 +57,5 @@ package() {
install -D -m644 include/*.h "${pkgdir}/usr/include"
# license
- install -D -m644 "LICENSE" "${pkgdir}/usr/share/licenses/${pkgname}/LICENSE"
+ install -D -m644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
}