summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAndy Weidenbaum2015-06-09 11:41:58 -0700
committerAndy Weidenbaum2015-06-09 11:41:58 -0700
commitc7e2d28c8f347e3841697fa169e02491f7aee7b2 (patch)
tree17d3a72f3e3b81d2898dfbab199407516d738cfe
downloadaur-c7e2d28c8f347e3841697fa169e02491f7aee7b2.tar.gz
Initial import
-rw-r--r--.SRCINFO23
-rw-r--r--PKGBUILD41
-rw-r--r--fzf-extras.install38
3 files changed, 102 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..2ecfa7dbed11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,23 @@
+pkgbase = fzf-extras-git
+ pkgdesc = Extra keybindings for fzf
+ pkgver = 20150511
+ pkgrel = 1
+ url = https://github.com/atweiden/fzf-extras
+ install = fzf-extras.install
+ arch = any
+ license = MIT
+ makedepends = git
+ depends = fzf
+ optdepends = ctags: select tags
+ optdepends = git: git checkout fuzzy commits, branches
+ optdepends = mlocate: locate files
+ optdepends = vim-fzf: fzf.vim
+ optdepends = xdg-utils: open files
+ optdepends = zsh: zsh keybindings
+ provides = fzf-extras
+ conflicts = fzf-extras
+ source = git+https://github.com/atweiden/fzf-extras
+ sha256sums = SKIP
+
+pkgname = fzf-extras-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..31fb10c02290
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,41 @@
+# Maintainer: Andy Weidenbaum <archbaum@gmail.com>
+
+pkgname=fzf-extras-git
+pkgver=20150511
+pkgrel=1
+pkgdesc="Extra keybindings for fzf"
+arch=('any')
+depends=('fzf')
+makedepends=('git')
+optdepends=('ctags: select tags'
+ 'git: git checkout fuzzy commits, branches'
+ 'mlocate: locate files'
+ 'vim-fzf: fzf.vim'
+ 'xdg-utils: open files'
+ 'zsh: zsh keybindings')
+url="https://github.com/atweiden/fzf-extras"
+license=('MIT')
+source=(git+https://github.com/atweiden/fzf-extras)
+sha256sums=('SKIP')
+provides=('fzf-extras')
+conflicts=('fzf-extras')
+install=fzf-extras.install
+
+pkgver() {
+ cd ${pkgname%-git}
+ git log -1 --format="%cd" --date=short | sed "s|-||g"
+}
+
+package() {
+ cd ${pkgname%-git}
+
+ msg2 'Installing documentation...'
+ install -Dm 644 README.md "$pkgdir/usr/share/doc/fzf-extras/README.md"
+
+ msg2 'Installing...'
+ install -Dm 755 fzf-extras.sh "$pkgdir/etc/profile.d/fzf-extras.bash"
+ install -Dm 755 fzf-extras.zsh "$pkgdir/etc/profile.d/fzf-extras.zsh"
+
+ msg 'Cleaning up pkgdir...'
+ find "$pkgdir" -type d -name .git -exec rm -r '{}' +
+}
diff --git a/fzf-extras.install b/fzf-extras.install
new file mode 100644
index 000000000000..5d132198eb4b
--- /dev/null
+++ b/fzf-extras.install
@@ -0,0 +1,38 @@
+post_install() {
+ printf "%b\n" "$fzfin"
+}
+
+post_upgrade() {
+ printf "%b\n" "$fzfup"
+}
+
+read -d '' fzfin <<'EOF'
+fzf-extras
+==========
+
+Add the following to your shell config:
+
+ . /etc/profile.d/fzf-extras.bash # when bash
+ . /etc/profile.d/fzf-extras.zsh # when zsh
+EOF
+
+read -d '' fzfup <<'EOF'
+fzf-extras
+==========
+
+Bash Users: Potentially Breaking Update (2015-05-09)
+----------------------------------------------------
+
+To ensure zsh compatibility, Bash keybindings are now
+installed to:
+
+ /etc/profile.d/fzf-extras.bash
+
+Formerly, Bash keybindings were installed as:
+
+ /etc/profile.d/fzf-extras.sh
+
+Bash users' config may be broken by this update if bashrc sources
+/etc/profile.d/fzf-extra.sh, as that file is now absent. Consult with
+your local config.
+EOF