summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorOrhun Parmaksız2023-08-18 15:11:50 +0300
committerOrhun Parmaksız2023-08-18 15:11:50 +0300
commit00977ab215304064a04c1297b8ce6e570d35dec2 (patch)
treefd5072e121f2abe3c10a33995e0943e231ecbce9
downloadaur-00977ab215304064a04c1297b8ce6e570d35dec2.tar.gz
Initial upload: fzf-make 0.6.0-1
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD39
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..0cc94fa7208b
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = fzf-make
+ pkgdesc = Fuzzy finder for Makefile
+ pkgver = 0.6.0
+ pkgrel = 1
+ url = https://github.com/kyu08/fzf-make
+ arch = x86_64
+ license = MIT
+ makedepends = cargo
+ depends = gcc-libs
+ source = fzf-make-0.6.0.tar.gz::https://github.com/kyu08/fzf-make/archive/v0.6.0.tar.gz
+ sha256sums = e39a34a6fb1f220b0f0927c526ffffce518a50ed59350b138e323bf92b569656
+
+pkgname = fzf-make
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..3db36c072642
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: orhun <orhunparmaksiz@gmail.com>
+# https://github.com/orhun/pkgbuilds
+
+pkgname=fzf-make
+pkgver=0.6.0
+pkgrel=1
+pkgdesc="Fuzzy finder for Makefile"
+arch=('x86_64')
+url="https://github.com/kyu08/fzf-make"
+license=('MIT')
+depends=('gcc-libs')
+makedepends=('cargo')
+source=("$pkgname-$pkgver.tar.gz::$url/archive/v$pkgver.tar.gz")
+sha256sums=('e39a34a6fb1f220b0f0927c526ffffce518a50ed59350b138e323bf92b569656')
+
+prepare() {
+ cd "$pkgname-$pkgver"
+ cargo fetch --locked --target "$CARCH-unknown-linux-gnu"
+}
+
+build() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ export CARGO_TARGET_DIR=target
+ cargo build --release --frozen
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+ export RUSTUP_TOOLCHAIN=stable
+ cargo test --frozen
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+ install -Dm 755 "target/release/$pkgname" -t "$pkgdir/usr/bin"
+ install -Dm 644 README.md -t "$pkgdir/usr/share/doc/$pkgname"
+ install -Dm 644 LICENSE -t "$pkgdir/usr/share/licenses/$pkgname"
+}