summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Reuße2016-06-25 09:05:57 +0200
committerSebastian Reuße2016-06-25 09:08:59 +0200
commite601bb935e1ac959b5ca6bed7517427577fb142d (patch)
treee1d04ca032018427012c5c441d0fe362dee25d76
downloadaur-e601bb935e1ac959b5ca6bed7517427577fb142d.tar.gz
Init
-rw-r--r--.SRCINFO21
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD35
-rw-r--r--fzf-marks.install3
4 files changed, 60 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..338bed677f07
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,21 @@
+# Generated by mksrcinfo v8
+# Sat Jun 25 07:08:58 UTC 2016
+pkgbase = fzf-marks-git
+ pkgdesc = Create, navigate and delete bookmarks in Bash and Zsh, using the fuzzy finder fzf
+ pkgver = r11.5cf67a2
+ pkgrel = 1
+ url = https://github.com/urbainvaes/fzf-marks
+ install = fzf-marks.install
+ arch = any
+ license = GPL
+ makedepends = git
+ depends = fzf
+ optdepends = zsh: to use with zsh
+ optdepends = bash: to use with bash
+ provides = fzf-marks
+ conflicts = fzf-marks
+ source = git+https://github.com/urbainvaes/fzf-marks
+ md5sums = SKIP
+
+pkgname = fzf-marks-git
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..468cd87d3ce8
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..cf8efa293cca
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Maintainer: Sebastian Reuße <seb@wirrsal.net>
+pkgname=fzf-marks-git
+_gitname=fzf-marks
+pkgver=r11.5cf67a2
+pkgrel=1
+pkgdesc="Create, navigate and delete bookmarks in Bash and Zsh, using the fuzzy finder fzf"
+arch=(any)
+url=https://github.com/urbainvaes/fzf-marks
+license=(GPL)
+depends=(fzf)
+makedepends=(git)
+optdepends=(
+ "zsh: to use with zsh"
+ "bash: to use with bash"
+)
+provides=(fzf-marks)
+conflicts=(fzf-marks)
+source=(git+https://github.com/urbainvaes/fzf-marks)
+md5sums=(SKIP)
+install=fzf-marks.install
+
+pkgver() {
+ cd "$_gitname"
+ # No tagged commits. ヽ(´ー`)ノ
+ commit=$(git rev-list --count master)
+ hash=$(git rev-parse --short HEAD)
+ echo "r$commit.$hash"
+}
+
+package() {
+ cd "$_gitname"
+ install -Dm644 README.md "$pkgdir"/usr/share/doc/fzf-marks/README.md
+ install -Dm644 fzf-marks.plugin.bash "$pkgdir"/usr/share/fzf-marks/fzf-marks.bash
+ install -Dm644 fzf-marks.plugin.zsh "$pkgdir"/usr/share/fzf-marks/fzf-marks.zsh
+}
diff --git a/fzf-marks.install b/fzf-marks.install
new file mode 100644
index 000000000000..94cddda6d7e5
--- /dev/null
+++ b/fzf-marks.install
@@ -0,0 +1,3 @@
+post_install() {
+ echo "To use, source one of fzf-marks.{bash,zsh} from /usr/share/fzf-marks."
+}