summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraslingguang2024-01-28 13:28:36 +0800
committeraslingguang2024-01-28 13:28:36 +0800
commit7cad8f71bb4be5f86fefc4075c542dd550afc05c (patch)
tree0072e00c88fc62a1a9ff9c8851f3258c4cd1680d
parent52177dde3da7ed447c8fa8e074e0baf4968b2328 (diff)
downloadaur-7cad8f71bb4be5f86fefc4075c542dd550afc05c.tar.gz
更新打包方式
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD26
2 files changed, 22 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index dd3489b534dc..cc439d6b8dda 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,10 +1,11 @@
pkgbase = fzf-tab-source
pkgdesc = 替代zsh的命令补全功能,加入文件和目录预览,可使用rg和rga辅助fzf搜索。 Replace zsh's default completion selection menu with fzf.Add file and directory previews,and can use rg or rga to assist fzf searches. After the installation is completed, use 'fts -a' to enable the plugin
- pkgver = 1.0.2
+ pkgver = r6.05c1fc5
pkgrel = 1
url = https://github.com/aslingguang/fzf-tab-source
arch = x86_64
license = GPL
+ makedepends = git
depends = zsh
depends = fzf
optdepends = exa: 目录结构预览
@@ -20,7 +21,9 @@ pkgbase = fzf-tab-source
optdepends = unrar: rar预览
optdepends = p7zip: 7z预览
optdepends = fd: 快速查找文件和目录,比默认的find更快
- source = https://github.com/aslingguang/fzf-tab-source/releases/download/v1.0.2/fzf-tab-source.tar.gz
- sha256sums = 20e418c7c0c4c7fd0c376a40a0e7740aec417ba1bf1a951133fd5988a1f58cec
+ conflicts = fzf-tab-git
+ conflicts = fzf-tab-bin-git
+ source = git+https://github.com/aslingguang/fzf-tab-source.git
+ sha256sums = SKIP
pkgname = fzf-tab-source
diff --git a/PKGBUILD b/PKGBUILD
index 720f35caf71f..1c772eaf8631 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
pkgname=fzf-tab-source
-pkgver=1.0.2
+pkgver=r6.05c1fc5
pkgrel=1
pkgdesc="替代zsh的命令补全功能,加入文件和目录预览,可使用rg和rga辅助fzf搜索。
Replace zsh's default completion selection menu with fzf.Add file and directory previews,and can use rg or rga to assist fzf searches.
@@ -8,7 +8,8 @@ arch=('x86_64')
url="https://github.com/aslingguang/fzf-tab-source"
license=('GPL')
depends=('zsh' 'fzf')
-
+makedepends=('git')
+conflicts=('fzf-tab-git' 'fzf-tab-bin-git' )
optdepends=('exa: 目录结构预览'
'chafa: 图片预览'
'perl-image-exiftool: 元数据预览'
@@ -22,14 +23,19 @@ optdepends=('exa: 目录结构预览'
'unrar: rar预览'
'p7zip: 7z预览'
'fd: 快速查找文件和目录,比默认的find更快')
-source=("https://github.com/aslingguang/fzf-tab-source/releases/download/v1.0.2/fzf-tab-source.tar.gz")
-sha256sums=('20e418c7c0c4c7fd0c376a40a0e7740aec417ba1bf1a951133fd5988a1f58cec')
+source=("git+https://github.com/aslingguang/fzf-tab-source.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/$pkgname"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
package() {
- mkdir -p "$pkgdir/opt"
- cp -r "$srcdir/fzf-tab-source" "$pkgdir/opt"
- chmod +x -R "$pkgdir/opt/fzf-tab-source"
- mkdir -p "$pkgdir/usr/bin"
- cp "$srcdir/fzf-tab-source/fts.sh" "$pkgdir/usr/bin/fts"
- chmod +x "$pkgdir/usr/bin/fts"
+ cd "$srcdir/$pkgname"
+ install -dm755 "${pkgdir}/usr/share/zsh/plugins/${pkgname}"
+ cp -dr --no-preserve=ownership {fzf-tab.zsh,lib,modules} \
+ "${pkgdir}/usr/share/zsh/plugins/${pkgname}"
+ ln -s "fzf-tab.zsh" \
+ "${pkgdir}/usr/share/zsh/plugins/${pkgname}/fzf-tab.plugin.zsh"
}