summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorwebmeister2015-07-05 18:00:19 +0200
committerwebmeister2015-07-05 18:00:19 +0200
commit0512a10f73c0e1a24a511846402dc2adada5a788 (patch)
tree6c20910257af47cfced1919a804ccd709c760792
downloadaur-0512a10f73c0e1a24a511846402dc2adada5a788.tar.gz
Initial import
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD42
-rw-r--r--g15macro-1.0.3-Makefile.am.patch13
-rw-r--r--g15macro-1.0.3-configure.in.patch10
4 files changed, 85 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ab8576f966fc
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = g15macro
+ pkgdesc = A simple Macro recording/playback app for G15Daemon.
+ pkgver = 1.0.3
+ pkgrel = 4
+ url = http://www.g15tools.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = g15daemon
+ depends = libxtst
+ options = !libtool
+ source = http://downloads.sourceforge.net/g15daemon/g15macro-1.0.3.tar.bz2
+ source = g15macro-1.0.3-Makefile.am.patch
+ source = g15macro-1.0.3-configure.in.patch
+ sha256sums = 2645118330e61208d67026a5a212c342f556971945c43d14c60809b7748be2d6
+ sha256sums = 2c4d8825bf69d30894960547121b86d7a603283caa72eb1f81b400742061a6ed
+ sha256sums = 85e6a7fc0e3aef2bfed36049c074d92b7fdd5b3a2eefaacb8c93b62a725c6d73
+
+pkgname = g15macro
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5198103aa177
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,42 @@
+# Contributor: zoulnix <http://goo.gl/HQaP>
+
+pkgname=g15macro
+pkgver=1.0.3
+pkgrel=4
+pkgdesc='A simple Macro recording/playback app for G15Daemon.'
+arch=('i686' 'x86_64')
+url='http://www.g15tools.com/'
+license=('GPL')
+depends=('g15daemon' 'libxtst')
+options=('!libtool')
+source=("http://downloads.sourceforge.net/g15daemon/$pkgname-$pkgver.tar.bz2"
+ "$pkgname-$pkgver-Makefile.am.patch"
+ "$pkgname-$pkgver-configure.in.patch")
+sha256sums=('2645118330e61208d67026a5a212c342f556971945c43d14c60809b7748be2d6'
+ '2c4d8825bf69d30894960547121b86d7a603283caa72eb1f81b400742061a6ed'
+ '85e6a7fc0e3aef2bfed36049c074d92b7fdd5b3a2eefaacb8c93b62a725c6d73')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ msg "Patching..."
+ for i in $srcdir/*.patch; do
+ patch -Np1 -i "$i"
+ done
+
+ autoreconf -vis
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var
+
+ make
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+
+ make DESTDIR="$pkgdir" install
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/g15macro-1.0.3-Makefile.am.patch b/g15macro-1.0.3-Makefile.am.patch
new file mode 100644
index 000000000000..bc457dc52fbd
--- /dev/null
+++ b/g15macro-1.0.3-Makefile.am.patch
@@ -0,0 +1,13 @@
+--- a/Makefile.am
++++ b/Makefile.am
+@@ -10,9 +10,8 @@
+ imagedir = $(prefix)/share/g15macro/splash
+ image_DATA = ${top_builddir}/g15macro.wbmp
+
+-LIBS = -lg15daemon_client -lg15render -lX11 -lXtst
++LIBS = -lg15daemon_client -lg15render -lX11 -lXtst -lpthread
+ IMCLUDES = -I
+-g15macro_LDFLAGS = -avoid-version
+ g15macro_SOURCES = g15macro.c
+
+
diff --git a/g15macro-1.0.3-configure.in.patch b/g15macro-1.0.3-configure.in.patch
new file mode 100644
index 000000000000..7cdde1d098ec
--- /dev/null
+++ b/g15macro-1.0.3-configure.in.patch
@@ -0,0 +1,10 @@
+--- a/configure.in
++++ b/configure.in
+@@ -8,7 +8,6 @@
+ AC_CONFIG_HEADER([config.h])
+
+ AC_PROG_CC
+-AC_PROG_LIBTOOL
+ AC_PROG_RANLIB
+
+ AC_CHECK_LIB([g15daemon_client], [g15daemon_version],,AC_MSG_ERROR(["libg15daemon_client (or its devel package) not found. please install it"]))