summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMathieu OTHACEHE2015-06-11 17:54:14 +0200
committerMathieu OTHACEHE2015-06-11 17:54:14 +0200
commitdeb06f902c4418a130d3e51aedc940b37cfa0560 (patch)
tree214879887c8a8bfc42f899dd02fdb44ec43dbd60
downloadaur-deb06f902c4418a130d3e51aedc940b37cfa0560.tar.gz
Initial import
-rw-r--r--.SRCINFO26
-rw-r--r--PKGBUILD37
-rw-r--r--g15mpd-libmpdheader.patch27
3 files changed, 90 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fd32ac27f9a5
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,26 @@
+pkgbase = g15mpd
+ pkgdesc = A simple frontend for the Media Player Daemon, for use with G15Daemon.
+ pkgver = 1.0.0
+ pkgrel = 3
+ url = http://www.g15tools.com/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ makedepends = autoconf
+ makedepends = automake
+ makedepends = gcc
+ makedepends = libtool
+ makedepends = make
+ makedepends = patch
+ makedepends = pkg-config
+ depends = g15daemon
+ depends = libmpd
+ depends = libxtst
+ options = !libtool
+ source = http://downloads.sourceforge.net/g15daemon/g15mpd-1.0.0.tar.bz2
+ source = g15mpd-libmpdheader.patch
+ md5sums = 20f44c69b121750c27879e04c2cdff60
+ md5sums = 6392a59672f0b737535a9bcf04ba49a0
+
+pkgname = g15mpd
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..d22653eee710
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,37 @@
+# Contributor: zoulnix <http://goo.gl/HQaP>
+pkgname=g15mpd
+pkgver=1.0.0
+pkgrel=3
+pkgdesc="A simple frontend for the Media Player Daemon, for use with G15Daemon."
+arch=('i686' 'x86_64')
+url="http://www.g15tools.com/"
+license=('GPL')
+depends=('g15daemon' 'libmpd' 'libxtst')
+makedepends=('autoconf' 'automake' 'gcc' 'libtool' 'make' 'patch' 'pkg-config')
+options=('!libtool')
+source=(http://downloads.sourceforge.net/g15daemon/${pkgname}-${pkgver}.tar.bz2 \
+ ${pkgname}-libmpdheader.patch)
+md5sums=('20f44c69b121750c27879e04c2cdff60' '6392a59672f0b737535a9bcf04ba49a0')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ # apply patches...
+ patch -Np1 -i ../${pkgname}-libmpdheader.patch || return 1
+
+ # Generating build system
+ sh autogen.sh || return 1
+
+ ./configure --prefix=/usr \
+ --sysconfdir=/etc \
+ --localstatedir=/var \
+ --disable-static
+
+ make || return 1
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+
+ make DESTDIR=${pkgdir} install || return 1
+}
diff --git a/g15mpd-libmpdheader.patch b/g15mpd-libmpdheader.patch
new file mode 100644
index 000000000000..d406e0695f5b
--- /dev/null
+++ b/g15mpd-libmpdheader.patch
@@ -0,0 +1,27 @@
+--- g15mpd-1.0.0.orig/autogen.sh 1970-01-01 01:00:00.000000000 +0100
++++ g15mpd-1.0.0/autogen.sh 2009-07-16 20:20:36.067515353 +0200
+@@ -0,0 +1,2 @@
++#!/bin/sh
++autoreconf -vfi
+--- g15mpd-1.0.0.orig/configure.in 2007-02-11 02:33:42.000000000 +0100
++++ g15mpd-1.0.0/configure.in 2009-07-16 20:18:18.628616415 +0200
+@@ -18,7 +18,7 @@ AC_HEADER_SYS_WAIT
+ AC_CHECK_HEADERS(g15daemon_client.h libg15render.h,,AC_MSG_ERROR(["libg15daemon_client (or its devel package) could not be found. please install it"]))
+ AC_CHECK_HEADERS(X11/Xlib.h X11/XF86keysym.h,,AC_MSG_ERROR(["Xorg development files could not be found. please install the devel package"]))
+ AC_CHECK_HEADERS(X11/extensions/XTest.h,,AC_MSG_ERROR(["Xorg XTEST Extension devel headers could not be found. please install the devel package"]))
+-AC_CHECK_HEADERS(libmpd/libmpd.h,,AC_MSG_ERROR(["libmpd development files could not be found. please install the libmpd devel package"]))
++AC_CHECK_HEADERS(libmpd-1.0/libmpd/libmpd.h,,AC_MSG_ERROR(["libmpd development files could not be found. please install the libmpd devel package"]))
+ AC_PATH_X
+
+ AC_OUTPUT(Makefile)
+--- g15mpd-1.0.0.orig/g15mpd.c 2007-01-01 21:51:41.000000000 +0100
++++ g15mpd-1.0.0/g15mpd.c 2009-07-16 20:30:02.213366872 +0200
+@@ -26,7 +26,7 @@
+ This is a simple frontend for the Media Player Daemon (MPD)
+ */
+
+-#include <libmpd/libmpd.h>
++#include <libmpd-1.0/libmpd/libmpd.h>
+ #include <unistd.h>
+ #include <stdio.h>
+ #include <stdlib.h>