summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgraziano.giuliani2015-07-04 16:41:08 +0200
committergraziano.giuliani2015-07-04 16:41:08 +0200
commit9c1d6f78087a7aaa08bbfa9a7c855815a0eea3c1 (patch)
tree881fa17835280901e8a7c8882b779bac8ac57aa8
downloadaur-9c1d6f78087a7aaa08bbfa9a7c855815a0eea3c1.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--NWS_license.txt55
-rw-r--r--PKGBUILD35
3 files changed, 107 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..4656f5a619fd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = g2clib
+ pkgdesc = GRIB2 encoder/decoder (C version)
+ pkgver = 1.4.0
+ pkgrel = 5
+ url = http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2
+ arch = i686
+ arch = x86_64
+ license = custom:NWS
+ provides = g2clib
+ options = staticlibs
+ source = http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2/g2clib-1.4.0.tar
+ source = NWS_license.txt
+ md5sums = f0cbab4ebbaec6d8dd15da1a36c93675
+ md5sums = 64f9f7f5ad383df409986d8a67d2fa78
+
+pkgname = g2clib
+
diff --git a/NWS_license.txt b/NWS_license.txt
new file mode 100644
index 000000000000..7c30166a5a22
--- /dev/null
+++ b/NWS_license.txt
@@ -0,0 +1,55 @@
+http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2
+
+NCEP codes for decoding and encoding data in GRIB2 format
+
+Note: These codes are provided as is for the use of NCEP data users. NCEP does
+not and can not provide any support for them.
+
+http://www.weather.gov/disclaimer
+
+Disclaimer
+ National Weather Service
+ National Headquarters
+[...]
+
+Use of Data and Products
+
+ The information on National Weather Service (NWS) Web pages are in the public
+ domain, unless specifically noted otherwise, and may be used without charge
+ for any lawful purpose so long as you do not: 1) claim it is your own (e.g.,
+ by claiming copyright for NWS information -- see below), 2) use it in a
+ manner that implies an endorsement or affiliation with NOAA/NWS, or 3)
+ modify its content and then present it as official government material. You
+ also cannot present information of your own in a way that makes it appear to
+ be official government information.
+
+ Use of the NWS name ("National Weather Service") and/or visual identifier
+ are protected under trademark law and may not be used without permission
+ from the NWS. Use of the NWS name and/ or visual identifier to identify
+ unaltered NWS content or links to NWS web sites are allowable uses.
+ Permission may be requested for this use at
+ http://www.weather.gov/logorequest. Permission is not required to display
+ unaltered NWS products which include the NWS name or NWS/NOAA visual
+ identifier as part of the original product. Neither the name nor visual
+ identifier may be used, however, in a manner that implies an endorsement or
+ affiliation with NOAA/NWS.
+
+ Before using information obtained from any NWS Web page special attention
+ should be given to the date and time of the data and products being
+ displayed.
+
+ The user assumes the entire risk related to its use of information on NWS
+ Web pages. NWS is provides such information "as is," and NWS disclaims any
+ and all warranties, whether express or implied, including (without
+ limitation) any implied warranties of merchantability or fitness for a
+ particular purpose. In no event will NWS be liable to you or to any third
+ party for any direct, indirect, incidental, consequential, special or
+ exemplary damages or lost profit resulting from any use or misuse of this
+ data.
+
+ As required by 17 U.S.C. ยง 403, third parties producing copyrighted works
+ consisting predominantly of the material appearing in NWS Web pages must
+ provide notice with such work(s) identifying the NWS material incorporated
+ and stating that such material is not subject to copyright protection.
+
+[...]
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2d21334c86c1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+# Contributor: Graziano Giuliani
+
+pkgname=g2clib
+pkgver=1.4.0
+pkgrel=5
+pkgdesc="GRIB2 encoder/decoder (C version)"
+url="http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2"
+license="custom:NWS"
+arch=('i686' 'x86_64')
+provides=(g2clib)
+dependes=(jasper libpng)
+options=('staticlibs')
+source=(http://www.nco.ncep.noaa.gov/pmb/codes/GRIB2/${pkgname}-${pkgver}.tar
+ NWS_license.txt)
+md5sums=('f0cbab4ebbaec6d8dd15da1a36c93675'
+ '64f9f7f5ad383df409986d8a67d2fa78')
+
+build() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ export CFLAGS="${CFLAGS} -fPIC"
+ export CXXFLAGS="${CXXFLAGS} -fPIC"
+ sed -i makefile -e 's/-X64//' -e '/CFLAGS=/d' -e '/CC=/d'
+ CC=gcc CFLAGS="$CFLAGS -DUSE_JPEG2000 -DUSE_PNG" make
+}
+
+package() {
+ cd ${srcdir}/${pkgname}-${pkgver}
+ mkdir -p ${pkgdir}/usr/{lib,include,share/licenses/${pkgname}}
+ install -m 644 libgrib2c.a ${pkgdir}/usr/lib
+ install -m 644 *.h ${pkgdir}/usr/include
+ install -m 644 ${srcdir}/NWS_license.txt \
+ ${pkgdir}/usr/share/licenses/${pkgname}/NWS
+}
+
+# vim:set ts=2 sw=2 et: