summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12022-12-03 13:59:57 +0800
committerChocobo12022-12-03 14:11:07 +0800
commit06b08e4dd8257de9641afd82b17838b1e00a3e4f (patch)
tree91694a682de7ac483fab22846d2de6930979e30e
downloadaur-06b08e4dd8257de9641afd82b17838b1e00a3e4f.tar.gz
newpkg: g3k 0.16.0-1
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD38
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..72c68613d467
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = g3k
+ pkgdesc = A 3DUI widget toolkit
+ pkgver = 0.16.0
+ pkgrel = 1
+ url = https://gitlab.freedesktop.org/xrdesktop/g3k
+ arch = i686
+ arch = x86_64
+ license = MIT
+ makedepends = meson
+ depends = glibc
+ depends = gxr
+ depends = json-glib
+ depends = libcanberra
+ depends = pango
+ depends = shaderc
+ source = g3k-0.16.0-src.tar.bz2::https://gitlab.freedesktop.org/xrdesktop/g3k/-/archive/0.16.0/g3k-0.16.0.tar.bz2
+ sha256sums = a843205ca9194aed5fbab28d2ab3b7dbf58c4d03becf9cab69ca93f5b5a76dbf
+
+pkgname = g3k
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5e86b0cfb1ab
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
+
+pkgname=g3k
+pkgver=0.16.0
+pkgrel=1
+pkgdesc="A 3DUI widget toolkit"
+arch=('i686' 'x86_64')
+url="https://gitlab.freedesktop.org/xrdesktop/g3k"
+license=('MIT')
+depends=('glibc' 'gxr' 'json-glib' 'libcanberra' 'pango' 'shaderc')
+makedepends=('meson')
+source=("$pkgname-$pkgver-src.tar.bz2::https://gitlab.freedesktop.org/xrdesktop/g3k/-/archive/$pkgver/g3k-$pkgver.tar.bz2")
+sha256sums=('a843205ca9194aed5fbab28d2ab3b7dbf58c4d03becf9cab69ca93f5b5a76dbf')
+
+
+build() {
+ cd "$pkgname-$pkgver"
+
+ meson setup \
+ --buildtype=plain \
+ --prefix="/usr" \
+ --sbindir="bin" \
+ "_build"
+ meson compile -C "_build"
+}
+
+check() {
+ cd "$pkgname-$pkgver"
+
+ #meson test -C "_build"
+}
+
+package() {
+ cd "$pkgname-$pkgver"
+
+ meson install -C "_build" --destdir "$pkgdir"
+ install -Dm644 "LICENSE" -t "$pkgdir/usr/share/licenses/g3k"
+}