summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSimon Eriksson2021-08-01 01:02:04 +0200
committerSimon Eriksson2021-08-01 01:02:04 +0200
commit5dc8a0992f7cbe85b579249dc2b854c00c1db7e2 (patch)
tree4c2fb24d8491c26d8b6ce447ea0800ad03049476
downloadaur-5dc8a0992f7cbe85b579249dc2b854c00c1db7e2.tar.gz
Initial commit
-rw-r--r--.SRCINFO12
-rw-r--r--PKGBUILD35
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6a979f52ec58
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,12 @@
+pkgbase = g64drive
+ pkgdesc = Portable Linux/Mac tool for Retroactive 64drive
+ pkgver = 0.3
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ makedepends = go
+ depends = libftdi
+ source = https://github.com/rasky/g64drive/archive/refs/tags/v0.3.tar.gz
+ sha256sums = 402d1e2b9c39a6d21345a4e076b802520ab01d7db1d4dc1b2552bd0004d320df
+
+pkgname = g64drive
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..c8af8c2b4158
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,35 @@
+#Maintainer: Simon Eriksson <simon.eriksson.1187+aur AT gmail.com>
+
+pkgname=g64drive
+pkgver=0.3
+pkgrel=1
+pkgdesc='Portable Linux/Mac tool for Retroactive 64drive'
+arch=('x86_64')
+license=('MIT')
+makedepends=('go')
+depends=('libftdi')
+source=("https://github.com/rasky/g64drive/archive/refs/tags/v${pkgver}.tar.gz")
+sha256sums=('402d1e2b9c39a6d21345a4e076b802520ab01d7db1d4dc1b2552bd0004d320df')
+
+prepare() {
+ cd g64drive-${pkgver}
+ mkdir -p build/
+}
+
+build() {
+ cd g64drive-${pkgver}
+ export CGO_CPPFLAGS="${CPPFLAGS}"
+ export CGO_CFLAGS="${CFLAGS}"
+ export CGO_CXXFLAGS="${CXXFLAGS}"
+ export CGO_LDFLAGS="${LDFLAGS}"
+ export GOFLAGS="-buildmode=pie -trimpath -ldflags=-linkmode=external -mod=readonly -modcacherw"
+ go build -o build
+}
+
+package() {
+ cd g64drive-${pkgver}
+ install -Dm755 build/g64drive "$pkgdir"/usr/bin/g64drive
+
+ #install license
+ install -Dm644 LICENSE.mit "${pkgdir}/usr/share/licenses/$pkgname/LICENSE"
+}