summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2017-01-23 22:45:20 +0100
committerMatMoul2017-01-23 22:45:20 +0100
commit40469a0ec749f822f7be54df79f0cb1b501e80ab (patch)
treeba6bf00647ffaa1fe90ac465a5e9bd92ce2b01e0
parent29fd976e3ad95baf9470d86edc1e04799f0a0f8d (diff)
downloadaur-40469a0ec749f822f7be54df79f0cb1b501e80ab.tar.gz
New version
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD16
2 files changed, 14 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ac3772187e00..973ff2270968 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,18 +1,19 @@
# Generated by mksrcinfo v8
-# Mon Jan 23 02:19:58 UTC 2017
+# Mon Jan 23 21:45:20 UTC 2017
pkgbase = g810-led-git
- pkgdesc = Linux led controller for the Logitech G810, G410, G610 and G910 Keyboard
+ pkgdesc = Linux led controller for Logitech G410, G610, G810 and G910 Keyboards
pkgver = 0.0.1
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/MatMoul/g810-led
install = g810-led-git.install
arch = i686
arch = x86_64
license = GPL3
+ makedepends = git
makedepends = gcc
makedepends = make
depends = hidapi
- optdepends = libusb: alternative USB communication library (slower, more stable)
+ optdepends = libusb: slower, old implementation, use only if you have problem with hidapi
provides = g410-led=0.0.1
provides = g610-led=0.0.1
provides = g810-led=0.0.1
@@ -21,7 +22,7 @@ pkgbase = g810-led-git
options = !emptydirs
backup = etc/g810-led/profile
backup = etc/g810-led/reboot
- source = https://github.com/MatMoul/g810-led/archive/master.zip
+ source = git://github.com/MatMoul/g810-led.git
md5sums = SKIP
pkgname = g810-led-git
diff --git a/PKGBUILD b/PKGBUILD
index b94e933b1faf..11b06697fd38 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,22 +2,22 @@
pkgname=g810-led-git
_appname=g810-led
-_gitname=g810-led-master
+_gitname=g810-led
pkgver=0.0.1
-pkgrel=1
-pkgdesc="Linux led controller for the Logitech G810, G410, G610 and G910 Keyboard"
+pkgrel=2
+pkgdesc="Linux led controller for Logitech G410, G610, G810 and G910 Keyboards"
arch=('i686' 'x86_64')
url="https://github.com/MatMoul/g810-led"
license=('GPL3')
depends=('hidapi')
-makedepends=('gcc' 'make')
-optdepends=('libusb: alternative USB communication library (slower, more stable)')
+makedepends=('git' 'gcc' 'make')
+optdepends=('libusb: slower, old implementation, use only if you have problem with hidapi')
conflicts=('g810-led')
install=${pkgname}.install
provides=("g410-led=${pkgver}" "g610-led=${pkgver}" "g810-led=${pkgver}" "g910-led=${pkgver}")
backup=("etc/${_appname}/profile" "etc/${_appname}/reboot")
options=(!emptydirs)
-source=("https://github.com/MatMoul/${_appname}/archive/master.zip")
+source=("git://github.com/MatMoul/${_appname}.git")
md5sums=('SKIP')
build() {
@@ -26,8 +26,8 @@ build() {
# build with hidapi :
make
- # build with libusb :
- # make LIB=libusb
+ # build with libusb :
+ # make LIB=libusb
}
package() {