summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatMoul2017-05-07 02:20:18 +0200
committerMatMoul2017-05-07 02:20:18 +0200
commit5c710b748e38f7619efb0f04cc0db1ab7a3dca79 (patch)
treef45832e73be63f778a2beda95960e0f5618ca324
parent386de4f56cbfb1e1685022bed44dfbfbb195b1b4 (diff)
downloadaur-5c710b748e38f7619efb0f04cc0db1ab7a3dca79.tar.gz
New version
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD12
-rw-r--r--g810-led-git.install11
3 files changed, 24 insertions, 19 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 59bfc796351..3bf9647ebb9 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,27 +1,27 @@
# Generated by mksrcinfo v8
-# Sat Apr 29 15:17:41 UTC 2017
+# Sun May 7 00:20:18 UTC 2017
pkgbase = g810-led-git
pkgdesc = Linux led controller for Logitech G213, G410, G610, G810 and G910 Keyboards
- pkgver = 0.2.1
+ pkgver = 0.2.2
pkgrel = 1
url = https://github.com/MatMoul/g810-led
install = g810-led-git.install
- arch = i686
- arch = x86_64
+ arch = any
license = GPL3
makedepends = git
makedepends = gcc
makedepends = make
depends = hidapi
- optdepends = libusb: old implementation, use only if you have problem with hidapi
- provides = g213-led=0.2.1
- provides = g410-led=0.2.1
- provides = g610-led=0.2.1
- provides = g810-led=0.2.1
- provides = g910-led=0.2.1
+ optdepends = libusb: old implementation, for developpers
+ provides = g213-led=0.2.2
+ provides = g410-led=0.2.2
+ provides = g610-led=0.2.2
+ provides = g810-led=0.2.2
+ provides = g910-led=0.2.2
options = !emptydirs
backup = etc/g810-led/profile
backup = etc/g810-led/reboot
+ backup = etc/udev/rules.d/g810-led.rules
source = git://github.com/MatMoul/g810-led.git
md5sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index 7d2027d0a85..b39caa94971 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,18 +3,18 @@
pkgname=g810-led-git
_appname=g810-led
_gitname=g810-led
-pkgver=0.2.1
+pkgver=0.2.2
pkgrel=1
pkgdesc="Linux led controller for Logitech G213, G410, G610, G810 and G910 Keyboards"
-arch=('i686' 'x86_64')
+arch=('any')
url="https://github.com/MatMoul/g810-led"
license=('GPL3')
depends=('hidapi')
makedepends=('git' 'gcc' 'make')
-optdepends=('libusb: old implementation, use only if you have problem with hidapi')
+optdepends=('libusb: old implementation, for developpers')
install=${pkgname}.install
provides=("g213-led=${pkgver}" "g410-led=${pkgver}" "g610-led=${pkgver}" "g810-led=${pkgver}" "g910-led=${pkgver}")
-backup=("etc/${_appname}/profile" "etc/${_appname}/reboot")
+backup=("etc/${_appname}/profile" "etc/${_appname}/reboot" "etc/udev/rules.d/${_appname}.rules")
options=(!emptydirs)
source=("git://github.com/MatMoul/${_appname}.git")
md5sums=('SKIP')
@@ -23,10 +23,10 @@ build() {
cd ${_gitname}
# build with hidapi :
- make
+ make bin
# build with libusb :
- # make LIB=libusb
+ # make bin LIB=libusb
}
package() {
diff --git a/g810-led-git.install b/g810-led-git.install
index 92e0dcaf550..347317cfd69 100644
--- a/g810-led-git.install
+++ b/g810-led-git.install
@@ -5,10 +5,13 @@ pre_install() {
## arg 1: the new package version
post_install() {
- /usr/bin/g810-led -p /etc/g810-led/profile
udevadm control --reload-rules
systemctl daemon-reload
- systemctl enable g810-led-reboot
+ /usr/bin/g810-led -p /etc/g810-led/profile
+ # Don't enable service by default in ArchLinux
+ #systemctl enable g810-led-reboot
+ echo "You can enable systemd unit g810-led-reboot with the next command :"
+ echo "systemctl enable g810-led-reboot"
}
## arg 1: the new package version
@@ -21,13 +24,15 @@ pre_upgrade() {
## arg 2: the old package version
post_upgrade() {
udevadm control --reload-rules
- /usr/bin/g810-led -p /etc/g810-led/profile
systemctl daemon-reload
}
## arg 1: the old package version
pre_remove() {
+ systemctl stop g810-led-reboot
systemctl disable g810-led-reboot
+
+ # For old release, need to be removed
systemctl stop g810-led
systemctl disable g810-led
}