summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Sferrazza2017-10-05 18:04:21 -0400
committerKyle Sferrazza2017-10-05 18:05:12 -0400
commit57cd9e4e01b97e1ba3ea6aa3b37bf2e27d722c79 (patch)
tree5000fa0d4293a0a848d11c98c0b98d65b92d02cd
downloadaur-57cd9e4e01b97e1ba3ea6aa3b37bf2e27d722c79.tar.gz
initial commit
-rw-r--r--.SRCINFO11
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD19
3 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..7348e0e8ef96
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,11 @@
+pkgbase = gactions
+ pkgdesc = The command line interface that you use to test and update your app for the Google Assistant.
+ pkgver = 1
+ pkgrel = 1
+ url = https://developers.google.com/actions/tools/gactions-cli
+ arch = x86_64
+ source = gactions::https://dl.google.com/gactions/updates/bin/linux/amd64/gactions/gactions
+ md5sums = fbcf827a7c528c1cdc1ce9878b2c3366
+
+pkgname = gactions
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..bdf7d37841e5
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+*.xz
+src
+pkg
+gactions
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..dbc1d39c7920
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,19 @@
+# Maintainer: Kyle Sferrazza <kyle.sferrazza@gmail.com>
+
+pkgname=gactions
+pkgver=1
+pkgrel=1
+pkgdesc="The command line interface that you use to test and update your app for the Google Assistant."
+arch=('x86_64')
+url="https://developers.google.com/actions/tools/gactions-cli"
+source=($pkgname::https://dl.google.com/gactions/updates/bin/linux/amd64/gactions/gactions)
+md5sums=('fbcf827a7c528c1cdc1ce9878b2c3366')
+
+build() {
+ chmod +x $pkgname
+}
+
+package() {
+ mkdir -p $pkgdir/usr/bin
+ install -m 0755 $pkgname $pkgdir/usr/bin/$pkgname
+}