summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorGiovanni Santini2015-07-26 20:14:35 +0000
committerGiovanni Santini2015-07-26 20:14:35 +0000
commit8d7bf5fd45836ed4fda596790f9fe5f827a1a212 (patch)
tree366304a09f37c3a9aec1e24cef58fd9f63dde01c
downloadaur-8d7bf5fd45836ed4fda596790f9fe5f827a1a212.tar.gz
Initial AUR release
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD30
-rw-r--r--gadget-deadbeef-legacy-dhcp.install6
-rw-r--r--gadget-deadbeef-legacy-dhcp.modules-load2
-rw-r--r--gadget-deadbeef-legacy-dhcp.network7
5 files changed, 62 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a61984ffe1c0
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = gadget-deadbeef-legacy-dhcp
+ pkgdesc = Allow connection through USB (via 'legacy' module 'g_ether') - DHCP setup
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/WarheadsSE/PKGs/blob/master/gadget-deadbeef/
+ install = gadget-deadbeef-legacy-dhcp.install
+ arch = any
+ license = GPL2
+ conflicts = gadget-deadbeef
+ conflicts = gadget-deadbeef-dhcp
+ source = gadget-deadbeef-legacy-dhcp.modules-load
+ source = gadget-deadbeef-legacy-dhcp.network
+ md5sums = 690fbeec1f918177a869bd04e358c268
+ md5sums = 019b112ca41642b14931dc921c67fc88
+
+pkgname = gadget-deadbeef-legacy-dhcp
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..2f9e7150e00c
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Giovanni 'ItachiSan' Santini <giovannisantini93@yahoo.it>
+# Based on the awesome WarheadsSE PKGBUILD: https://github.com/WarheadsSE/PKGs/blob/master/gadget-deadbeef/
+#contributor: Jason Plum <jplum@archlinuarm.org>
+pkgname=gadget-deadbeef-legacy-dhcp
+_pkgname=gadget-deadbeef # The original package
+pkgver=0.1
+pkgrel=1
+pkgdesc="Allow connection through USB (via 'legacy' module 'g_ether') - DHCP setup"
+arch=('any')
+url=https://github.com/WarheadsSE/PKGs/blob/master/gadget-deadbeef/
+license=('GPL2')
+source=("$pkgname.modules-load"
+ "$pkgname.network")
+md5sums=('690fbeec1f918177a869bd04e358c268'
+ '019b112ca41642b14931dc921c67fc88')
+install=${pkgname}.install
+
+# It conflicts with the original package
+provide=($_pkgname)
+conflicts=(
+ $_pkgname
+ ${_pkgname}-dhcp
+ )
+
+package() {
+ install -Dm644 ${srcdir}/${pkgname}.modules-load \
+ ${pkgdir}/etc/modules-load.d/${_pkgname}.conf
+ install -Dm644 ${srcdir}/${pkgname}.network \
+ ${pkgdir}/etc/systemd/network/${_pkgname}.network
+}
diff --git a/gadget-deadbeef-legacy-dhcp.install b/gadget-deadbeef-legacy-dhcp.install
new file mode 100644
index 000000000000..a1baf1a9975c
--- /dev/null
+++ b/gadget-deadbeef-legacy-dhcp.install
@@ -0,0 +1,6 @@
+
+post_install () {
+ echo ">>> to enable ethernet"
+ echo " systemctl enable systemd-networkd"
+ echo ">>> No serial support in this package, sorry"
+}
diff --git a/gadget-deadbeef-legacy-dhcp.modules-load b/gadget-deadbeef-legacy-dhcp.modules-load
new file mode 100644
index 000000000000..5290dbd18d00
--- /dev/null
+++ b/gadget-deadbeef-legacy-dhcp.modules-load
@@ -0,0 +1,2 @@
+# load the g_ether module to get ethernet (no serial, sorry)
+g_ether
diff --git a/gadget-deadbeef-legacy-dhcp.network b/gadget-deadbeef-legacy-dhcp.network
new file mode 100644
index 000000000000..a9f1a3ddc635
--- /dev/null
+++ b/gadget-deadbeef-legacy-dhcp.network
@@ -0,0 +1,7 @@
+# systemd-networkd .network profile for gadget-deadbeef
+[Match]
+Name=usb0
+#MACAddress=de:ad:be:ef:00:01
+
+[Network]
+DHCP=yes