summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorewolnux2016-07-30 18:38:05 +0200
committerewolnux2016-07-30 18:38:05 +0200
commitfb4e9c6f322b548da6e10c79dfe938fda05821e3 (patch)
treeaeafc3121f64a2851791507e518156873cd2b4c9
downloadaur-fb4e9c6f322b548da6e10c79dfe938fda05821e3.tar.gz
Initial import
-rw-r--r--.AURINFO16
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
3 files changed, 68 insertions, 0 deletions
diff --git a/.AURINFO b/.AURINFO
new file mode 100644
index 000000000000..7f371e5351fa
--- /dev/null
+++ b/.AURINFO
@@ -0,0 +1,16 @@
+pkgbase = gadmin-rsync
+ pkgdesc = An easy to use GTK+ frontend for the rsync backup client and server.
+ pkgver = 0.1.9
+ pkgrel = 3
+ url = http://dalalven.dtdns.net/linux/gadmintools-webpage/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk2
+ depends = rsync
+ depends = openssh
+ optdepends = gksu: for running from menu
+ source = http://dalalven.dtdns.net/linux/gadmin-rsync/gadmin-rsync-0.1.9.tar.gz
+ options = !emptydirs
+
+pkgname = gadmin-rsync
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..5c1dc4d2059c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+# Generated by mksrcinfo v8
+# Sat Jul 30 16:36:09 UTC 2016
+pkgbase = gadmin-rsync
+ pkgdesc = An easy to use GTK+ frontend for the rsync backup client and server.
+ pkgver = 0.1.9
+ pkgrel = 3
+ url = http://dalalven.dtdns.net/linux/gadmintools-webpage/
+ arch = i686
+ arch = x86_64
+ license = GPL
+ depends = gtk2
+ depends = rsync
+ depends = openssh
+ optdepends = gksu: for running from menu
+ options = !emptydirs
+ source = http://dalalven.dtdns.net/linux/gadmin-rsync/gadmin-rsync-0.1.9.tar.gz
+ md5sums = 9ea479cdeeb5a831b9df4c8cc92faa41
+
+pkgname = gadmin-rsync
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9a2b0bac9f4e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: ewolnux <thinux@gmx.fr>
+# Contributor: Xavion <Xavion (dot) 0 (at) Gmail (dot) com>
+# Contributor: sebikul <sebikul@gmail.com>
+# Contributor: aaditya <aaditya_gnulinux@zoho.com>
+
+pkgname=gadmin-rsync
+pkgver=0.1.9
+pkgrel=3
+pkgdesc="An easy to use GTK+ frontend for the rsync backup client and server."
+arch=("i686" "x86_64")
+url="http://dalalven.dtdns.net/linux/gadmintools-webpage/"
+license=("GPL")
+depends=("gtk2" "rsync" "openssh")
+optdepends=("gksu: for running from menu")
+options=(!emptydirs)
+source=(http://dalalven.dtdns.net/linux/gadmin-rsync/gadmin-rsync-0.1.9.tar.gz)
+md5sums=('9ea479cdeeb5a831b9df4c8cc92faa41')
+
+build() {
+ cd $srcdir/$pkgname-$pkgver
+ ./configure --prefix=/usr --sysconfdir=/etc --localstatedir=/var --sbindir=/usr/bin
+ make || return 1
+}
+
+package() {
+ cd $srcdir/$pkgname-$pkgver
+ make DESTDIR=$pkgdir install
+ # Use gksu in desktop file
+ sed -i 's/Exec=gadmin-rsync/Exec=gksu gadmin-rsync/' desktop/$pkgname.desktop
+ install -D -m755 desktop/$pkgname.desktop $pkgdir/usr/share/applications/$pkgname.desktop
+ install -Dm644 COPYING $pkgdir/usr/share/licenses/$pkgname/LICENCE
+}