summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2024-03-12 08:48:54 +0100
committerlangurmonkey2024-03-12 08:48:54 +0100
commit08dd6ca935dc11af6d9976913a32dbb32992fbe4 (patch)
treecac8cc31c8d00394c7b6fd54a6a176bc60f43239
parent3c451b4311761860063c5ef573903a579e3d7677 (diff)
downloadaur-08dd6ca935dc11af6d9976913a32dbb32992fbe4.tar.gz
Version 3.6.0.
-rw-r--r--.SRCINFO10
-rw-r--r--PKGBUILD10
-rw-r--r--releasenotes.txt27
3 files changed, 34 insertions, 13 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4e0348b4967a..48eeeed1166d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.5.9
- pkgrel = 2
+ pkgver = 3.6.0
+ pkgrel = 1
epoch = 3
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.9-2.422e5e11c/gaiasky-3.5.9-2.422e5e11c.tar.gz
- md5sums = daacddf9a0cb777e3cc549ddf66ff0af
- sha256sums = 9bf4bc9620b5b7ffda51ad6973e714cc7f3722007cdee05450b9b9d8d6607f30
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.6.0.afdd9547d/gaiasky-3.6.0.afdd9547d.tar.gz
+ md5sums = 43c86508a144c2250fb2a4e63435a1a3
+ sha256sums = db4029a782ac3c2e25eb4c54913a9f6753c2495c35c9dd08d900c4b7abf0249c
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 0994d635342c..0ea1a5bce6ac 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.5.9
-pkgrel=2
+pkgver=3.6.0
+pkgrel=1
epoch=3
-versionstr=3.5.9-2.422e5e11c
+versionstr=3.6.0.afdd9547d
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -22,8 +22,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${versionstr//_/-}/$pkgname-${versionstr//_/-}.tar.gz")
noextract=()
-md5sums=("daacddf9a0cb777e3cc549ddf66ff0af")
-sha256sums=("9bf4bc9620b5b7ffda51ad6973e714cc7f3722007cdee05450b9b9d8d6607f30")
+md5sums=("43c86508a144c2250fb2a4e63435a1a3")
+sha256sums=("db4029a782ac3c2e25eb4c54913a9f6753c2495c35c9dd08d900c4b7abf0249c")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index 68cc0bba8817..f46f27f706f1 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,7 +1,28 @@
-# Gaia Sky 3.5.9-2
+# Gaia Sky 3.6.0
+
+## Features
+- add support for OptFlowCam (Piotrowski 2024) method to convert keyframes into camera path files. Gaia Sky calls the local python3 interpreter to process the keyframe files, so a local python3 installation (with numpy) needs to be in place for it to work.
+- add support for B-splines, additionally to Catmull-Rom splines, as a method for interpolating positions between keyframes.
+- reorganize keyframes window layout for better use of space.
+- add different durations for the transitions in position and orientation in the API call.
+- add smooth interpolation methods to `cameraTransition()` calls. The new methods can use either a logistic sigmoid or a logit function. Smoothing factor is configurable via a parameter.
+- add 'textureAttribute' to particle sets, so that textures are selected with respect to the value of an attribute.
+- use local dataset descriptors to construct catalog infos, when they are not explicitly set.
+- enable local data information in the '+ info' window. This displays the local data on an object. In particle and star groups, the extra attributes are also offered.
+- enable extra arguments of type string for star and particle sets.
+- rename 'star systems' group to 'exoplanets \& extrasolar systems'. Add icons to group title in dataset manager.
+- add support for multiple key sets bound to actions in hotkey tooltip.
+- keyframes and camera path file saving no longer overwrites existing files. Instead, it generates a new unique file name based on the given one.
+- support comma- as well as whitespace-separated values for camera and keyframes files. Default to comma-separated values for writing.
+- add API call to get the window coordinates of an object, in pixels.
+- add API calls to do camera transitions only in position and orientation.
+- add time transition API call and test script.
## Bug Fixes
-- individual object visibility API calls, and generic model alpha interpolation.
+- check leap years in date dialog.
+- prevent NaNs in some camera operations.
+- clean up test scripts a bit.
+- `startRecordingCameraPath(String filename)` does not use the filename correctly.
## Build System
-- only add natives for the specific target platform in built packages.
+- update dependency library versions.