summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2021-02-25 15:08:41 +0100
committerlangurmonkey2021-02-25 15:08:41 +0100
commit2233024033a47db4897a10f0b5bfe56e04eb30ef (patch)
tree952e88a3a0ade699bc2f1e33efa33fa2eedf6b09
parentd3c46413257a7f4f0d43d65706a27333359517da (diff)
downloadaur-2233024033a47db4897a10f0b5bfe56e04eb30ef.tar.gz
Version 3.0.3
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md45
-rw-r--r--PKGBUILD6
3 files changed, 52 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index a91964e98b49..3532377d1007 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Interactive 3D Universe software focused on ESA's Gaia mission
- pkgver = 3.0.2.9bd17f001
+ pkgver = 3.0.3.39da1974c
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,9 +10,9 @@ pkgbase = gaiasky
license = MPL
depends = jre11-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.0.2.9bd17f001/gaiasky-3.0.2.9bd17f001.tar.gz
- md5sums = 325bb8d20b624425d4adae8cd6f39ab7
- sha256sums = 4907dcb0c55dcfb257b60b972350f7b64a11d8712a796702e8be70468d4b69c2
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.0.3.39da1974c/gaiasky-3.0.3.39da1974c.tar.gz
+ md5sums = 047fc6014f7c96dca414b3ae50ba2c1f
+ sha256sums = 8194976826f86e3d27eb8f5ef0a0f60e4d795675698f9f4ddf591d7d7b7f205f
pkgname = gaiasky
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 6c30eb604f8b..430eca5ea757 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,3 +1,48 @@
+<a name="3.0.3"></a>
+## [3.0.3](https://gitlab.com/langurmonkey/gaiasky/tree/3.0.2) (2021-02-25)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/3.0.2...3.0.3)
+
+### Bug Fixes
+- controller image fetch crash
+- getDistanceTo() with star group object, goToObject() with no angle
+- setSimulationTime() crash
+- move wikiname to celestial body, remove unused parameters, prepare star to be loaded directly
+- use proper values for depth test
+- post-process bugs (sorting, etc.)
+- check the wrong catalog type 'catalog-lod'
+- use local descriptors when server descriptor fails to recognize a catalog
+- button sizes adapt to content (fixes [#353](https://gitlab.com/langurmonkey/gaiasky/issues/353)) [#353](https://gitlab.com/langurmonkey/gaiasky/issues/353)
+- bug introduced in 40b99a2 - star cores not applied alpha - fixes [#352](https://gitlab.com/langurmonkey/gaiasky/issues/352) [#352](https://gitlab.com/langurmonkey/gaiasky/issues/352)
+- move temp folder into data folder - partially fixes [#350](https://gitlab.com/langurmonkey/gaiasky/issues/350) [#350](https://gitlab.com/langurmonkey/gaiasky/issues/350)
+- local catalog numbers work when no internet connection available
+- update jamepad and gdx-controllers versions due to macOS crash
+
+### Build System
+- exclude appimage files from install media
+- remove branding from installer strings
+- move to gdx-controllers 2.1.0, macos tests pending
+- genearte md5 and sha256 of appimage package
+- add appimage build
+- update docs repository pointer
+- update bundled jre version to 15.0.2
+- complete move to Shenandonah GC
+- use Shenandonah GC instead of G1, minor fixes
+- upgrade to libgdx 1.9.14
+
+### Features
+- improvements to catalog generation (hashmap to treemap, rename params, accept multiple string ids per column, etc.)
+- add search suggestions to search dialog - fixes [#351](https://gitlab.com/langurmonkey/gaiasky/issues/351) [#351](https://gitlab.com/langurmonkey/gaiasky/issues/351)
+- remember 'show hidden' preference in file chooser
+
+### Performance Improvements
+- remove runtime limiting magnitude
+
+### Style
+- cosmetic changes to octree generator
+- renamed some variables, add some extra code comments
+- tweak some parameters in star renderer
+
+
<a name="3.0.2"></a>
## [3.0.2](https://gitlab.com/langurmonkey/gaiasky/tree/3.0.1) (2021-01-21)
[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/3.0.1...3.0.2)
diff --git a/PKGBUILD b/PKGBUILD
index ab31739940d1..0f362921100a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.0.2.9bd17f001
+pkgver=3.0.3.39da1974c
pkgrel=1
epoch=2
pkgdesc="Interactive 3D Universe software focused on ESA's Gaia mission"
@@ -21,8 +21,8 @@ install=gaiasky.install
changelog=CHANGELOG.md
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("325bb8d20b624425d4adae8cd6f39ab7")
-sha256sums=("4907dcb0c55dcfb257b60b972350f7b64a11d8712a796702e8be70468d4b69c2")
+md5sums=("047fc6014f7c96dca414b3ae50ba2c1f")
+sha256sums=("8194976826f86e3d27eb8f5ef0a0f60e4d795675698f9f4ddf591d7d7b7f205f")
validpgpkeys=()
prepare() {