summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2022-12-13 13:36:18 +0100
committerlangurmonkey2022-12-13 13:36:18 +0100
commit2b2c80e8730b5bf290177b748982a63514fe439a (patch)
tree19b69718e9a59439878e673dff1f8016d9956b41
parent1db268b042fcecd020181bac71aff2cd897e4d93 (diff)
downloadaur-2b2c80e8730b5bf290177b748982a63514fe439a.tar.gz
Version 3.3.1
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--releasenotes.txt151
3 files changed, 45 insertions, 120 deletions
diff --git a/.SRCINFO b/.SRCINFO
index fb293bd872e4..1e8837909308 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.3.0.aca9fadc2
+ pkgver = 3.3.1.d6f853125
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = jre-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.3.0.aca9fadc2/gaiasky-3.3.0.aca9fadc2.tar.gz
- md5sums = b350cfdeac5b45f6fe9be3bcf26bd688
- sha256sums = 0c0b0c2d06d190a183eec4e297e2922917998a9ec19e7fcde94ce1485171e736
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.3.1.d6f853125/gaiasky-3.3.1.d6f853125.tar.gz
+ md5sums = 2d4b1033643e2088254018a3ce636a53
+ sha256sums = fc1ffef9eea500dd9feafbc8e67c6c83648987ce1f9a31903c34bbb70cbfa137
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 39a8d9b4b863..635a9299c1ab 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.3.0.aca9fadc2
+pkgver=3.3.1.d6f853125
pkgrel=1
epoch=2
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
@@ -21,8 +21,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("b350cfdeac5b45f6fe9be3bcf26bd688")
-sha256sums=("0c0b0c2d06d190a183eec4e297e2922917998a9ec19e7fcde94ce1485171e736")
+md5sums=("2d4b1033643e2088254018a3ce636a53")
+sha256sums=("fc1ffef9eea500dd9feafbc8e67c6c83648987ce1f9a31903c34bbb70cbfa137")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index 32560d9bdf3b..3da95affc265 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,121 +1,46 @@
-# Gaia Sky 3.3.0
-
-## Code Refactoring
-- the largest change in this version by far is the complete refactoring of the internal model. We have moved from an object-oriented inheritance hierarchy to an entity component system (ECS).
-- move render lists to Java collections.
-- flatten object hierarchy by removing some classes, merging their functionality upwards.
-- abstract attitude loading system, remove Gaia class, use heliotropic satellite.
-- add `I18nFormatter` to reformat i18n files.
-- remove old date formatting infrastructure (desktop, html, mobile) in favor of a direct approach.
-- remove useless number formatting infrastructure.
+# Gaia Sky 3.3.1
## Features
-- enable minimizing focus info interface.
-- adjust debug interface layout.
-- key bindings file versioning. If the key bindings file starts with the line `#v[version]`, that version is compared to the default one and overwritten when necessary. That makes updating key bindings much easier.
-- recompute UI scale at startup when starting with default config file.
-- add back-buffer scale API call.
-- add back-buffer scale controls to UI.
-- add repository to `-v` information.
-- rename fisheye post-processing effect and shader to reprojection. Update cubemap projection from fisheye to azimuthal equidistant.
-- add shaders for Lambert equal-area, orthographic and stereographic projections.
-- add re-projection GUI drop-down in preferences window. Add `setReprojectionMode()` scripting API call.
-- include orthographic projection in panorama mode. Includes both hemispheres on the screen, side by side. Can be cycled through with `ctrl`+`shift`+`k`.
-- Include "orthosphere" panorama mode -- orthospherical projection with both hemispheres overlaid to give a view of the celestial sphere from the outside.
-- add new camera mode, orthosphere view, which includes the regular and the cross-eye orthosphere projections.
-- add cross-eye view of the orthographic projection of the celestial sphere
-- add support for KTX and ZKTX textures.
-- change from thread to scheduled task to remove the mode change info pop-up.
-- add mode change pop-up setting to enable or disable showing a pop-up with information when changing modes (panorama, planetarium, stereo, etc.).
-- add GUI button to exit stereo mode.
-- add new object type, 'cosmic locations', to mark the positions of interesting areas or regions.
-- enable scene lights for shape objects when static light is off.
-- new model attribute 'blendMode', which defaults to 'alpha' but can also be set to 'additive' to control the object blending.
-- enable gamepad operation in welcome GUI.
-- add zero-point to gamepad configuration.
-- introduce gamepad support for spacecraft mode, remove 'Gaia scene' camera mode (can be mimicked with focus mode), refactor input controllers, fix default SDL gamepad mappings file.
-- add several new functions to enable setting the camera state from scripts.
-- add time zone to settings. Time zone can be either UTC, or the system default. Update date dialog year limits, fix time component layout.
-- adapt raymarching effects work with ECS model.
-- light glow effect now works with ECS model.
-- expose post-processor properties as settings in configuration file.
-- save configuration when closing dataset manager window.
-- add popup notice when opening the keyframes window if component 'others' is not visible.
-- add full screen bit depth and refresh rate to fully qualify selected full screen modes.
-- improve layout and information of crash window.
-- add notice when there are no datasets.
+- migration to new dataset structure, add data location cleaner utility at startup.
+- support gzipped data descriptor files.
+- re-balance the weights for every axis-mapped action in main gamepad listener, resulting in a much smoother navigation with game controllers and joysticks.
+- add sRGB color space support in preparation for migration to OpenXR. Activate it with the key `graphics::useSRGB` in the configuration file.
+- add support for images in tip generator, include gamepad input images.
+- complete Spanish translation to 100%.
+- add star visual settings to gamepad GUI.
+- increase global font size and UI spacing.
+- generic controller support in all UI windows.
+- add preliminary keyboard support for navigating UI menus and windows.
+- add some extra room between dataset types to improve readability.
+- add star glow factor control and API call to fine tune the amount of light irradiated by stars close to the camera.
+- add screen mode button at the top-right of the welcome GUI.
+- add gamepad support in dataset manager window.
+- remove music component from controls window.
+- activate lazy shader loading for all but the basic shader versions (SSR, motion blur, relativistic mode, gravitational waves).
+- introduce index of refraction for the celestial sphere when orthosphere view is on. Included as a slider in the experimental section of the GUI.
## Bug Fixes
-- disable tessellation on macOS by default.
-- bug in latest version determination in version checker.
-- remove unnecessary spacing in layout of focus info interface.
-- trajectory size determination algorithm not accurate, breaks when adding points close to the origin.
-- add model size attribute to compute solid angle for model objects more accurately.
-- correctly query graphics device for resolution and apply scaling.
-- toggling SSR and motion blur does not update depth state in some shaders.
-- double definitions in shader libraries.
-- render constellation boundaries as closed polygons in order to avoid artifacts.
-- index errors in keybaord in controller GUI.
-- back-buffer scale is now applied correctly (and only once), works with external view.
-- remove angle from zenith from cubemap renderer in planetarium, use shader-based solution.
-- prevent rendering titles if panorama mode is on.
-- initialize position from coordinates object during initialization phase.
-- land at location never returns. [#674](https://codeberg.org/gaiasky/gaiasky/issues/674)
-- set foucs with `FocusView` object type. [#671](https://codeberg.org/gaiasky/gaiasky/issues/671)
-- provide a correct index mapping for arbitrary attributes with string values.
-- particle size of interactively loaded point cloud datasets.
-- vertically flip UV coordinates of two-faced billboard to correct texture orientation.
-- regression in billboard group rendering. [#663](https://codeberg.org/gaiasky/gaiasky/issues/663)
-- update coordinates in invisible only when present. [#662](https://codeberg.org/gaiasky/gaiasky/issues/662)
-- prevent runtime error due to non-invertible matrix in spacecraft entity.
-- diffuse color contribution calculated incorrectly when nLights > 1 in normal shaders.
-- names in star groups can now be localized, fix focus name in panel.
-- translate strings of filters, shapes, datasets and minimap. [#403](https://codeberg.org/gaiasky/gaiasky/issues/403)
-- moon orbits are recomputed more often.
-- filters crash with instanced star renderers.
-- modal windows made not collapsible by default.
-- hotkey tooltip backgrounds.
-- jump in Pluto's orbit due to deviation between full periods.
-- highlight 'all visible' setting in quad-based star renderers.
-- frame sequence number synchronized, value updated when opening preferences.
-- use view angle instead of view angle apparent in go to object API call.
-- increase number of vertices of minimap shape renderer, fixes crash in heliosphere minimap.
-- typo in Jupiter English translation file, add meshes to data descriptor file.
-- break link in dataset manager if too long.
-- make sure direction and up vectors are orthogonal in camera transition call.
-- increase size star point buffer when needed.
-- null-check satellite attitude before getting quaternion. [#402](https://codeberg.org/gaiasky/gaiasky/issues/402)
-- empty tips may crash Gaia Sky at startup.
-- 'add scene graph object' event missing source object. [#400](https://codeberg.org/gaiasky/gaiasky/issues/400)
-- remove phase of pi radians in default-model orbital elements.
-- regression with libgdx 1.11.0 that caused vertical tooltips.
-- null-check settings in crash reporter.
-- workaround for libgdx backslash bug in asset manager. Fixes [#398](https://codeberg.org/gaiasky/gaiasky/issues/398)
-- hide system cursor correctly with GLFW until libgdx 1.10.1 is released.
-- use minimum width for debug interface to prevent dynamic resizing depending on content.
+- backup/restore perspective camera state before/after rendering off-screen frames and screenshots to avoid rendering artifacts whenever any of the cubemap-based modes (planetarium, panorama) is on.
+- context menu crashes when no object is hit. Fixes [#694](https://codeberg.org/gaiasky/gaiasky/issues/694).
+- add 'gamepads detected' notification text to I18N files.
+- screen resizing sets internal resolution state and is persisted on restart. Adjust automatic UI scaling algorithm.
+- apply 'angle from zenith' in planetarium mode as camera rotation instead of as an effect parameter to enable 5-side optimization when aperture <= 180.
+- reimplement automatic tone mapping algorithm and manager.
+- refocusing on a star set does not always work.
+- camera speed API call not mapping values correctly.
+- add 'compiling shaders' message during loading process.
+- bookmarks to stars not selecting the right objects.
+- affine transformations applied correctly to mesh objects.
## Build System
-- move repository from Gitlab to Codeberg.
-- update Gitlab references to Codeberg, when possible. Use Codeberg API for version checking.
-- update changelog template repository to Codeberg.
-- remove Gitlab CI file.
-- extract documentation to own project, which is no longer a submodule.
-- upgrade to libgdx 1.11.0 and LWJGL 3.3.1 --- this adds M1 Mac support.
-- add aarch64 JRE to macOS bundle for M1 machines. Move to macOS single bundle archive from deprecated old single bundle.
-- force safe graphics mode on M1 macOS.
-- use default GC (G1) in favor of Shenandoah (only LTS).
-- upgrade gradle wrapper version to 7.5.1.
+- changelog creation script now does not produce a full change log for the whole history of the project anymore. It now gets the tag or tag range as input and the maintainer is supposed to update the `CHANGELOG.md` file manually. The changes are provided since a few releases ago in the release notes file.
-## Documentation
-- update repository pointers to Codeberg.
-- update in-app mastodon reference from cat to social, as it's in English.
-- remove twitter link, add mastodon hashtag.
-- improve comments on color maps GLSL code.
-- add new panorama orthographic projection to API Javadocs.
-- remove wrong license (leftover from old copy-paste) in fisheye fragment shader code.
-- add contributor.
-- typos and so.
+## Code Refactoring
+- move ambient light watcher from main Gaia Sky class to own inner class, remove unused event.
+- guard GLSL libraries with `#ifndef`/`#define` preprocessor statements to prevent double definitions.
+- change screenshots system from poll to reactive.
+- rename controller GUI to gamepad GUI.
+- move content of 'Gaia' tab to 'Data' tab in preferences window.
-## Style
-- mend variable names in about window to follow camel case.
-- fix linter stylistic warnings in GUI and interfaces.
+## Documentation
+- improve contributing guidelines for translations.