summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2021-09-22 11:36:19 +0200
committerlangurmonkey2021-09-22 11:36:19 +0200
commit4d25f610c45dae867bae6d126b2a741fc889c0e5 (patch)
tree286b0667866b1469c5dd9662a867c55f640f9886
parent9004561dde3b9ccdb2ae3f42ce05284bfae74c6f (diff)
downloadaur-4d25f610c45dae867bae6d126b2a741fc889c0e5.tar.gz
Version 3.1.5
-rw-r--r--.SRCINFO8
-rw-r--r--CHANGELOG.md42
-rw-r--r--PKGBUILD6
3 files changed, 48 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index e53c5359a702..f3c1079e8082 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.1.4.6ba45ec21
+ pkgver = 3.1.5.ee324a4e6
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = jre-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.1.4.6ba45ec21/gaiasky-3.1.4.6ba45ec21.tar.gz
- md5sums = 359b5f30cf3b1bab41ce375455e7056e
- sha256sums = 08d2e78f27b09256ff92d997f4d9f0fa61de2f19be6e751d77b965458d9601e2
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.1.5.ee324a4e6/gaiasky-3.1.5.ee324a4e6.tar.gz
+ md5sums = aa0a932bd7399e359c4483d90c6a2450
+ sha256sums = 080092dea99c285347bffd1543648d5fed447b09c000bac81143396ebce10aec
pkgname = gaiasky
diff --git a/CHANGELOG.md b/CHANGELOG.md
index 967057a75c95..3cfaebb2bddf 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,6 +1,46 @@
<a name="unreleased"></a>
## [Unreleased](https://gitlab.com/langurmonkey/gaiasky/tree/master)
-[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/3.1.4...HEAD)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/3.1.5...HEAD)
+
+
+<a name="3.1.5"></a>
+## [3.1.5](https://gitlab.com/langurmonkey/gaiasky/tree/3.1.4) (2021-09-22)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/3.1.4...3.1.5)
+
+### Bug Fixes
+- pointer guides use wrong shader program and render incorrectly
+- concurrent camera state modification issue resulting in camera jumps and skips when capturing still frames -- regression introduced with arbitrary precision module in `3.1.0`
+- order of repositories in build file
+- frame output target FPS not persisted correctly
+- add notice when location log is empty
+- individual visibility in asteroids and other orbital elements-based objects
+- preferences dialog catalog selection tab
+- manipulate visibility of stars with proper names
+- bug in `goToObject()` camera direction
+- star offset in star groups [#375](https://gitlab.com/langurmonkey/gaiasky/issues/375)
+- some tweaks to VR mode, fix crashes
+
+### Build System
+- remove gradle plugin portal from repositories
+
+### Code Refactoring
+- API change: `unparkRunnable()` is now deprecated in favour of `removeRunnable()`
+- remove all statics from global resources
+- encapsulate global resources
+- remove generics from IAttribute, remove static model from star groups
+- multiple internal initialization changes
+
+### Documentation
+- update URLs in file
+
+### Features
+- change value of screenshot mode from 'redraw' to 'advanced' both in the API call `setFrameOutputMode()` and in the config file
+- improve welcome screen button icons
+- add a filter textbox to per-object visibility window
+- add collapsible groups to catalog selection window
+- add mouse-over behavior for most UI elements
+- add hover over feature to buttons in skins
+- new YAML based configuration system to replace java properties file
<a name="3.1.4"></a>
diff --git a/PKGBUILD b/PKGBUILD
index 94ea87997d3f..4c04dbab7130 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.1.4.6ba45ec21
+pkgver=3.1.5.ee324a4e6
pkgrel=1
epoch=2
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
@@ -21,8 +21,8 @@ install=gaiasky.install
changelog=CHANGELOG.md
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("359b5f30cf3b1bab41ce375455e7056e")
-sha256sums=("08d2e78f27b09256ff92d997f4d9f0fa61de2f19be6e751d77b965458d9601e2")
+md5sums=("aa0a932bd7399e359c4483d90c6a2450")
+sha256sums=("080092dea99c285347bffd1543648d5fed447b09c000bac81143396ebce10aec")
validpgpkeys=()
prepare() {