summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2023-10-24 09:23:21 +0200
committerlangurmonkey2023-10-24 09:23:21 +0200
commit4d4424649ad78098a21744e4defc1a27f39febc3 (patch)
treea100e2f593c4e25ae114701f41a901e6bbe2ed12
parentf81991d107b114ff3c0940041a1e4be624d7daa8 (diff)
downloadaur-4d4424649ad78098a21744e4defc1a27f39febc3.tar.gz
Version 3.5.6-2.
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD8
-rw-r--r--releasenotes.txt34
3 files changed, 13 insertions, 37 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ca53fdd70893..cd8a869e917b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
pkgver = 3.5.6
- pkgrel = 1
+ pkgrel = 2
epoch = 3
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
install = gaiasky.install
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = java-runtime
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.6.8bb71564a/gaiasky-3.5.6.8bb71564a.tar.gz
- md5sums = 32987184b9613e7027a14d4a665da1c2
- sha256sums = 438b4a94f4db09d49c49a481e55b977432d1003d99a8bb56155554498041ebf5
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.5.6-2.b9300ce43/gaiasky-3.5.6-2.b9300ce43.tar.gz
+ md5sums = be18d2605285e1648ce53921a6d2bd62
+ sha256sums = 423402b08209fad4c0d61c739e4fd048adcf2b0315ec6856dc99419adc028678
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index efa56f51ee33..466c43166572 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,9 +1,9 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
pkgver=3.5.6
-pkgrel=1
+pkgrel=2
epoch=3
-versionstr=3.5.6.8bb71564a
+versionstr=3.5.6-2.b9300ce43
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
arch=(x86_64)
url="https://zah.uni-heidelberg.de/gaia/outreach/gaiasky"
@@ -22,8 +22,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${versionstr//_/-}/$pkgname-${versionstr//_/-}.tar.gz")
noextract=()
-md5sums=("32987184b9613e7027a14d4a665da1c2")
-sha256sums=("438b4a94f4db09d49c49a481e55b977432d1003d99a8bb56155554498041ebf5")
+md5sums=("be18d2605285e1648ce53921a6d2bd62")
+sha256sums=("423402b08209fad4c0d61c739e4fd048adcf2b0315ec6856dc99419adc028678")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index 1733ba140926..1df15ee1a450 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,31 +1,7 @@
-# Gaia Sky 3.5.6
-
-## Features
-- add film grain filter (disabled by default).
-- set a maximum age for `.part` download files of 6 hours.
-- improve recursive grid with travelling pulses and a noise mask.
-- add 'animate' setting to recursive grid preferences to toggle animation on and off.
-- add checkbox to control recursive grid animation.
-- add initial notice about Gaia Sky contacting the server to get the dataset updates list.
-- improve shader compilation error handling.
-- enable elevation (height) representation without tessellation in a new 'regular' mode. This is the new default mode, as tessellation is a bit to taxing on old and integrated GPUs.
-- discontinue parallax mapping elevation type; the new vertex displacement type supersedes it.
-- add full support for point lights, and use them for stars.
-- true depth-tested close-by stars, also working with light glow enabled.
+# Gaia Sky 3.5.6-2
## Bug Fixes
-- prevent creation of background blur object, as camera motion blur was disabled a few versions ago.
-- use predicted position for tracking objects.
-- 'reload defaults' button in visual settings component actually sets the default value to the elevation multiplier slider.
-- new star shader in intel GPUs.
-- mouse coordinates collision with objects when back buffer scale != 1.
-
-## Code Refactoring
-- move GLSL snippet shader chunks to own directory `assets/shader/snippet`.
-- rename shaders from 'normal' to 'pbr'.
-
-## Build System
-- set `-source` to 16 in gradle build script to enable pattern matching in instanceof.
-
-## Style
-- code style now formats Javadoc comments.
+- prevent SVT library to use `dFdx()` and `dFdy()` in vertex shaders.
+- SVT detection shader still passing lights explicitly.
+- shadow map camera direction with point lights.
+- null pointer in context menu.