summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2020-12-02 14:20:49 +0100
committerlangurmonkey2020-12-02 14:20:49 +0100
commit50f8a809c340868c662fddc38357cee6e32a4261 (patch)
treecf7f02ec98439eb3853510307d6d42b983c1c340
parentc0478c2c985360ddf52ca77d907f19f770b0ce6e (diff)
downloadaur-50f8a809c340868c662fddc38357cee6e32a4261.tar.gz
Version 3.0.0
-rw-r--r--.SRCINFO6
-rw-r--r--CHANGELOG.md117
-rw-r--r--PKGBUILD4
3 files changed, 105 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index f787d57f93d4..25fa7570a3e5 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Interactive 3D Universe software focused on ESA's Gaia mission
- pkgver = 2.3.1.b19516f2e
+ pkgver = 3.0.0.74a524ebf
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = jre11-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/2.3.1.b19516f2e/gaiasky-2.3.1.b19516f2e.tar.gz
- md5sums = e4a47ad4a04492eb581178e2c8892db8
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.0.0.74a524ebf/gaiasky-3.0.0.74a524ebf.tar.gz
+ md5sums = 6fec582a1d14e188987a4d1c67860b60
pkgname = gaiasky
diff --git a/CHANGELOG.md b/CHANGELOG.md
index b77f9bf72e19..17964207afa4 100644
--- a/CHANGELOG.md
+++ b/CHANGELOG.md
@@ -1,7 +1,100 @@
-<a name="unreleased"></a>
-## [Unreleased](https://gitlab.com/langurmonkey/gaiasky/tree/master)
-[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.3.1...HEAD)
+<a name="3.0.0"></a>
+## [3.0.0](https://gitlab.com/langurmonkey/gaiasky/tree/2.3.1) (2020-12-02)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.3.1...3.0.0)
+### Bug Fixes
+- adjust default area line width
+- star clusters visual appearance
+- min star size scaled by resolution
+- apply scale factor to milky way
+- camera group bottom buttons aligned to center
+- emulate 64-bit float with two 32-bit floats in shader to be able to extend time beyond +-5 Myr
+- controller mappings not found on first startup. Fixes [#341](https://gitlab.com/langurmonkey/gaiasky/issues/341). [#341](https://gitlab.com/langurmonkey/gaiasky/issues/341)
+- use Java2D instead of Toolkit to determine initial screen size
+- data description update
+- controller mappings looking for assets location if not found
+- manpage gen
+- smooth game camera view
+- spacecraft mode fixes
+- GUI registry check
+- add timeout to sync behavior in dataset loading
+- new default startup window size to accommodate welcome screen
+- update default data desc pointers to version 3.0.0
+- default fps limit value, aux vectors in recursive grid
+- overwrite coordinate system matrix by recursive grid
+- start some units over `XZ` plane to avoid conflicting with recursive grid
+- gaiasky script defaults back to system java installation if nothing else is found
+- octreegen empty hip x-match crash
+- points in VertsObject with wrong uniform name - incorrect location
+- do not round dialog position values
+- blue, orange and red themes crashed
+- controls scroll box resizing
+- download data window sizings, update data desc
+- regular color picker does not show dialog
+- music player actually finds audio files
+- size of keyboard shortcuts table in controls pane
+- disable background models' depth test
+- focused widgets in scroll panes capture all keyboard events
+- actually send errors to `stderr` instead of `stdout`
+- fix VR properties data pointer
+- motion blur bug producing wrong results for models
+- `touchUp` event on Link and LinkButton objects not working
+- improve logging messages in case of index name conflicts
+- update URL pointers after ARI CMS update
+- graphics quality in log messages
+
+### Build System
+- modify installer unpacking message
+- ignore release candidates in changelog, update some defaults
+- generate `sha256` in catalog-pack script
+- macOS does not query screen size due to exception
+- check OS when trying to use Linux commands
+- remove music files from release, don't use OS-dependent system for controller mappings
+- upgrade to Libgdx `1.9.12`
+- update STIL library jar
+- upgrade to Libgdx `1.9.11`
+- update version and data pointer
+
+### Code Refactoring
+- run code inspections, cleanup. Improve particle effects
+- `begin()` and `end()` substituted with `bind()`
+- remove unused or derived uniform definitions
+- use `java.utils` collections whenever possible, Libgdx buggy since `1.9.11`
+- complete font update to more modern, spacey choices
+- all regular UI fonts from Tahoma to Roboto regular
+- use `system.out` with UTF-8 encoding, improve gen scripts
+- remove ape, Gaia scan properties
+- move RenderGroup to render package for consistency
+
+### Features
+- add number of objects to download manager
+- velocity scaling allows approaching stars slowly
+- API call to set the maximum allowed time
+- add arrow caps to polylines
+- add progress bar to dataset loading, touch up some styles
+- download helper accepts local files, reorganize catalogs
+- new API call to get parameters from stars given its name or id
+- add brightness power and reload defaults to visual settings
+- improve loading tips subsystem with custom styles and arbitrary elements
+- 3D fonts can be limited in solid angle size
+- UI adjustments and tweaks
+- new welcome screen reorganizes dataset management
+- add complimentary color to inner recursive grid
+- add projection lines on reference system plane, with distances
+- first final version of recursive grid
+- new recursive grid object
+- catalog selection displayed when more than one Gaia catalog is selected
+- add wavefront converter, update gradle version
+- fix color picker
+- camera speed-from-distance function rescaling
+- first version of gamepad keyboard
+- update eDR3 catalog descriptors
+- controller UI to modify some properties using a gamepad
+- add `--debug` flag for more info
+- restructure loading GUI layout
+- improve `--version` information
+- add ASCII Gaia image to text ouptut
+- update data descriptor with new MW model
<a name="2.3.1"></a>
## [2.3.1](https://gitlab.com/langurmonkey/gaiasky/tree/2.3.0) (2020-07-08)
@@ -17,7 +110,6 @@
### Features
- hot reload of galaxy models
-
<a name="2.3.0"></a>
## [2.3.0](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.6) (2020-07-07)
[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.6...2.3.0)
@@ -188,8 +280,8 @@
<a name="2.2.5"></a>
-## [2.2.5](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.4-1) (2020-03-04)
-[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.4-1...2.2.5)
+## [2.2.5](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.4) (2020-03-04)
+[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.4...2.2.5)
### Bug Fixes
- some API calls crash when using double[]
@@ -202,6 +294,8 @@
- VRAM profiling crash for AMDGPUs [#326](https://gitlab.com/langurmonkey/gaiasky/issues/326)
- adapt star brightness in cubemap modes [#318](https://gitlab.com/langurmonkey/gaiasky/issues/318)
- reload default configuration file crash
+- build script typo
+- ambient light slider
### Build System
- fix versions of sdl2gdx and jsamp, refactor VMemInfo
@@ -239,15 +333,6 @@ API call setStarSize() now gets the star point size in
pixels instead of a normalized value between 0 and 100.
-<a name="2.2.4-1"></a>
-## [2.2.4-1](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.4) (2020-01-23)
-[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.4...2.2.4-1)
-
-### Bug Fixes
-- build script typo
-- ambient light slider
-
-
<a name="2.2.4"></a>
## [2.2.4](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.3) (2020-01-22)
[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.3...2.2.4)
@@ -327,7 +412,6 @@ pixels instead of a normalized value between 0 and 100.
### Performance Improvements
- improve performance of api call method/parameter matching
-
<a name="2.2.3"></a>
## [2.2.3](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.2) (2019-11-05)
[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.2...2.2.3)
@@ -346,7 +430,6 @@ pixels instead of a normalized value between 0 and 100.
- add cancel download button to manager
- add support for release notes in download manager
-
<a name="2.2.2"></a>
## [2.2.2](https://gitlab.com/langurmonkey/gaiasky/tree/2.2.1) (2019-10-31)
[Full changelog](https://gitlab.com/langurmonkey/gaiasky/compare/2.2.1...2.2.2)
diff --git a/PKGBUILD b/PKGBUILD
index 54bd320348af..1b5efabc898f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=2.3.1.b19516f2e
+pkgver=3.0.0.74a524ebf
pkgrel=1
epoch=2
pkgdesc="Interactive 3D Universe software focused on ESA's Gaia mission"
@@ -21,7 +21,7 @@ install=gaiasky.install
changelog=CHANGELOG.md
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("e4a47ad4a04492eb581178e2c8892db8")
+md5sums=("6fec582a1d14e188987a4d1c67860b60")
validpgpkeys=()
prepare() {