summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorlangurmonkey2022-12-18 08:10:00 +0100
committerlangurmonkey2022-12-18 08:10:00 +0100
commit51ec300612f2988eaa4f6f8bc4dc36a8913d6a4e (patch)
tree63f119017b30a212a38874a81d1878887e75d4c7
parent2b2c80e8730b5bf290177b748982a63514fe439a (diff)
downloadaur-51ec300612f2988eaa4f6f8bc4dc36a8913d6a4e.tar.gz
Version 3.3.2
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD6
-rw-r--r--releasenotes.txt48
3 files changed, 12 insertions, 50 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 1e8837909308..2d2c9f464215 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = gaiasky
pkgdesc = Open source 3D universe simulator for desktop and VR with support for more than a billion objects
- pkgver = 3.3.1.d6f853125
+ pkgver = 3.3.2.b5202d46f
pkgrel = 1
epoch = 2
url = https://zah.uni-heidelberg.de/gaia/outreach/gaiasky
@@ -10,8 +10,8 @@ pkgbase = gaiasky
license = MPL
depends = jre-openjdk
depends = xorg-xrandr
- source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.3.1.d6f853125/gaiasky-3.3.1.d6f853125.tar.gz
- md5sums = 2d4b1033643e2088254018a3ce636a53
- sha256sums = fc1ffef9eea500dd9feafbc8e67c6c83648987ce1f9a31903c34bbb70cbfa137
+ source = http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/3.3.2.b5202d46f/gaiasky-3.3.2.b5202d46f.tar.gz
+ md5sums = 4a3c78a7f8022f175fb80087bebb4438
+ sha256sums = 3f7cb0d7dca804bca868f80f1932b81b0ed0c404dd1a960be6efeccf61e59a40
pkgname = gaiasky
diff --git a/PKGBUILD b/PKGBUILD
index 635a9299c1ab..6cfff8ef802b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,6 +1,6 @@
#Maintainer: Toni Sagrista Selles <tsagrista@ari.uni-heidelberg.de>
pkgname=gaiasky
-pkgver=3.3.1.d6f853125
+pkgver=3.3.2.b5202d46f
pkgrel=1
epoch=2
pkgdesc="Open source 3D universe simulator for desktop and VR with support for more than a billion objects"
@@ -21,8 +21,8 @@ install=gaiasky.install
changelog=releasenotes.txt
source=("http://gaia.ari.uni-heidelberg.de/gaiasky/files/releases/${pkgver//_/-}/$pkgname-${pkgver//_/-}.tar.gz")
noextract=()
-md5sums=("2d4b1033643e2088254018a3ce636a53")
-sha256sums=("fc1ffef9eea500dd9feafbc8e67c6c83648987ce1f9a31903c34bbb70cbfa137")
+md5sums=("4a3c78a7f8022f175fb80087bebb4438")
+sha256sums=("3f7cb0d7dca804bca868f80f1932b81b0ed0c404dd1a960be6efeccf61e59a40")
validpgpkeys=()
prepare() {
diff --git a/releasenotes.txt b/releasenotes.txt
index 3da95affc265..6aba5c98aa22 100644
--- a/releasenotes.txt
+++ b/releasenotes.txt
@@ -1,46 +1,8 @@
-# Gaia Sky 3.3.1
-
-## Features
-- migration to new dataset structure, add data location cleaner utility at startup.
-- support gzipped data descriptor files.
-- re-balance the weights for every axis-mapped action in main gamepad listener, resulting in a much smoother navigation with game controllers and joysticks.
-- add sRGB color space support in preparation for migration to OpenXR. Activate it with the key `graphics::useSRGB` in the configuration file.
-- add support for images in tip generator, include gamepad input images.
-- complete Spanish translation to 100%.
-- add star visual settings to gamepad GUI.
-- increase global font size and UI spacing.
-- generic controller support in all UI windows.
-- add preliminary keyboard support for navigating UI menus and windows.
-- add some extra room between dataset types to improve readability.
-- add star glow factor control and API call to fine tune the amount of light irradiated by stars close to the camera.
-- add screen mode button at the top-right of the welcome GUI.
-- add gamepad support in dataset manager window.
-- remove music component from controls window.
-- activate lazy shader loading for all but the basic shader versions (SSR, motion blur, relativistic mode, gravitational waves).
-- introduce index of refraction for the celestial sphere when orthosphere view is on. Included as a slider in the experimental section of the GUI.
+# Gaia Sky 3.3.2
## Bug Fixes
-- backup/restore perspective camera state before/after rendering off-screen frames and screenshots to avoid rendering artifacts whenever any of the cubemap-based modes (planetarium, panorama) is on.
-- context menu crashes when no object is hit. Fixes [#694](https://codeberg.org/gaiasky/gaiasky/issues/694).
-- add 'gamepads detected' notification text to I18N files.
-- screen resizing sets internal resolution state and is persisted on restart. Adjust automatic UI scaling algorithm.
-- apply 'angle from zenith' in planetarium mode as camera rotation instead of as an effect parameter to enable 5-side optimization when aperture <= 180.
-- reimplement automatic tone mapping algorithm and manager.
-- refocusing on a star set does not always work.
-- camera speed API call not mapping values correctly.
-- add 'compiling shaders' message during loading process.
-- bookmarks to stars not selecting the right objects.
-- affine transformations applied correctly to mesh objects.
-
-## Build System
-- changelog creation script now does not produce a full change log for the whole history of the project anymore. It now gets the tag or tag range as input and the maintainer is supposed to update the `CHANGELOG.md` file manually. The changes are provided since a few releases ago in the release notes file.
+- stop intercepting data location in paths, implementation did not work for Windows when the original path contained '*', and it was useless anyway, as we always use fully-defined paths.
+- avoid expanding dataset file paths in dataset manager to prevent horizontal overflow.
-## Code Refactoring
-- move ambient light watcher from main Gaia Sky class to own inner class, remove unused event.
-- guard GLSL libraries with `#ifndef`/`#define` preprocessor statements to prevent double definitions.
-- change screenshots system from poll to reactive.
-- rename controller GUI to gamepad GUI.
-- move content of 'Gaia' tab to 'Data' tab in preferences window.
-
-## Documentation
-- improve contributing guidelines for translations.
+## Features
+- improve drag rotation behaviour when very close to objects.